RNS-E and SDHC that work!


Registered User
Sep 29, 2006
Reaction score
Could some of you guys recommend 32GB SDHC cards that definitely work in an RNS-E Mk2

I bought a 32gb Kingston Class 6 off amazon and it just comes up as 'Data Corrupted' - I have tried formatting it in a few machines and different OSes but still no joy

Before I waste anymore money I was hoping someone could recommend something they are using and which definitely works


Im probably wrong but I thought I read before that the total was 32GB, as in two 16GB cards, one in each slot totaling 32GB?
How old is the car mate? Not sure what year the RNS-E changed but up to a certain point only SD is compatible.
The car is an MY11 BE and the RNS-E is a retrofitted Mk2 (the one with the media button)

I am pretty sure it takes 2 x 32GB

I have seen a thread where someone has a 32gb Kingston class 4 that works so I am bit puzzled why the 32Gb Kingston Class 6 doesn't - I am wondering whether it is a fake (though I got it through amazon)
Best to use a class 10 tbh, storage options works fine, just awaiting a class 10 from another supplier to test.

Just be aware, there are allot of counterfeits out there, they are labelled as kingston, class etc, but are infact a much lesser version & not the capacity stated.

Max is 32GB per slot, not across the slots, so 64GB in total.
yes formatted as FAT32 - tried it on various platforms - Windows 7 / Win XP via Parallels Desktop on a Mac and also Windows 7 on my laptop. Going to try Win XP at work but not expecting any joy. It appears fine on the OS but just does work in the RNS-E

I bought the kingston from amazon but I had heard there are a lot of counterfeits about so going to try a class 10 from a reputable supplier.
If you hold of for few more days I may have an answer.
thats sounds like a very good idea - I will wait and see how you get on
I've used Transcend brand 32gb class 10 from Amazon uk, they work fine in two mk2 RNSEs I've tried them in, formatting them FAT32 in Windows 7 x64
Will give one of them a whirl. Managed to pick up a Kingston 32GB class 10 and that works but they aren't cheap

Similar threads