1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

VCDS Modifications

davidbir Sep 21, 2016

  1. mjcourtney

    mjcourtney Registered User

    1,692
    536
    113
    I tried activating lane assist with OBDeleven yesterday. Ended up with two errors, one for 'Adaptive Light fault' and the other for 'Side Assist Fault'. So I undid the changes and am looking into it further. If anyone has any success with enabling this on UK cars with Matrix Lights i'd be interested to know what you did as I think the coding changes upset the camera for the lights.. (I followed the coding here: http://www.audiworld.com/forums/a4-...ctive-lane-assist-all-cars-pre-sense-2907906/)
     
  2. Avatar

    snack-media
    Advertisement


  3. ScottishA4B9

    ScottishA4B9 Registered User

    3,729
    1,072
    113
    Hope it's not effected your matrix lights operation mate?

    I was looking at activating this as well and I also have the matrix lights.
     
    mjcourtney likes this.
  4. bpnike

    bpnike Registered User

    47
    9
    8

    i had the same error with side assist so i have skipped module 17 lane change assistant coding option. this option requires sensors on the side of the car and at the rear i think. it enables blind spot monitoring.

    not sure about the other error. have you done all the coding to the end and restarted the MMI? some of the errors are showing up during the coding but dissapear once everything is finished.

    also please remember that the lane assist shows up in MMI after approx 30min of switching the car off or after the MMI reset. it doesnt show up straight away after coding
     
  5. mjcourtney

    mjcourtney Registered User

    1,692
    536
    113
    Yeah I will try again and skip the module 17 coding. The adpative light fault stayed even after completing the coding and resetting the MMI. It seemed to pop up as soon as HC was activated in the first step so i'm not sure if it's related to that setting (whatever that is?!)

    All back to normal now and working correctly, as I just reversed all the coding back to stock.
     
  6. ScottishA4B9

    ScottishA4B9 Registered User

    3,729
    1,072
    113
    So for a complete coding novice like me, how hard is it?

    Also where do you get the codes from?
     
  7. mjcourtney

    mjcourtney Registered User

    1,692
    536
    113
    I was also a novice until last week when I managed to code the needle sweep and lap timer. Relatively easy - but i'd make sure you have the pro version of OBD eleven as it keeps a record of your changes. So far i've only tried those, and attempted the lane assist - but it seems ok so far. Certainly no problems undoing the lane change mods, just be careful to follow the process in reverse to undo the changes.

    Not many codes around for the B9 seemingly. It shares a lot of the platform with the new Q7 so i've found a few codes on there. Sadly not all of them read across (Disable start-stop for example).

    Have a look for a starter:

    http://www.vwaudiforum.co.uk/forum/showthread.php/176518-Q7-(4M)-Coding
     
  8. Brasso

    Brasso Registered User

    2,313
    1,080
    113
    Just take care.

    I have read some horror stories about OBDEleven but then again I've read some about people making changes with Ross tech stuff as well.

    I bought myself a cheap note book when I started doing vcds stuff and kept a careful note of the changes so I could undo them if anything went wrong.

    I've got on ok with changing stuff on my old S3 without any problem. Some times stuff just didn't work in which case I changed it back to the factory settings and all was ok.




    Sent from my iPad using Tapatalk
     
    ScottishA4B9 likes this.
  9. ScottishA4B9

    ScottishA4B9 Registered User

    3,729
    1,072
    113
    Thanks for the helpful into guys.

    @mjcourtney Did you get the lane assist working in the end?
     
  10. ScottishA4B9

    ScottishA4B9 Registered User

    3,729
    1,072
    113
    Would it be an idea to post codes on here for the various mods or start a new thread?
     
  11. mjcourtney

    mjcourtney Registered User

    1,692
    536
    113
    Ok so just tried again. Managed to get it coded and this time the adaptive light fault cleared when completed. Not sure what I did wrong last time.

    Not sure if it's worked yet as haven't had a chance to drive it, but I'll let you know!

    Sent from my Nexus 6P using Tapatalk
     
    bpnike likes this.
  12. Avatar

    snack-media
    Advertisement


  13. ScottishA4B9

    ScottishA4B9 Registered User

    3,729
    1,072
    113
    Thanks. I noticed the graphics for it in the virtual cockpit and that it's not active as standard.
     
  14. mjcourtney

    mjcourtney Registered User

    1,692
    536
    113
    I've not seen any indication that it's activated yet on mine. Nothing appeared in the MMI or the VC in the menus, but i'll go back and check at lunch time to see if it's reset and working.
     
  15. mjcourtney

    mjcourtney Registered User

    1,692
    536
    113
    Success!! Tested it out and it works :)[​IMG]

    [​IMG]

    Sent from my Nexus 6P using Tapatalk
     
    rasA4, ScottishA4B9 and bpnike like this.
  16. basegreen

    basegreen Registered User

    116
    43
    28
    Awesome. What spec do you have (inc options)
     
  17. mjcourtney

    mjcourtney Registered User

    1,692
    536
    113

    2017 B9 Mythos Black A4 Avant 2.0tdi 190 S-line S-tronic.
    Sport Suspension, Technology Pack, Light and Vision Pack. Parking Assistance Pack, Privacy Glass, Storage Pack, Tow Bar.
     
  18. basegreen

    basegreen Registered User

    116
    43
    28
    Hmm. Only thing I don't have there is the vision pack.. of which all I don't have is the matrix lights. Is the sensor for lane assist only part of those lights?
     
  19. bpnike

    bpnike Registered User

    47
    9
    8
    Lane assist is using audi pre sense city camera behind the rear view mirror. Same camera for the high beam assist as well
     
  20. cuke2u

    cuke2u Well-Known Member

    13,031
    5,277
    113
  21. Pork

    Pork Registered User

    279
    115
    43
    Kudos, you're a brave man MJ
     
    mjcourtney likes this.
  22. Brasso

    Brasso Registered User

    2,313
    1,080
    113
    @djalex, with this in mind what is the best tool to buy to do coding on the A4.


    Sent from my iPad using Tapatalk
     
  23. DJAlix

    DJAlix VAG Car Coding™ Limited Site Sponsor Gold Supporter VCDS Map User VAG Can Professional ODIS (Offboard Diagnostic System)

    6,625
    5,069
    113
    At this moment in time VAG CAN Professional is the only tool which fully supports the MLB platform.
     
    Brasso likes this.
  24. cuke2u

    cuke2u Well-Known Member

    13,031
    5,277
    113
    Brasso likes this.
  25. Brasso

    Brasso Registered User

    2,313
    1,080
    113
    They seem to be.

    I'm only after locking beep though.

    I have no interest with vim, and lap time is enables as standard. I need to check on the auto activation of the front parking sensors as if that not already on I'll want that too. Not sure there's much else I'd do and I'm not sure it's worth the money to buy VCP for two mods.


    Sent from my iPad using Tapatalk
     
  26. DJAlix

    DJAlix VAG Car Coding™ Limited Site Sponsor Gold Supporter VCDS Map User VAG Can Professional ODIS (Offboard Diagnostic System)

    6,625
    5,069
    113
    Not in or around London by chance are you?
     
  27. Brasso

    Brasso Registered User

    2,313
    1,080
    113
    I'm in near Northampton but could come down to London. Spent best part of the last 13 years working there.


    Sent from my iPad using Tapatalk
     
  28. ScottishA4B9

    ScottishA4B9 Registered User

    3,729
    1,072
    113
    @mjcourtney Do you have the obdeleven codes for the lane assist, needle sweep and lap timer? Thanks

    How are you finding the lane assist?
     
  29. mjcourtney

    mjcourtney Registered User

    1,692
    536
    113
    I followed these instructions for Lane Assist:

    http://www.audiworld.com/forums/a4-...ctive-lane-assist-all-cars-pre-sense-2907906/

    But skip the Lane Change Assistant line in Module 17 if you don't have Side Assist fitted or else it'll throw the error that came up on mine too.

    For lap timer and needle sweep look here:

    http://www.vwaudiforum.co.uk/forum/showthread.php/176518-Q7-(4M)-Coding

    Getting on fine with Lane Assist, doesn't really interfere in day to day driving, and the odd time it does try and adjust the steering it's very minor and easily ignored / overcome. I will say it's not that great at identifying lane markings on anything other than dual carriageway / motorways, but then I guess that's what it was intended for anyway.

    Sent from my Nexus 6P using Tapatalk
     
    rasA4 and ScottishA4B9 like this.
  30. ScottishA4B9

    ScottishA4B9 Registered User

    3,729
    1,072
    113
  31. exca

    exca Registered User

    15
    16
    3
    You have to skip this coding "Lane Change Assistant >Active" in Dashboard, leave it. It's what enables side assist and it gives the error you describe if you don't have the sensors for it. In fact, it doesn't have much to do with the active lane assist.
     
    Last edited: Jan 3, 2017
  32. exca

    exca Registered User

    15
    16
    3
    I have changed a bit today to my A4 MY17 with OBD Eleven:

    1) High Beam Assist (works if you have the front camera at the rearview mirror):

    CENTRAL ELECTRICS
    high_beam_functions> head_light_assistant
    FRONT SENSORS DRIVER ASSISTANCE SYSTEM
    afs_coding_light_assist> high_beam_assist
    Controle-eenheid 09 (CV elektra)
    mmi_fla_glw_mxb> active​

    2) Map display in dashboard with SD-based navigation

    I have the basic MMI with SD-navigation and a color DIS. I was disappointed when i noticed the map couldn't be shown there like with the A6, probably to push us buying the VC. By this coding you can switch between showing the map or the original navigation instructions by controlling the DIS with a multifunctional steering wheel. If you leave it on the map next time you start the car it will show the map again.

    You need to have the color DIS offcourse and also the multifunctional steering wheel

    INFORMATION CONTROL UNIT 1
    Dashboard_Display_Configuration
    navigation_map_transmission_mode -> MOST_Streaming
    navigation_map_compression_mode -> H264
    navigation_map_Resolution -> resolution_1

     

    Attached Files:

    • img.jpg
      img.jpg
      File size:
      282.7 KB
      Views:
      1,149
    JayK86, GavinE, SLINEA4AVANT and 2 others like this.
  33. Avatar

    snack-media
    Advertisement


  34. steviefleming

    steviefleming Registered User

    27
    14
    3

    Okay .....so unlocked video in motion

    Does it invalidate your insurance if anything happens to the car ......I want it but I'm worried about risking a £50k+ car against it.

    Secondly .....will I get pulled over from police ????.......that new b9 screen sits a little high . Will it be viewed easily from other cars whilst I drive ??...especially in the dark !!
     
  35. adamcooke

    adamcooke Registered User

    9
    1
    1
    If you're driving with a video playing, I rather hope you do get pulled over by the police! :rage:
     
    tickedon likes this.
  36. adamcooke

    adamcooke Registered User

    9
    1
    1
    What a mature response. Do grow up.
     
  37. cuke2u

    cuke2u Well-Known Member

    13,031
    5,277
    113
    Ok steady guys, each to their own opinion..
     
  38. DJAlix

    DJAlix VAG Car Coding™ Limited Site Sponsor Gold Supporter VCDS Map User VAG Can Professional ODIS (Offboard Diagnostic System)

    6,625
    5,069
    113
    Only "driver aids" are allowed to be visible to driver / person in charge of a vehicle, everything else must be out of your line of sight. I deal with a lot of Video In Motion Activation requests to allow the use of 3rd party satnav devices via the onboard display, which is legal.
     
  39. ScottishA4B9

    ScottishA4B9 Registered User

    3,729
    1,072
    113
    @mjcourtney Hi mate. I still can't find the right coding for the lane assist.
    The links you keep posting up just have driver assist and steering assist! Is it these?
    I just don't have the time to go through 10's of pages on an American forum.

    Thanks mate.
     
  40. mjcourtney

    mjcourtney Registered User

    1,692
    536
    113
    The first post in the first thread I linked has the lane assist activation procedure in it. Essentially you need to enable options in the steering wheel controller, camera, central electrics and dashboard to activate it. Let me know if it's still not clear and I'll see if I can post up a reduced version with just the steps I followed.

    Sent from my Nexus 6P using Tapatalk
     
  41. ScottishA4B9

    ScottishA4B9 Registered User

    3,729
    1,072
    113
    @mjcourtney I haven't seen any of those steps! I seem to be missing out loads.
    If you could please pal it would be very much appreciated. Thanks.
     
  42. exca

    exca Registered User

    15
    16
    3
    Found another useful tweak, let the MMI use your phone's tethering dataconnection through wifi/bluetooth:

    F5 VEHICLE CONFIGURATION
    ADAPTATION
    Vehicle configuration
    wifi_client_hmi -> activated (was “not activated”)

    Currently this is disabled and you can only use it the other way (where the car tethers it's data through wifi). This is very useful to me as i have a more than sufficient monthly 10GB data plan for my phone, now i don't need an audi dataplan or a seperate simcard anymore.

    All online stuff still needs a licence from Audi though.
     
    rasA4 and Keef like this.
  43. ScottishA4B9

    ScottishA4B9 Registered User

    3,729
    1,072
    113
Tags:

Share This Page

Do Not Sell My Personal Information