SERIOUS. Oil Pressure Warning. But still ok to drive?

JJ.Foulds

Registered User
Right so over the time of a few weeks, my oil pressure warning light came on. I stopped the car instantly waited a few mins and started again, the light did not show again.

HOWEVER tonight, the light came on 2 or 3 times on the 2 mile trip home from tesco.
I did the same as before turned the engine off instantly (luckily no cars on the road soo i kept driving lol) then turned it back on with the light gone.

Now as much as i am worried about my engine blowing up, i seem to feel this might be a sensor of some sort because its not there when i restart the car? surely if its a proper problem it would still show?

Also it seems to come on after turning a corner? (another sign of a sensor?)

I also have just purchased VCDS, but when i scan it never says anything about this warning being on. Is there any way of getting some useful info out of VCDS to help?

If someone could suggest a few things to check for, that would be great!

Thanks all, Jon.
 

Av4nt

Registered User
sorry to be obvious... have you checked the oil level...?
My avant used to beep 3 times with te oil pressure/warning light on random occasions when cornering.. and as soon as i checked the oil level it was below minimum.
so I always used to keep a bottle of oil in the boot and just top up before any long journeys.
 

JJ.Foulds

Registered User
sorry to be obvious... have you checked the oil level...?
My avant used to beep 3 times with te oil pressure/warning light on random occasions when cornering.. and as soon as i checked the oil level it was below minimum.
so I always used to keep a bottle of oil in the boot and just top up before any long journeys.

After the first 2 times of it hapening i checked the oil instantly, and it was fine, i also checked for drips after a 24 hour stand still.

I havnt checked after tonights one, but i will do in the morning. I would of thought it will tell me if the oil level is low tho? lol
 

Av4nt

Registered User
Well I am only going from experience with my last car ofc but on cornering sometiems a red oil warning light would flash and beep then just dissappear after straightening up. It was very odd and always due to low oil. Of course I thought the same as you that ifthere was an issue it would just stay on but no.

Cars are just wierd lol. nothing is hardly ever the same so my exp may be something completely different from whats happening to yours
 

coxy8329

Registered User
If you have VCDS scroll through the engine measuring blocks until you find the one for oil px. Take it for a drive if you're happy to and log that measuring block. It will show if there is actual loss of oil pressure.
It does sound as though something is blocked though. I believe this is a fairly common issue with some engines.
 

Marshy

Settled in
Yeah sounds like the oil pickup pipe is blocked.
Needs the sump off and pickup pipe replaced or cleaned.
Out of interest how many miles has your car done?
Seems to be more frequent on cars with 60k or so on longlife servicing.
 

hades-

Well-Known Member
VCDS Map User
so many drivers think yeah **** it its ok to drive
some do get away with it been a sensor
most end up with a new turbo and engine rebuild or sh engine.
is it worth not spending a few quid to remove sump and check the pick up and replace ?
 

JJ.Foulds

Registered User
yes the warning is RED, and the car has done 120k miles.

I will check oil level again, and try and find the logging on the vcds and see what it says.
Surely its ok to drive if the light isnt on right?
 

MrLapou

Registered User
It may be, but if strainer is part blocked, then this could lead to oil starvation to parts of the engine and turbo.
 

JJ.Foulds

Registered User
ok, so i tryed to find the VCDS stuff with oil and log it, but i cant open the logs lol.

ANYWAY, its drives round fine, but as soon as i floored it the light came on instantly, do the engine load change the rate of the oil pump or anything like that?
 

s3joe

Registered User
ok, so i tryed to find the VCDS stuff with oil and log it, but i cant open the logs lol.

ANYWAY, its drives round fine, but as soon as i floored it the light came on instantly, do the engine load change the rate of the oil pump or anything like that?

It's the pick up pipe it's blocked get it replaced asap
 

s3joe

Registered User
Replaced? cant it just be cleaned? anychance of a part number if so and il order one today, engine is AXX

There about £20 from tps if you ring them or even Audi any parts person will know what it is as it's been a problem for years
 

Auditaf

New Member
Hi matey. Having the exact same issue however ive just changed the pickup pipe with the revised one. Did you find a fix in the end ?
 

JJ.Foulds

Registered User
Hi matey. Having the exact same issue however ive just changed the pickup pipe with the revised one. Did you find a fix in the end ?
Old old thread, but I had pickup pipe done, sump cleaned and was still getting the oil light. Changed the oil pressure sensor also, same issue. My mechanic said the only thing left to do was to start replacing oil pumps etc but i sold the car as I couldn’t afford to keep looking into things! I would advise to just change it all and know your in the clear.

I think if I remember also these vehicles used to trigger the light if your really belted it around corners, as the oil would starve the sensor or engine parts?
im sure a company made some sort of extra oil pump system to sort this, I remember it for the s3’s but they are a slight newer engine I suppose.
 

Auditaf

New Member
thanks did a oil and filter change and it seems to have cleared up. no errors and ive done a full tank. It seems to be fixed but unfortunately ill be listening out for that dreaded three beeps every time i get in the car now
 

JJ.Foulds

Registered User
thanks did a oil and filter change and it seems to have cleared up. no errors and ive done a full tank. It seems to be fixed but unfortunately ill be listening out for that dreaded three beeps every time i get in the car now
Unfortunately that sticks with you. Every car that beeps at me, I automatically ptsd back to oil pressure issues!
 

Subsea77

Registered User
Hi

Mine started doing this today after fitting a new maf and abit if spirited driving
Have the three dreaded beeps come back??

Sent from my SM-G981B using Tapatalk
 
Top