1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Q7 Q7 2007 mmi control panel Q7

Mattam Jan 4, 2020

  1. Mattam

    Mattam New Member

    5
    0
    1
    Hi all I've just bought a Q7 3.0 TDI 2007 s line on Xmas eve. Sold the A4 Avant and Mrs her astra.

    Is an amazing drive

    Only had 2 problems so far.

    1.
    The mmi control panel wasn't working so I took it all out cleaned the circuit board and all is good.

    The only problem I have is the button writing doesn't light up on the car, setup etc side and the same as the control knob. The red lights light up when the button is pressed but not the writing. The other side does, radio media etc.

    Any idea where the bulb would be as I didn't see one when I took the circuit board out.

    2. If I'm at the lights, keep the brakes pressed, then try to rev the car, it revs to around 1500 then is completely slow when I pull away unless I go from sport to D or the other way round.
    Any reason why.
    Thanks alot
     
  2. Avatar

    snack-media
    Advertisement


  3. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    31,667
    2,301
    113
    Possibly the mmi panel has a fault, they're LEDs but given its a number of them but not all, I'd consider a replacement as it would be all, if it was another part causing, speculating of course but I'd try another of possible.

    Not sure about the 2nd issue tbh.
     

Share This Page

Do Not Sell My Personal Information