1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Audi A6 2.5TDI hopeless crankshaft speed sensor issue..

Vannhickey May 27, 2018

  1. Vannhickey

    Vannhickey New Member

    9
    0
    1
    Hey, first of all i wanna say, im bad on english, but ill try my best..

    Got 2.5tdi Audi a6 2001, bought as AKE, but got roll cams..? also tiptronic & quattro.
    Driven around 250 000km.
    Problems is, its running rought on idle revs jumping little and on (service mode)? revs limited 3k.
    Also On Reverse & Drive, i barely can keep it still with brake on, revs jump a bit more on thoes. After heating up a bit i might get it running steady on P and Neutral on idle, but little touch of pedal makes revs jump again.
    Its giving fault codes:
    01126 - Enghine Speed Signal
    16-10 - Signal Outside Specifications - Intermittent
    And
    00513 Engine Speed Sensor (G28)
    27-10 - Implausible Signal - Intermittent

    So far car visited couple of workshops, even original audi service where they found out 6mm bolt inside cutted 3 of 6 flywheel pins, so no wonder it was running rought no signal on 3 pins. New Flywheel installed, same issue...
    Heres parts changed so far and checked multiple times.
    New VP44
    New Ecu
    New 3rd cylinder nozzle
    New crankshaft speed sensor(got three of them)
    New Transmission Fluids.
    New MAF
    New Flywheel
    Rest of nozzles checked also, (opening preasures)
    Timing checked multiple times.
    Also most of wires checked.
    Running same whatever you unplug.
    +Cams are almost new. not worn a bit.

    Thinking about transmission but what else could be broken by 6mm bolt.. (No freaking idea how it got there, when i bought car, earlier owner said its only g28 what needs to be changed..)
     
  2. Avatar

    Google AdSense Advertisement


  3. amiram

    amiram A6 C5 Allroad 2.5L TDI Tip Still on air :)

    74
    4
    8
    Check if diesel fuel is suitable without water and without air
     
  4. Vannhickey

    Vannhickey New Member

    9
    0
    1
    Tried giving fuel straight from canister Even without Fuel filter which is Also changed.. :(
     
  5. amiram

    amiram A6 C5 Allroad 2.5L TDI Tip Still on air :)

    74
    4
    8
    Do you have the ability to scan faults codes and block values?
     
  6. Vannhickey

    Vannhickey New Member

    9
    0
    1
    Yea i got vagcom.
     
  7. amiram

    amiram A6 C5 Allroad 2.5L TDI Tip Still on air :)

    74
    4
    8
    Measuring values block - injection quantity (for 5 injectors) and start of injection. Check the results when the engine is at working temperature!
     
  8. Vannhickey

    Vannhickey New Member

    9
    0
    1
    Measuring block injected quantity drops around 0-2.0 when it starts running rough,(jumping revs) also Qty adj valve act time goes around same, around 0-6 CF

    Running steady Injected quantity is between 6.0-7.0
    Qty Adj Valve is pretty steady also, around 20 CF

    Feels like its not getting enough.. ?

    Perhaps workshop got pump timing wrong afterall, ( when they changed it) but engine is starting great tho.. I hope these tells u something.
     
  9. amiram

    amiram A6 C5 Allroad 2.5L TDI Tip Still on air :)

    74
    4
    8
    In the Measuring block values There is a possibility to check each injector quantity separately (5). And also the start of the injection, Should be at 2 degrees BTDC 1.5+\- .
    These parameters will give you a clearer picture of the timing of the injection pump and engine.
    Also check the condition of the electrical socket engine speed sensor G28 (Clean it with a contact cleaner)
     
    Last edited: May 29, 2018
  10. Vannhickey

    Vannhickey New Member

    9
    0
    1
    Pretty much everything is cleaned up, timing was no go.. car IS 2001 and got immo 3, so does new pump need coding? Also got new ecu which still needs some work to get Immo off, but with new ecu ignination on ESP and abs Lights go off. With old ecu lights stay on whole Time.
     
  11. amiram

    amiram A6 C5 Allroad 2.5L TDI Tip Still on air :)

    74
    4
    8
    In the old ECU Delete the fault codes from all channels
     
  12. Avatar

    Google AdSense Advertisement


  13. Vannhickey

    Vannhickey New Member

    9
    0
    1
    Did it several times,But moving timing too early (If i remember right) made car run on Idle and GEARS steady, smoked a bit More but Ran Stable. Still service mode on and fault codes from g28.
     
  14. Vannhickey

    Vannhickey New Member

    9
    0
    1
    A bit More about ecu, first ecu was send to diagnose and they Said itse Burnd probably becouse tuning, they send 4b2 907 401 j for replace, and Said they transfered data from old one to new. I believe, first one was 4b2 907 401 e, Any idea whats The difference between thoes two?

    E: got new both j and e, waiting for unlock. J is making buzzing noise on vp44 relay constantly..
     
  15. amiram

    amiram A6 C5 Allroad 2.5L TDI Tip Still on air :)

    74
    4
    8
    It is for a different year of production.
    E - 10\1999 - 5\2000. VIN 4B_Y_200000...
    J - 2002-2003. VIN 4B_2_000001 - 4B_2_140000
    Both AKE 108 PS
    My vehicle 2002 with AKE engine also with rollers. The previous owner did it :friendly wink:
     
  16. Vannhickey

    Vannhickey New Member

    9
    0
    1
    Allright thanks, so probably no Big difference then. My last hope is that only working ecu is messed up.. probably not, but running out of ideas at this point.. something on Fuel side it must be..
     
  17. Vannhickey

    Vannhickey New Member

    9
    0
    1
    Vcds says pump timing too advanced no matter how much turning it retarded sticks to upper line.. Any suggestions what Makes that?
     
  18. amiram

    amiram A6 C5 Allroad 2.5L TDI Tip Still on air :)

    74
    4
    8
    The engine should be at working temperature (90C) for this test
     

Share This Page