1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Sensor for cylinder head temperature

fingermouse Jun 20, 2019

  1. fingermouse

    fingermouse thats me

    4,245
    198
    63
    Can anyone help pls

    Scanned car with capcom and got fault code 10219 Sensor for cylinder head temperature

    254 fault frequency since 16.6.19


    Anyone shed a bit of light on this please.

    Scanned the car as my start stop was always going into fault. Was expecting low battery but all seems ok that way.
     
  2. Avatar

    snack-media
    Advertisement


  3. B5NUT

    B5NUT Well-Known Member VCDS Map User

    5,077
    1,237
    113
    I could find very little on this fault, etka shows a sensor here
    upload_2019-6-21_9-24-31.png
    unfortunately item 59 is a link to another page in etka with a bun of sensors, and the only one I can see on that page that could match is a sensor base engine.
    upload_2019-6-21_9-27-19.png

    Only way to tell is to unplug that sensor and see if the fault code changes or a new one appears.
     
    fingermouse likes this.
  4. fingermouse

    fingermouse thats me

    4,245
    198
    63
    Ok thx for the info
     
  5. Eastmidsdude

    Eastmidsdude 2014 A6 2.0tdi Black Edition

    75
    34
    18
    Looks like a coolant temp sensor. I guess if the ecu doesn’t know the water temp then the stop start won’t operate?
     
    fingermouse likes this.
  6. fingermouse

    fingermouse thats me

    4,245
    198
    63
    struggling to locate this but the weather hasn`t helped

    more info

    10219 - Sensor for Cylinder Head Temperature
    P017D 00 [046] - Short to Plus
    Intermittent - Confirmed - Tested Since Memory Clear
    Freeze Frame:
    Fault Status: 00000001
    Fault Priority: 2
    Fault Frequency: 254
    Mileage: 219716 km
    Date: 2019.06.16
    Time: 14:42:13
    Engine speed: 1311.50 /min
    Normed load value: 0.0 %
    Vehicle speed: 41 km/h
    Coolant temperature: 92 °C
    Intake air temperature: 20 °C
    Ambient air pressure: 1000 mbar
    Voltage terminal 30: 14.460 V
    Unlearning counter according OBD: 40
    Accelerator pedal travel: 0.00 %
    Coolant temperature at radiator outlet: actual value: 26.5 °C
    Heat delivery temperature in cooling system: -273.1 °C
    Outside air temperature: 14.5 °C
    Fuel consumption: 0.00 l/h
    Fuel temperature: 32.2 °C
    Engine oil temperature: 96.2 °C
     
  7. fingermouse

    fingermouse thats me

    4,245
    198
    63
    Unplugged this sensor and got no new faults
     

    Attached Files:

  8. fingermouse

    fingermouse thats me

    4,245
    198
    63
  9. Mo-S3

    Mo-S3 Registered User

    857
    35
    28
    pm me your chassis no
     
    fingermouse likes this.
  10. fingermouse

    fingermouse thats me

    4,245
    198
    63
    :salute:
     
  11. Mo-S3

    Mo-S3 Registered User

    857
    35
    28
    As you have been told.. there is no cylinder head temp sensor. Cant find one on etka. The sensor you unplugged as per your pic is one of the oil pressure sensors.
    Unless vcds has the wrong label for the actual sensor description as P017D is referring to oil pressure switch amongst other descriptions when searched in google
     
  12. Avatar

    snack-media
    Advertisement


  13. fingermouse

    fingermouse thats me

    4,245
    198
    63
    Ok cheers. Very little came back on searches. I’ve ordered a sensor that might be it from the post I found where the guy had the same fault code but that was a unplugged sensor.

    Might have to try some other software at a local garage I know they have just invested in a new system.

    Audi said 198 quid lol just to diagnose the issue.
     
  14. fingermouse

    fingermouse thats me

    4,245
    198
    63
    So picked up the new sensor today, got home and unplugged the one in the car and connected the new one in thin air.

    Scanned the car again and bingo the error code has gone.

    Just got to fit the bleeder but thats a job for Saturday and a cold engine.

    Will post more details up later for part numbers and better pics in case anyone get this error in the future
     

Share This Page

Do Not Sell My Personal Information