S4 B6 clutch slip

S4Marc

Registered User
Under certain conditions my clutch seems to want to slip rather than fully engage and hold, I'm unsure if this is myself needing to get used to a Quattro system or the car

A little bit of background info on my car, it had a new clutch fitted by MRC approximately 12,000 miles ago

Under hard acceleration the clutch does not slip if you fully realease the clutch before touching the accelerator pedal

When pulling away enthusically or changing gear and accelerating hard the clutch would rather slip then hold
 

Pops848

Registered User
Potentially just need to get used to it
If clutch was fitted 12k ago and it's slipping something is not right.

Go find a steep hill, out car in 2nd gear and try pulling away. If you stall then all is good, if not you'll see a lot of clutch slip and know straight away


Sent from my iPhone using Tapatalk
 

S4Marc

Registered User
Potentially just need to get used to it
If clutch was fitted 12k ago and it's slipping something is not right.

Go find a steep hill, out car in 2nd gear and try pulling away. If you stall then all is good, if not you'll see a lot of clutch slip and know straight away


Sent from my iPhone using Tapatalk
Will give it a go up some steep hills

It was almost like once the clutch has started to slip it can't grip until you completely let off the gas and let it catch up with itself

I spoke to a well renowned Audi workshop and they stated the early S4 V8 clutch isn't inherently weak and is either me or previous owner has abused it

Sent from my EVA-L09 using Tapatalk
 
Top