1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Drivers mirror not de-misting

Audi Bairn Sep 13, 2019 at 1:03 PM

  1. Audi Bairn

    Audi Bairn Moderator Staff Member Moderator TFSI Owners Group Gold Supporter Team Navarra Audi S3 saloon quattro S tronic DSG

    4,598
    5,842
    113
    I know I'm on the A3/S3 forum asking about a TT but there's likely to be more responses here.
    Been using the wifes TT to even up the mileage a bit on the two cars.
    Noticed the past two mornings that the drivers mirror ain't demisting (the passenger one is).
    Any quick fixes I can do myself? Trying to avoid a garage trip if poss.
     
  2. Avatar

    Google AdSense Advertisement


  3. AlS3BE

    AlS3BE Well-Known Member

    2,627
    1,468
    113
    Check fuse first. If fuse is ok then pull the mirror out and get a multimeter across the terminals on the mirror to see if there’s any voltage across them. Could be corroded terminals on the mirror as it’s just spade terminals. Had that on my a6 quick scrub and wd40 it all worked.
     
  4. Flying Scotsman

    Flying Scotsman Well-Known Member Team Ara Blue Audi S3 saloon

    1,402
    2,804
    113
    That is a good response from AIS3BE. If that is the case is the case, a great product to use is Corrosion X ( If available in the UK) It is a far superior product to WD 40. It prevents corrosion and maintains electrical continuity.
    I had the same issue with VAG heated mirrors in the past and now treat them with Corrosion X after I pick up my new cars and no issues.
     
    AlS3BE and Audi Bairn like this.
  5. lee red

    lee red Member

    40
    1
    8
    I recently had this problem turned out to be the control module for the mirrors it’s inside the drivers door it was not sending any power to my drivers mirror for the demistter ..,warranty work
     
    Audi Bairn likes this.
  6. larbel

    larbel Well-Known Member Team Sepang Audi S3 saloon

    913
    699
    93
    If you have VCDS or OBD11, you can do a output test and see if it's indeed working or not... Plus if there's break in the currents or malfunction, it should throw a code...
     
    Audi Bairn likes this.
  7. George_P

    George_P New Member

    15
    9
    3
    Yep, same on brand new s3, very annoying
     
    Audi Bairn likes this.
  8. Audi Bairn

    Audi Bairn Moderator Staff Member Moderator TFSI Owners Group Gold Supporter Team Navarra Audi S3 saloon quattro S tronic DSG

    4,598
    5,842
    113
    I think it's going to have to go back in under warranty as I've tried everything I can given my limited abilities

    Thanks for all the input, appreciated.
     
  9. AlS3BE

    AlS3BE Well-Known Member

    2,627
    1,468
    113
    Have you turned the knob to heated mirror?
    Not trying to say you are an idiot but lots of folk think it turns on with the heated window and not the mirror switch.
     
  10. Flying Scotsman

    Flying Scotsman Well-Known Member Team Ara Blue Audi S3 saloon

    1,402
    2,804
    113
    He stated that only the drivers mirror was misting and the passenger one was receiving heat.
     
    Audi Bairn and AlS3BE like this.
  11. AlS3BE

    AlS3BE Well-Known Member

    2,627
    1,468
    113
    Need to stop skimming post while at work :wink:
     
    Audi Bairn and Flying Scotsman like this.
  12. Avatar

    Google AdSense Advertisement


  13. George_P

    George_P New Member

    15
    9
    3
    After 6 months of owing S3 I've found the knob! Thanks
     
    Audi Bairn and AlS3BE like this.
  14. AlS3BE

    AlS3BE Well-Known Member

    2,627
    1,468
    113
    At least my comment helped someone. :icon thumright:
     
    Flying Scotsman and Audi Bairn like this.
  15. Audi Bairn

    Audi Bairn Moderator Staff Member Moderator TFSI Owners Group Gold Supporter Team Navarra Audi S3 saloon quattro S tronic DSG

    4,598
    5,842
    113
    :laughing: I'm guilty of the same myself, no worries
     
    AlS3BE likes this.
Tags:

Share This Page