1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cold start misfires!

CoffeeAndJam Aug 3, 2018

  1. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    Hey all,

    Sorry for a bit of a long post. Want to give as much info as possible.

    I’m having random cold start misfires in my 2017 S3 that’s setting off the CEL. It has 30k miles on it. Stock except for tinted windows. This issue has been going on for over two months between the dealer and I. They haven’t been able to find the cause (they thought they did).

    It started with me changing all the coils and plugs myself and inspecting the PCV valve after my first CEL was thrown for random misfires on multiple cylinders (also got misfire codes for cylinder 3&4). PCV valve was good. Changing coils and plugs didn’t solve the problem.

    I brought it to the dealer next. They’ve done compression tests, leakdown tests, checked the camshaft adjuster (exhaust side), ran a fuel additive through it, change plugs again (said that was the problem at first along with bad fuel), and did a software update to fix the cold start issues (apparently there’s an update just for that). All the tests came back great, no leakage and compression is 180psi on all cylinders.

    After all that testing (see attached service report) they said the next step was to replace the injectors for $1300 (my car is TD1, long story). They said they’re possibly causing fuel to leak into the cylinders over time when sitting, causing misfires during start. So I OK’ed the repair. Got the car today, and the car is experiencing the same problems as before (coldstart misfires) and it’s a matter of time before the CEL comes back on.

    Needless to say, I’m very frustrated and don’t want to blindly throw money at it anymore. Anyone have suggestions? Someone told me to have them pull the valve cover and check the springs, since a VW tech sees a number of cars come through for bad springs.
     

    Attached Files:

  2. Avatar

    Google AdSense Advertisement


  3. malinmip

    malinmip New Member

    15
    6
    3
    Shouldn't they compensate their misdiagnosis somehow? It's not up to customer to pay their mistakes of misdiagnosis.
     
  4. Matt Titanium

    Matt Titanium Well-Known Member Team Navarra Audi S3 Manual

    464
    515
    93
    I had a 1.8 tfsi with cold/warm start problems. Longer cranking, running on three cylinders for a few seconds, rough idle when cold. Audi cleaned the injectors in an ultrasonic bath, no better. Ended up replacing all the injectors to cure the fault.
     
  5. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    Yes, I think they should compensate the misdiagnosis somehow. Not sure if they will, but they should.

    Replacing all the injectors didn’t fix it for me. Cylinder 4 is still misfiring over 40 times during a cold start, same as before which threw a CEL. Cylinder 1 is pretty bad too, and the rest misfire occasionally during a 25 mile drive.
     
  6. Retroman

    Retroman Audi A3 2010 Sportback 2.0 TDI 170 (CBBB engine)

    996
    294
    63
    Only an internet guess, but given your low mileage and the changes/checks done so far I would suspect an (in)correct "fuel mixture" delivery issue. I guess they would have checked the fuel pressure? and so the fuel pump can be ruled out? After that I would suspect the Mass Air Flow (MAF) sensor. Modern fuel injectors are very sensitive to incorrect (lean) fuel delivery. Once the engine is warmed, the post combustion sensors "kick-in" and help fine tune the combustion mix - hence the problem being restricted to a cold start when the MAF should be controlling a richer combustion mix.
     
  7. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    Another shop I talked to suspected a fueling issue. I’m not sure if the dealer checked the fuel pump. They didn’t tell me they did or put it anywhere in the write up that’s attached. Only thing I see is something with a fuel sensor.

    Is checking a fuel pump something I could do or does it involve special tools and skills?

    Regarding the MAF, would it be worth it to clean it, or if it was causing the misfires, would it just be bad and not worth a cleaning?
     
  8. MrFlibble

    MrFlibble Guest

    0
    0
    0
    Tricky problem.

    The S3 uses MAP fuel control, so should be more tolerant to vacuum/boost leaks than cars which use MAF control. However, it would still be worth checking for vacuum/boost leaks; if the PCV was changed because of malfunction, then this includes checking things like the engine gaskets, including valve cover gasket. Consider replacing the MAP sensor anyway, they are cheap.

    Fuel injectors and ignition have been replaced, so are unlikely to be the cause, which suggests a mechanical problem. Although compression is good when warm, it's still possible that compression is poor when cold. This could be due to valve springs, hydraulic lifters, sticking valves etc. as well as things affecting the performance of the hydraulic lifters, like the oil system. So, I would be inspecting the springs/valves/clearances and the lifters, including checking for excessive carbon build up on the intake valves.

    If you're lifting the valve cover for inspection, would also be worth checking the HPFP follower, just to make sure that this isn't a potential problem, although I wouldn't have thought this likely.

    Is it possible that the misfire is a misdiagnosis? Are the cylinders really misfiring, before the ECU decides enough is enough and cuts fuel? Faulty crank position sensor could cause the ECU to misdiagnose a misfire condition and take inappropriate corrective action.
     
  9. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    MrFlibble,

    That’s some good info. Thanks.

    I don’t think the PCV system was changed, just checked. I took it off and checked all the seals, and the diaphragm that commonly splits (the pancake piece). All looked good so I put it back together.

    Someone who’s works on VW’s and Audi’s said to check the valve springs as they are seeing them going bad a number of times recently. Would bad valve springs make the engine misfire more during a cold start than when warm?

    I’m hoping it’s not a big problem like a head gasket. The leakdown and compression test they did would’ve shown that to be a problem, correct? Plus I’m not losing any coolant, as I’ve been monitoring it very closely.

    Regarding misdiagnosis, wish I had the knowhow to check a sensor like the crank position sensor. I’d look into it ASAP.

    One thing they noted when doing a borescope was how clean the piston heads / cylinders were. This was right after they put two cans of additive through the system, which is their reasoning for it being so clean. I’m not sure if they checked for excess carbon build up on the intake valves though.
     
  10. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    Sure enough I got a CEL for P0301 & P0304 (misfire cylinder 1 & 4) this morning on a cold start.

    What I’ve noticed is the longer it sits, the more it seems to misfire on the cold start.

    I’m going to bring it to a specialist in town who has a good reputation (Steve’s European).
     
    Last edited: Aug 6, 2018
  11. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    Update:

    Got a preliminary recommendation from the shop and it’s not good:

    They’re saying I need a new engine. There’s considerable piston damage / cylinder wall scores, and piston heads are slightly melted. They showed me the borescope photos and it doesn’t look pretty.

    They said compression checks out good however, no issues there so they’re keeping the car a day longer to do more tests but it sounds like I’ll have to get a new engine.

    This sucks. They said a new engine for this car is $10k before install. I’m looking at around $15k for a new engine. There has to be something cheaper, right?

    I am not in the position to shell out $15k for a new engine.
     
  12. Avatar

    Google AdSense Advertisement


  13. Svenedin

    Svenedin Well-Known Member Team Navarra Audi S3 quattro S tronic

    615
    450
    63
    So you modified your engine and it has invalidated your warranty (TD1)?

    Clearly it has been much too hot in your engine and this has caused the melting of the piston heads and the pistons to bind which has scored the cylinder walls. There are multiple reasons why that may have happened but possibly the wrong ignition timing with pre-ignition or too much boost that overwhelmed the ability of the injectors to supply fuel and caused an excessively hot over-lean mixture.

    What were the modifications of your engine?

    I’m sorry to hear that you have been landed with a huge bill. It may be too far gone but perhaps an engine specialist can rebuild your engine. Why not have a search for a specialist and send them your report for an opinion and quote? It will still be expensive because the engine will have to come out and be shipped to the rebuilder and then back in again so a lot of labour charges. Worth comparing though to the cost of a new or reconditioned engine. There may also be an option to swap your damaged engine for a reconditioned one. Your only other option is to sell the car at an enormous loss given that the new owner has major costs to get the car serviceable or they break it for parts.
     
  14. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    It had a stage 1+ tune from Unitronic. It was taken off and put back to stock but got flagged TD1 anyways.

    Not sure how bad it is, but they told me no engine shop will want to touch these engines since they’re still so new. But maybe there’s a shop around that will rebuild it.

    I still really like the car and would prefer to keep it so long as I know the engine is good. So selling at a huge loss isn’t an option for me.

    I don’t know how to go about finding a good reconditioned engine or is there a cheaper way to get a brand new one? I’ve searched online for replacement gen3 ea888 engines but nothing came up except for the APR built one.
     
  15. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    Update:

    Finally got a used long block engine with 10k miles and had it installed. Internal photos of the engine looked great and clean. Shop was extremely happy with how it looked. They used all existing accessories (turbo, injectors, intake manifold etc.) from my original engine. My injectors were just purchased a few months ago and only have 2k miles on them.

    Everything runs great. However, the odd thing is that cylinder 4 is still logging misfires on cold start. About 15-20 times. All other cylinders don’t log anything. No CEL though.

    Any ideas what could be causing it, considering the engine and injectors are almost brand new? We swapped coils and plugs to see if it followed, but the misfires still happen on cylinder 4.
     
  16. AlS3BE

    AlS3BE Well-Known Member

    998
    446
    63
    A couple of things I would check if you have changed everything else so far.
    Change the fuel filter, it could be blocked so when you crank the car it isn’t making enough pressure at the start but once it’s started there’s enough pressure to keep going. Then check the fuel pressure across the rail.
    Next check all the wiring to injector 4 and coil packs as even with a broken wire electricity can still arc over the break but occasionally it doesn’t and causes a misfire. A simple multimeter should be sufficient to test for broken wires. quite a few to check.
    Only other thing is the ecu if everything else checks out. Could be a bad flash, broken pins etc.
    I would check it it out sooner rather than later as you don’t want to damage your replacement engine. It only takes a short time running lean to damage pistons.
     
  17. Damo S

    Damo S Active Member

    168
    67
    28
    Oh man. sounds like a nightmare
     
  18. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    Your last paragraph concerns me. Is there a way for me to check if it’s running lean? I don’t have VCDS but I do have an OBD2 reader.

    The shop flashed it using an APR tune and then flashed it back to stock so hopefully it’s not a bad flash.
     
  19. AlS3BE

    AlS3BE Well-Known Member

    998
    446
    63
    You need an air-fuel meter in the exhaust to measure the air fuel ratio, doubt you get that information from the obd. Ideally do it on a dyno.
    I would expect it to run between 12-14 air to fuel. Not sure if these new engine types can run really lean to lower emissions so could be higher. Old school turbo engines are normally around the 12 mark, a little rich to avoid pinking/detonation

    Did the shop have to remove the ecu and unlock it for the flash? I know some vag cars required the ecu out and unlocked before it could be flashed. Not sure about the current s3.
     
  20. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    I don’t think the ECU has to be removed. They reflashed it almost instantly. I think it’s via OBD2 port.
     
  21. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    I’ve been logging the cold start misfires for the last few days and have noticed a correlation between the outside ambient temperature and how many misfires cylinder 4 gets.

    Oddly the colder it is, the less misfires. When it’s 34F degrees or below, cylinder 4 gets between 0 and 4 misfires on cold starts. When it’s 40F+ degrees, it gets 11 to 20 per cold start.

    Is there a reason why warmer weather would make it misfire more on cold-starts?
     
  22. AlS3BE

    AlS3BE Well-Known Member

    998
    446
    63
    There’s less oxygen in warmer air but the ecu should be smart enough to adjust the ignition timings to account for that.
    Have you tried swapping the ignition coils from one of the other cylinders? That will help rule out a failing coil.
     
  23. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    Yeah the shop I’m working with just swapped the coil and plug to a different cylinder to see if the condition would follow, but it didn’t.

    I replaced the air filter a few weeks before the problem began with my old engine. I wonder if the dealer could have given me the wrong filter or a bad one. Just coincidental timing. Not sure the air filter would cause a cylinder 4 only misfire during a cold start only.
     
  24. Damo S

    Damo S Active Member

    168
    67
    28
    A clean filter in theory means more air -> a leaner mixture -> more chance of detonation but you would have thought the various sensors, assuming they were working correctly, would recognise this and adjust accordingly.
     
  25. AlS3BE

    AlS3BE Well-Known Member

    998
    446
    63
    Doubt the air filter would make any difference.
    You could always try starting the car without the filter to see if it still misfires.
    If the coil pack is ok then check the plug and make sure it’s the correct plug with the right gap. Maybe even swap the injector between cylinders.
    Start with the basics then move on to the expensive stuff.
     
  26. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    Moving the plug and coil pack to a different cylinder didn’t effect cylinder 4 from misfiring during cold starts. Still misfiring around 10-15 times. Frustrating.

    Also, the fuel filter is built into the low pressure fuel pump so it would have to be replaced all together.

    The shop told me switching injectors wouldn’t be worth it since it requires removing the intake manifold, and at that point I should consider replacing the injector since it would cost just slightly more.
     
    Last edited: Nov 13, 2018
  27. AlS3BE

    AlS3BE Well-Known Member

    998
    446
    63
    Not sure what to suggest now. You are in the realms of expensive stuff now.
    Only other thing without removing the injector is get a multimeter across it and see if it’s pulsing correctly. That will at least rule out cables/wires.
     
  28. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    It’s been a nightmare so far. Shop is one of the best in the state, if not THE best and they are scratching their heads at this one as well.

    I’ll suggest them to use a multimeter and check the cables and wires. The asked for the car back to investigate further. They’re going to do a digital compression test using a pressure transducer just to be sure mechanically the engine is ok, which they said it is very unlikely it is not. They were very impressed with how well maintained the used engine was during installation.
     
  29. AlS3BE

    AlS3BE Well-Known Member

    998
    446
    63
    Could it be a knock sensor thats broken or not fitted properly? Not sure how it all works in the s3. I’m going by experience with older cars I’ve had and I’m running out of ideas now.
    Plugs, coils, check out ok. Injectors relatively new.
    New air filter as well so air supply is fine.
    So your suck, squeeze, bang, blow(think that’s the right order) , you have your suck(well blow from turbo), squeeze(assuming pistons and rings are ok on replacement engine), bang is your issue even though plugs and coils check out, blow is just exhaust.
    Your ecu controls the bang using data from various sensor so it’s going through them all I guess and the cabling to all the sensors.
    Strange thing is if it was a sensor I would guess it will affect all cylinders not just 1.
    Old cars were so much easier to mess with:wink:
     
  30. Invicta

    Invicta Active Member

    102
    57
    28
    Probably an ECU fault. Should've been your first port of call with remapping bringing common faults. Did the misfiring start before your remap, during or after it was flashed?
     
  31. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    Check engine light for the first misfire came on about a year after it was flashed.

    After that I flashed it back, and shop detirmined it needed a new engine after extensive testing. Bought and installed a replacement engine. No check engine light or fault codes have appeared after the engine swap. Car is stock.

    But, misfires are still happening on cylinder 4 during cold starts, with all other cylinders logging 15-25 misfires only after a long 1.5 hour drive (which may be normal and in spec according to Audi).

    Still could be a glitched ECU but they said it can’t really be tested. Only way is to replace it and see if it solves the problem.
     
  32. Invicta

    Invicta Active Member

    102
    57
    28
    This truly is an odd one. I appreciate the info and updates you have given, though. I hope that you get to the root of the problem and update us when you. Next port of call would be the fuel pump, I don't work on light petrol vehicles, only HGV diesels but I assume you'll have a high pressure pump still which would be my next port of call.

    • Main component the ECU will alter to enhance performance - probably works in a similar way to a tuning box and just reprograms the ECU so that it thinks that supplying 20% more fuel, for example, than usual is completely normal
    • A component that has been reused from the old engine
    • Over fuelling would cause an increase of temperature in the cylinders
    But for it to happen a year after the ECU was flashed to factory is even stranger, but very well be a glitch.
     
  33. Avatar

    Google AdSense Advertisement


  34. AlS3BE

    AlS3BE Well-Known Member

    998
    446
    63
    The thing is ecu is one of those things that you can’t borrow from someone and plug in and see if it works. There probably a **** load of coding to do as well.
    Being such an expensive item I would try to rule everything else out first.
    Could the tuner have flashed the wrong map back when they removed the tuned map? Is it worth going back and see if they can try and flash another factory map on?
     
  35. Damo S

    Damo S Active Member

    168
    67
    28
    Ive been digging around the net to see if I can find some info on my current running problem, but thought of you when this came up:

    Failing pcv valve symptoms:

    • Engine misfires at idle.
    • Lean air-fuel mixture.
    • Presence of engine oil in PCV valve or hose.
    • Increased oil consumption.
    • Hard engine start.
    • Rough engine idle.
     
  36. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    I could, but they don’t think it’s the ECU. They said other faults would show up most likely. They’re in the same boat as you, they’d rather rule out everything else, first.

    Thanks for thinking about me! The PCV valve was the first thing I checked myself. Took it off and inspected it and the hoses, found nothing wrong. I would think Audi and the independent shop would have checked as well.

    Funny thing is, the misfires started going down after the stock tune was applied. Ran it for a couple weeks and the cold start misfires went down to 7 at most in cylinder 4 only.

    After I told the shop that, they wanted to re-flash it back to the APR high-torque file and continue to monitor, which I did. Wow, so much more power and great throttle response. Car drives great.

    However, on the drive home (about 18 miles/35 minutes) it logged the following misfires, which are higher than normal for this duration of a drive:

    Cylinder 1 - 20
    Cylinder 2 - 12
    Cylinder 3 - 16
    Cylinder 4 - 10

    Maybe this is normal and acceptable for an APR tune? I’d love to know if anyone else is able to do some logging and see how many misfires their car get for a 30 minute drive for comparison sake. I haven’t been able to find anyone who’s logged them.
     
  37. AlS3BE

    AlS3BE Well-Known Member

    998
    446
    63
    I would be taking that apr tune off before you melt another engine. Not trying to be negative but not a good idea to mask a problem with a tune.
    What are you using to log your misfires?
    Is it turning the management light when this happens?
    When I get my car back I will see if it logs any misfires but last time I ran a full scan with vcds I didn’t find anything.
     
  38. CoffeeAndJam

    CoffeeAndJam Member

    30
    1
    8
    I completely understand. I don’t see it as being negative! I don’t want another melted engine, either. The shop that’s helping me is one of the best in the state, and I guess I’m trusting them with their recommendations and course of action. They want me to monitor it as they don’t think there’s any problem with the car right now and think the misfires are within operating spec, or it would be throwing a code or trigging a CEL (which it hasn’t since the engine was installed last month).

    I don’t have VCDS. Wish I did. I’m using OBD Fusion on my iPhone, connected to a Kiwi Bluetooth/WiFi OBDII reader. Not sure what you mean by turning management light... sorry. No light comes on anywhere, if that helps!
     
  39. AlS3BE

    AlS3BE Well-Known Member

    998
    446
    63
    Management light is cel. It’s probably good it’s not lighting up the cel but the fact it’s logging it 10-20 times across all cylinders would worry me but then I don’t know if that’s normal or not. I would say any misfire isn’t normal and should be looked into.
    If misfires are worse with the remap then I would be more inclined to remove it.
    Ran out of ideas what to look at now if everything checks out.
    Have you tried higher octane fuel or some octane booster? One of my old cars was bad for misfires if I used normal unleaded instead of super/premium unleaded.
     
  40. Damo S

    Damo S Active Member

    168
    67
    28
    My car is not behaving at present (on going problem), but this is what I got from this mornings drive:

    1 - 195
    2 - 1
    3 - 1
    4 - 1
     
  41. AlS3BE

    AlS3BE Well-Known Member

    998
    446
    63
    Wow 195! Did this light up the cel?
     
  42. Damo S

    Damo S Active Member

    168
    67
    28
    nope
     
  43. AlS3BE

    AlS3BE Well-Known Member

    998
    446
    63
    Maybe it’s normal for these cars to misfire but would have thought anything more than a handful would light up the cel.
    Could it be the exhausts cackle that’s misinterpreted as misfires by the ecu? Or a generic code logged by the obd reader that’s misinterpreted?
    Only real way to tell is get it on a dyno and replicate to see what’s actually happening. key thing in a boosted car is not to run lean so will get that checked.
     

Share This Page