Solid brake pedal after hard acceleration


Registered User
Jul 16, 2019
Reaction score
Has anyone ever had issues with a solid brake pedal after hard acceleration? My cousin had the same in his TT and never got to the bottom of it. What I know so far is that if my foots down, I can’t tap the brake at all (heel/toe action), and when I come off the accelerator, for a second or so, the revs stay where they are, if not even rise for a little, and in that time I can’t depress the brake pedal. This is obviously quite worrying at times.
My thought is possibly something like a laggy throttle position sensor?
Any previous experience would be great.
Cars a 54 plate 3.2 v6 A3

You can’t depress the throttle and brake at the same time, ecu prevents this as a safety feature. Ok for joe public but not for true enthusiastic drivers.
Ah ok. It’s like a vacuum thing stops the pedal from going down, presumably controlled by the ecu. Is there a way to override this? I’m not looking to heel toe, I’d just like the ability to brake sharply if needed after having the right foot down. My thought was possibly the TPS not recognising the foot coming off the accelerator quick enough
I have the same car as you and that isn’t normal. Foot off throttle and I can apply the brake immediately.

Your issue doesn’t sound safe to me.
I’ve just done a 160 mile drive and tried to replicate your symptoms.


I can full throttle then brake, brake with foot on the throttle and revs drop instantly.

I suspect there is an issue and it’s not the ecu cutting in.
I tried this last night as it doesn't make sense, and I can confirm I headbutted the steering wheel when stamping on the brakes with my left foot while accelerating (Y)

I am in a 2008 S3 though ,but it just doesn't sound "right"
Haha thanks for trying for me. Yes, doesn’t make sense. Like I say, only think I can think of is that either the throttle position sensor isn’t registering my foot coming off the gas quick enough, OR, whatever valve it is that opens to release the air from the brake pedal isn’t opening as quick as it should.
This only happens when I’m full throttle though, no other time. Maybe a vacuum issue (to the brake servo)? God knows. I was hoping someone on here had had the issue and solved it
So, an update and solution to help anyone in future. It turns out it was a split vacuum pipe. The pipe in question is the one that goes from the throttle body to the brake servo. Changed it for a new one, and no more solid brake pedal.
Hopefully this helps someone in future. Thanks for the input to everyone who replied


  • 66D96EA3-C99A-46C4-88CA-5CD34B1EAA3A.jpeg
    783.1 KB · Views: 173
  • Like
Reactions: Simply D, samuelh_888 and ahtcap