1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Water in passenger footwell

Wagon Wheels Jul 14, 2020

  1. Wagon Wheels

    Wagon Wheels Registered User

    32
    12
    8
    I'm having water ingress to the passenger side footwell, usually when cornering. The other half isn't so pleased when her feet get a cold shower. It seems like rain water sitting somewhere then being displaced but can't for the life of me find the source. I've had the battery out and removed the rubber grommet which was holding a lot a water in there. That helped, but it still happens now to a lesser extent. Any other ideas??

    Cheers
     
  2. Avatar

    snack-media
    Advertisement


  3. norad97

    norad97 Registered User

    695
    135
    43
    There is another rubber grommet under the brake servo you need to clean that one out as well,
    so you will have to remove the battery and tray to get to it.
     
  4. Wagon Wheels

    Wagon Wheels Registered User

    32
    12
    8
    Thanks for the tip! I managed to reach it just from underneath and yeah it was full of crud. Will see if that helps after next rain shower :)

    Cheers
     
  5. Wagon Wheels

    Wagon Wheels Registered User

    32
    12
    8
    Happened again today, so started digging by removing the glove box. Seemed to be coming down the outside corner and falling through a little rectangular hole on the plastic. Footwell carpet is soaking in the corner and insulation on back of the glove box too. So went on to remove the cabin filter assembly which is directly above that corner. Found a mass of leaves & **** which were absolutely sodden and blocking up the channel at the back which looks like is for any water in there to run around. Cleared it out and now trying to dry the carpet and glovebox lining! Hopefully that fixes it, we shall see. Also getting a new cabin filter tomorrow as the one in there was mank.

    Cheers

    IMG_20200716_154452.jpg IMG_20200716_154435.jpg IMG_20200716_155443.jpg
     
  6. norad97

    norad97 Registered User

    695
    135
    43
    I am sorry to say that looking at your picture I'm not supprised its leaking, not sure how long you had the car but it looks pretty grubby
    under there.
    We all know about the water that can build up in the bulk head under the battery and servo, so we have to check these,
    well I do especially before the winter and clear out any leaves etc.
    So let's hope you have solved it now, wet carpet can take time to dry and cause condensation.
     
  7. Wagon Wheels

    Wagon Wheels Registered User

    32
    12
    8
    Yeah i've not had it too long and i'm not one for going mad about engine bay cleaning, but saying that i've never had a car with so many hidden areas where dirt and water can accumulate!

    Cheers
     
  8. Wagon Wheels

    Wagon Wheels Registered User

    32
    12
    8
    Niagara falls is back. There seems to be a square hole right in the side of the cowl area and I can watch rain fall right off the dash into it. It has a plastic pipe coming out of the hole which clips onto the cabin filter assembly then goes nowhere else. I thought this hole must drain into the wing and out the wheel arch but now I don't think so. Anyone know what this pipe is for and if I can remove so I can plug up the hole? You can just see it in this pic. Cheers.
     

    Attached Files:

  9. tr7

    tr7 Registered User

    283
    80
    28
    Sorry can't help bud. I did have this happen on another B7 of mine and had no idea how it was getting in.

    Let us know if you do find the solution
     
  10. norad97

    norad97 Registered User

    695
    135
    43
    Plastic pipe is for the battery vent, mine comes out of the battery, clips to the cabin filter housing.
     
    Wagon Wheels likes this.
  11. norad97

    norad97 Registered User

    695
    135
    43
    20200801_115740.jpg
     
  12. Avatar

    snack-media
    Advertisement


  13. Wagon Wheels

    Wagon Wheels Registered User

    32
    12
    8
    Thanks norad, that explains a lot. My battery doesn't have a vent port, hence the plastic tube just hanging free at that end. Seems to be attached where it enters the wing? at the other end so can't just be pulled out. Would be interested to know if there's meant to be a grommet there? as I certainly don't have one, assuming that's what my problem is...
     
  14. norad97

    norad97 Registered User

    695
    135
    43
    I don't have a grommet in mine, but I have no leaks.
     
  15. Wagon Wheels

    Wagon Wheels Registered User

    32
    12
    8
    Yeah that's the thing I could be barking up the wrong tree entirely :) I've just put a glob of silicone over the hole, once the carpet dries (again) i'll test in the next rain shower.

    Cheers
     
  16. norad97

    norad97 Registered User

    695
    135
    43
    I not sure if the water is coming in there, but it wont hurt to seal it.
    I assume you have an updated picture of that area, hopefully looks cleaner.
    I would check the metal closely to make sure there are no rust holes anywhere, and around the pollen fillter housing.
     
  17. I'm Just Rob.

    I'm Just Rob. Moderating or something, Staff Member Moderator Gold Supporter VCDS Map User

    14,824
    6,875
    113
    Just a random thought chaps, i take it the car leaks whenever it rains then, or just heavy down pours.
     
  18. Wagon Wheels

    Wagon Wheels Registered User

    32
    12
    8
    I'm changing my mind on that now lol. Heavy rain past two days sitting out in it and was still bone dry. Normal driving this morning was fine. Some spirited cornering this afternoon and wet again. Had the air con on blast and the water does seem cold. Its like it is dripping straight down off the circular plastic piece that's directly under the cabin filter assembly back of the glove box, but where is starting out from I've no idea. :blue:

    Cheers
     
  19. norad97

    norad97 Registered User

    695
    135
    43
    Post a picture, could be from the aircon, maybe the drain is disconnected and running in the car.
     
  20. Wagon Wheels

    Wagon Wheels Registered User

    32
    12
    8
    This is the only part that felt wet to the touch:
    1.jpg
    I've been running with no glove box, so this time i could see where it starts on the carpet and only this area was actually wet. The carpet higher up and behind was still dry. It wasn't soaked through, so must have only just happened on that last drive. I've just looked at all the cowl area under the bonnet too out of interest and it's dry.
    2.jpg

    Cheers
     
  21. norad97

    norad97 Registered User

    695
    135
    43
    What you have highlighted in the picture is the blower fan, it's possible it has water inside and it's possible your heater matrix is leaking.
    I would remove the fan but put a plastic under it first incase of water drops.
    Do you have any misting on the windscreen when the fan is running, put it on demist to screen and check.
     
    Wagon Wheels likes this.
  22. Wagon Wheels

    Wagon Wheels Registered User

    32
    12
    8
    Never had misting on the windscreen. The AC/heat has always worked fine. I got a couple of small bolts out the bottom of the fan assembly, the third bolt is ridiculous to access, can barely get a finger tip on it never mind a socket. It dropped down a bit and there was a little moisture on the rubber seal, see pic. Looks like a b1tch to get the thing out as it all seems to be one unit that carries on behind the centre console?

    3.jpg

    Cheers
     
  23. norad97

    norad97 Registered User

    695
    135
    43
    Last edited: Aug 6, 2020
  24. Pie-eyedpiper

    Pie-eyedpiper Registered User

    681
    284
    63
    Try running your car without the aircon on so the condensor isn't condensing.
    It does sound like the outlet pipe could be wrongly routed. That way you can rule out the aircon being the issue.
     
  25. norad97

    norad97 Registered User

    695
    135
    43
    Wagon Wheels likes this.
  26. norad97

    norad97 Registered User

    695
    135
    43
    So what was the outcome, it would be good to post an update?
     
  27. Wagon Wheels

    Wagon Wheels Registered User

    32
    12
    8
    Update :)
    The week before last still present, then last week no problems and did a bit of driving with and without ac on throughout the week. Had an Audi tech friend go over it at the weekend, leak test from outside and went over everything from engine bay to under dash. Couldn't find anything and couldn't 'make' it leak! Only small thing he found was some junk in the draining tube, not blocked, but cleaned it out anyway. Had torrential rain since then and it's still dry. Not really sure if it's resolved! Time will tell I guess.

    Cheers
     
  28. norad97

    norad97 Registered User

    695
    135
    43
    Well let's hope its stopped, all the heavy rain we just had will cause a leak if there is one.
     
    I'm Just Rob. and Wagon Wheels like this.
  29. Alex Holmes

    Alex Holmes Registered User

    801
    357
    63
    Water leaks are a nightmare to diagnose. The carpet in my passenger foot well gets damp for some reason every now and again, not the accessory floor mat just the carpet underneath can't seem to figure it out but leaves a nice musty smell in the car the following moring
     

Share This Page

Do Not Sell My Personal Information