Help needed with cruise control

jord9412

Registered User
Tried following this guide

http://www.audi-sport.net/xf/threads/cruise-control-installation-guide.191791/

got stuck at the bit where i actually put the cruise control stalk on theres no way it will go on, on the guide it says just pull the stalks foward and split the cruise control one on..that was never going to happen. Did some googling read another guide and it says that i needed to talk off the wiper stalk and indicator stalk.... i tried doing that and it still didnt help at all...So i just tried putting it all back together as ive had enough.

Problem is now pretty sure i havent put the indicator stalk back on properly or have possibly damaged it and now my left indicator is always on and i cant indicate right....

Losing my marbles with this, is there anyone near the Hull area who has done this before and can help me out? ill pay of course.

Gonna have a crack again tomorrow at trying to fix the indicator as when i took it off it came off in like 3 parts i think.
 

Rackers

Registered User
I had the same problem, you literally have to pull it forward (plastic feels like it will break) but you can get it just far enough to plug in.

Nearly broke my indicator stalk as well, try and dismantle it and have another go!
 

jord9412

Registered User
I had the same problem, you literally have to pull it forward (plastic feels like it will break) but you can get it just far enough to plug in.

Nearly broke my indicator stalk as well, try and dismantle it and have another go!
Yeah think i need to go to scrap yard in morning and just buy another stalk as i could probably fix it but would take me ages as the parts are that small, Thinking back the indicator stalk has 4 screws on it and i think 2 or 1 of them are to just hold the stalk together and the other 2 or 3 are to secure it in place and i unscrewed all 4 and took apart the stalk by accident...
 

Rackers

Registered User
Good idea, I don't know how I managed to get mine back together as the springs and electronics all popped out of the stalk!
 

Sumner

Registered User
From reading the pinned post installation guide on this forum there are 3 clips to undo b4 pulling the stalks forward
 
Top