Heated mirrors

19ryanh93

Registered User
Hi all

Has anyone else had issues with heated mirrors?

2nd 8P ive has and the passenger side mirror seems to have stopped heating.

I know these mirrors are quite expensive so a bit wary about replacing them

Thanks


Sent from my iPhone using Tapatalk
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
Yes the elements can go or a common issue is the spade connectors either become corroded & a dremel with wire brush resolves or the connector on the mirror breaks of.

Swap mirrors over & see if it works on that side with driver mirror & vice versa.
 

George Kost

Registered User
How can you activate the heated mirrors on demand?
I remember when I removed the drivers mirror on the past that it had the two cables connected on it. Not sure if the passenger has it also.
But how do you activate them?
 

Abi

Registered User
How can you activate the heated mirrors on demand?
I remember when I removed the drivers mirror on the past that it had the two cables connected on it. Not sure if the passenger has it also.
But how do you activate them?

Turn on the heated rear window and make sure the electric mirror adjustment control is in the centre position


Sent from my iPhone using Tapatalk
 

henkkeumus

Dutch Retrofitfanatic
Turn on the heated rear window and make sure the electric mirror adjustment control is in the centre position


Sent from my iPhone using Tapatalk

You sure? Mine always turn on, no matter what position the control is in my drivers door.
 

19ryanh93

Registered User
Yes the elements can go or a common issue is the spade connectors either become corroded & a dremel with wire brush resolves or the connector on the mirror breaks of.

Swap mirrors over & see if it works on that side with driver mirror & vice versa.

Think it’s totally gone. The silicone pads are loose on the connectors? Do you know how much a replacement is? Problem I’ve got is it’s dimming and heating and last time I asked Audi they said about £300 inc vat


Sent from my iPhone using Tapatalk
 

henkkeumus

Dutch Retrofitfanatic
Think it’s totally gone. The silicone pads are loose on the connectors? Do you know how much a replacement is? Problem I’ve got is it’s dimming and heating and last time I asked Audi they said about £300 inc vat


Sent from my iPhone using Tapatalk

Could you share a pic, not sure what you mean with this.
 

19ryanh93

Registered User
Could you share a pic, not sure what you mean with this.

I don’t have it off now. I’m going to take it off again when I have the stuff to clean all the terminals up but the spades were absolutely solid and took some wiggling off. I’m going to test it properly when I get it off next.


Sent from my iPhone using Tapatalk
 

ab1702

Registered User
Think it’s totally gone. The silicone pads are loose on the connectors? Do you know how much a replacement is? Problem I’ve got is it’s dimming and heating and last time I asked Audi they said about £300 inc vat


Sent from my iPhone using Tapatalk
Just keep an eye on eBay etc. I managed to find a heating and dimming one for £45 brand new last year. Still not got round to fitting it though, it’s got the same problems as yours has.
 
Top