Desperately need help, MOT failure.

Smeds

Registered User
Hello All!

I've had a problem with my passenger wing mirror for the last couple of years, but its just caused it to fail the MOT. Had it investigated but the garage can't find the cause. The main issue is that the indicator doesn't work.
Plugged a new unit in but still didn't work. Not sure how long the indicator hasn't worked, certainly passed the MOT last year, so not sure why it's an issue now.

The mirror will also not dip on the switch, tried two new switches. The mirror folds and if I remember correctly from the last time we had frost, it also heats.

Had it into my normal mechanic recently and they ran loads of tests but got nowhere. They say that when hooked unto the computer and they use the switch, it is seeing the message on, then when the send a message to the mirror, it responds correctly. I assume it was all done in VCDS monitoring etc.

I'm taking it back to the normal garage in the morning for another go, but none of us are optimistic at the moment, anyone seen anything like this before?

Any suggestions? Worried I'm just going to have to PX it before the old MOT expires.

help...
 

EXSpartan36

Active Member
VCDS Map User
Get them to check the wiring loom for any broken wires in the grommet between the A pillar and the door. Seen it on a lot of cars where broken wires in that loom cause all sorts of different issues.

What year is your car? Ill see if I can dig out the wiring diagram.
 

RS3 S.

Registered User
As above,sounds electrical. Good auto electrician sort sort it.
 

EXSpartan36

Active Member
VCDS Map User
I've had a look at the diagram at it seems to be feed straight from the passenger door module. It is a yellow wire on pin 11 and a black/blue wires in pin 3. Check that wiring and the wiring between the door and the A-pillar. If all that is ok you are possibly looking at a new door module.
 

Smeds

Registered User
Fortunately I was able to get it over to Dan at Turner Race Developments. Fantastic work and he had the indicator sorted in a few minutes, the mirror is still screwed but I can live with that. Thanks all for the help, very much appreciated. MOT passed and panic over.
 

Smeds

Registered User
I've had a look at the diagram at it seems to be feed straight from the passenger door module. It is a yellow wire on pin 11 and a black/blue wires in pin 3. Check that wiring and the wiring between the door and the A-pillar. If all that is ok you are possibly looking at a new door module.
The door card is still partly off so will have a look at this, cheers.
 

Smeds

Registered User
I've had a look at the diagram at it seems to be feed straight from the passenger door module. It is a yellow wire on pin 11 and a black/blue wires in pin 3. Check that wiring and the wiring between the door and the A-pillar. If all that is ok you are possibly looking at a new door module.
Seems like the module is at fault, are they easy to change, whereabouts are they?

Cheers
 
Top