Facelift Coding light sensor without long coding?

Fraysa

Registered User
Hey everyone.

After successfully replacing the light switch and humidity sensor to a light sensor on my friend’s 2017 A3, we stumbled upon an issue where my VCDS cable doesn’t support his BCM when going into coding on Cent. Electronics.

After reading online, it seems HEX+CAN only supports models up to 2015 and I need a new cable (HEX+NET).

Although, I could go into adaptions. My question is - can I use adaptions to enable the light sensor? I remember in the long coding helper in my 2013 it was just one tick, and here I couldn’t find it.
 

larbel

Registered User
If you can get into adaptation then it's not Hex-CAN/Net issue, the newer BCM has no long coding at all, it just shows 000000000... Is that what you're getting? Everything is done through adaptation on newer BCMs.
 

Fraysa

Registered User
If you can get into adaptation then it's not Hex-CAN/Net issue, the newer BCM has no long coding at all, it just shows 000000000... Is that what you're getting? Everything is done through adaptation on newer BCMs.

It says “the BCM module does not support coding, you can use adaption” or something like that.

Do you know what adaption is required for the light sensor? On my 2013 I went into long coding and it was just enabling one byte.
 

larbel

Registered User
Exactly as it says... Newer BCM doesn't support coding... This is what I have...

Assistance light functions:
Regen_Lichtsensor:
LIN_Regen_Licht_Sensor
Feuchtesensor:
installed
Assistenzfahrlicht bei Regen:
active
Sonnensensor:
not installed
LS_Error_Ausgabe:
active
Maskierung_Regenfunktion:
not active
Lichtsensorempfindlichkeit:
normal

Light sensor:
Einschaltgrenze_CHO_LHO:
600 lx
Daemmerungsgrenze, Hysterese_obergrenze:
1200 lx
Daemmerungsgrenze_Hysterese_untergrenze:
2200 lx
Helligkeitsgrenze_sehr_hell:
2000 lx
Helligkeitsgrenze_Licht__einschalten:
1200 lx
Helligkeitsgrenze_Licht_ausschalten:
2200 lx
Minimale_Beleuchtungsstaerke:
0 lx
Maximale_Beleuchtungsstaerke:
6000 lx
Minimale_Ausgangsspannung:
2000 mV
Maximale_Ausgangsspannung:
4500 mV
Tunnel_einschalt_verzoegerung:
2
ECE_Lichteinschaltschwelle:
1000 lx
Helligkeitsgrenze_Licht_ausschalten_red:
50
HMI_Wiper_Comfort_Rain_Sensor_OFF:
not active
HMI_Exterior_light_on_highway:
not active
HMI_Exterior_light_on_rain:
not active
LS_Error_Ausgabe:
not active
HMI_exterior_light_sensitivity:
frueh
 

Fraysa

Registered User
Exactly as it says... Newer BCM doesn't support coding... This is what I have...

Assistance light functions:
Regen_Lichtsensor:
LIN_Regen_Licht_Sensor
Feuchtesensor:
installed
Assistenzfahrlicht bei Regen:
active
Sonnensensor:
not installed
LS_Error_Ausgabe:
active
Maskierung_Regenfunktion:
not active
Lichtsensorempfindlichkeit:
normal

Light sensor:
Einschaltgrenze_CHO_LHO:
600 lx
Daemmerungsgrenze, Hysterese_obergrenze:
1200 lx
Daemmerungsgrenze_Hysterese_untergrenze:
2200 lx
Helligkeitsgrenze_sehr_hell:
2000 lx
Helligkeitsgrenze_Licht__einschalten:
1200 lx
Helligkeitsgrenze_Licht_ausschalten:
2200 lx
Minimale_Beleuchtungsstaerke:
0 lx
Maximale_Beleuchtungsstaerke:
6000 lx
Minimale_Ausgangsspannung:
2000 mV
Maximale_Ausgangsspannung:
4500 mV
Tunnel_einschalt_verzoegerung:
2
ECE_Lichteinschaltschwelle:
1000 lx
Helligkeitsgrenze_Licht_ausschalten_red:
50
HMI_Wiper_Comfort_Rain_Sensor_OFF:
not active
HMI_Exterior_light_on_highway:
not active
HMI_Exterior_light_on_rain:
not active
LS_Error_Ausgabe:
not active
HMI_exterior_light_sensitivity:
frueh

Thank you so much, I’ll try that.

Do you know about the coming/leaving home lights? Managed to enable it on MMI, are there anymore setting needed?


Sent from my iPhone using Tapatalk
 

larbel

Registered User
There're like whole bunch of stuffs need to be activate... LC5, RB1, LB45, RB5, HLC10, HRA65, HA59 settings and at least 3 or 4 other settings... Just backup the adaptation and look it through, can't really help you with that...
 

Fraysa

Registered User
Okay, so after trying all the parameters you posted the car still refuses to accept the new headlight switch.

I also coded the sensor itself using the drop down menu on coding - I used 07006C (used the same coding that works on my car on his).

Anything else that I could be missing? I remember in my car it worked straight up by using the long coding helper and the sensor coding.
 
Top