1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anyone else had issue with AF requesting documents multiple times?

AU11 ALS Jan 27, 2016

  1. AU11 ALS

    AU11 ALS Well-Known Member Bronze Supporter Audi A4 Audi A3 Audi Avant Owner Group Black Edition

    717
    351
    63
    I've recently started a policy with AF for my A3 as it's being modified.. At inception of the cover they sent me the link to have my online account and within that I could upload all the required documents and complete the modified vehicle report...

    Since doing that I have had multiple emails reminding me to return the documents, I reply to these emails stating I have uploaded and clearly the team reading the responses don't read my emails, just send me the documents to complete again, failing to acknowledge that I have already uploaded.

    I think they have templates for their mails, as they read 'Further to your request, please find attached documents you requested for completion' etc etc... I'm getting pretty annoyed that they are not reading and in my last mail advised that if they can't acknowledge my emails correctly and track the documents I have uploaded then I would like to cancel the cover... Believe it or not, they then sent the blank documents again for me to complete but must have at least read the email as they said I could cancel my policy by discussing with the cancellations team...

    I've not had one apology, one explanation about what happened about the documents I uploaded... This is my first private insurance policy in 18 years and not a great experience so far....

    I've asked for a CS Manager to contact me tomorrow to discuss my experiences and I will see what happens then... My 14 day cooling off period ends on Friday...
     
  2. Avatar

    Google AdSense Advertisement


  3. AU11 ALS

    AU11 ALS Well-Known Member Bronze Supporter Audi A4 Audi A3 Audi Avant Owner Group Black Edition

    717
    351
    63
    After emailing to say ninjas uploaded, latest response said they hadn't received any attachments to my emails... No sh*t, that's cos there weren't any I used the upload function, why not read my emails!!
     

Share This Page