1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

very confused/frustrated!

Discussion in 'A3/S3 Forum (8L Chassis)' started by huffy123, Sep 26, 2012.

  1. huffy123
    Offline

    huffy123 New Member

    Joined:
    Sep 26, 2012
    Messages:
    4
    Likes Received:
    0
    Hi Guys, i have an audi a3 1.9tdi 1997, a few weeks ago had the catylytic convertor changed after failing the MOT, and a few minor thing(not sure what as the wife dealt with it as i was away) and all was fine, then all of a sudden the glow plug light came on whilst i was driving, i was passing a local indie garage, asked if they could have a look only to be told they didnt go back that far with their software, but should be ok to drive it till i found somewhere that had the software. i stopped using the car that day, went back to it started as normal, no glow plug lamp staying on, so carried on using it as normal, few days later, struggled to start but did eventually, and carried on as normal, then one day started, tried to reverse out of parking spot and car cut out each time i tried reverse, put in 1st and worked so drove of to get home, had to stop unfortunately, and when returned to car wouldnt entertain starting, no glow lug light at all on turning key, car turns and tries to start just wont, had to call the aa, they played with relay 109 to no avail, and towed car home, had mate look at it, and replaced relay 109, same issue, sent ecu off for fault finding, sent back no faults found, so fitted to car, started and acted as normal, got in after work to drive back had to reverse, cut out again, 1st was ok had to move car to parking spot, turned off, and tried again, no glow plug light.
    if leave the car few hours it starts until put in reverse, the next turn of key starts but then as release key it cuts out, then tries to start to no avail.


    would take to garage to try find a fault code but unable to start to move it from work, cant get it towed for various reasons at the moment either.

    any help suggestions greatfully recieved, sorry for the long message but trying to get as much info in as i could

    thanks in advance
    #1
  2. Sevv
    Offline

    Sevv Pushing the limits..

    Joined:
    Jan 27, 2011
    Messages:
    1,321
    Likes Received:
    116
    [h=2]after reading abit for you mate (vwaudi forum) quick google search hope this helps

    Re: glow plug light flashing all the time[/h] 16705/P0321/000801 - Engine Speed Sensor (G28): Implausible Signal

    Possible Symptoms



    • Engine shuts off
    • Engine doesn't start
    • Speedometer inoperative
    • Glow Plug Indicator Lamp (K29) flashes

    Possible Causes



    • Engine Speed Sensor (G28) loose
    • Engine Speed Sensor (G28) faulty

    Possible Solutions



    • Check Engine Speed Sensor (G28)

    Special Notes



    • The Engine Speed Sensor (G28) is also used as a reference sensor for the crankshaft position and correlates with the Camshaft Position Sensor Bank 1 (G40) and Camshaft Position Sensor Bank 2 (G163).
    • When found in a VW Golf/Jetta (1J/9M) or Audi A3 (8L) with 1.9l TDI-PD (AXR), check TPI 2007067 which explains issues with electro magnetic interference. A modification to the wiring will fix this problem, extensive details can be found in the named TPI. Even though this TPI was originally released for VW Golf/Jetta (1J/9M), a customer of ours came across the same issue on an Audi A3 (8L).
    • When found in a 2004 VW Golf, Jetta, or New Beetle with 1.9l TDI-PD (BEW), check for TSB 2010461 (01-07-45 formerly 97-05-03) or 201463 (01-07-44 formerly 97-05-04) calling for a flash update to the ECU and a secondary ground installation.
    #2
  3. Sevv
    Offline

    Sevv Pushing the limits..

    Joined:
    Jan 27, 2011
    Messages:
    1,321
    Likes Received:
    116
    a guy with the similar problem had this issue (with your glow plug on as you have said)

    hi alan,i have had the code read done it said ENGINE SPEED SENSOR G28 IMPLAUSIBLE SIGNAL PO321,it was cleared and the flashing glow plug light dissapeared,ware is the engine speed sensor located and does this mean it needs replacing if so have you any idea what they cost.thanks for the help so far dave.


    if you wanna have a read...

    Please Help glow plug light flashing all the time
    Last edited: Sep 26, 2012
    #3
  4. huffy123
    Offline

    huffy123 New Member

    Joined:
    Sep 26, 2012
    Messages:
    4
    Likes Received:
    0
    Thanks Sevv, really appreciate you taking the time to do that for me, however im not really car savvy sadly, so even though i do get what the issue means etc not sure if its saying i need the wiring mod or the ecu update? but ill definately mention all this to my mechanic mate see what he makes of it, thanks again.
    #4
  5. Sevv
    Offline

    Sevv Pushing the limits..

    Joined:
    Jan 27, 2011
    Messages:
    1,321
    Likes Received:
    116
    you (MAY) need a new engine speed sensor mate.. however its best to sca the car with VCDS to tell you even more... but accordingly the issue you discribed are directly related to that fault code
    #5
  6. huffy123
    Offline

    huffy123 New Member

    Joined:
    Sep 26, 2012
    Messages:
    4
    Likes Received:
    0
    Thanks Sevv, spoke to my mechanic mate he is going to get the relevant kit to scan it, so hopefully ill know soon, cheers once again
    #6
  7. huffy123
    Offline

    huffy123 New Member

    Joined:
    Sep 26, 2012
    Messages:
    4
    Likes Received:
    0
    JUst a quick update, ended up getting an auto electrician round to have a look, he traced the fault to the ignition switch, 14v going in as should be, but only5-6v out to the various areas it was supplying, when put in reverse it surged and shut the car down, replacing the ignition switch seems to have cured it, hope this helps anyone with a similar problem
    #7

Share This Page