1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Steering Angle Sensor - Implausible signal

Discussion in 'VCDS (formerly VAG-COM) forum' started by Wrath, Aug 14, 2010.

  1. Wrath
    Offline

    Wrath Well-Known Member

    Joined:
    Apr 7, 2009
    Messages:
    1,189
    Likes Received:
    41
    [Aug 14, 2010]
    I've got a B7 A4 and have just changed over the slip ring, steering control module, steering wheel and fitted cruise. I've gone through the Rosstech steering sensor calibration nearly 8 times but the ABS light is still on and I constantly get this error:

    Address 03: ABS Brakes Labels: 8E0-910-517.LBL
    Control Module Part Number: 8E0 910 517 B HW: 8E0 614 517 AT
    Component and/or Version: ESP8 front H04 0180
    Software Coding: 0004401
    Work Shop Code: WSC 06335 000 00000
    VCID: 26470E99E88F
    Fault Codes have been Erased
    1 Fault Found:
    00778 - Steering Angle Sensor (G85)
    008 - Implausible Signal
    Freeze Frame:
    Fault Status: 01101000
    Fault Priority: 2
    Fault Frequency: 1
    Reset counter: 40
    Time Indication: 0
    Freeze Frame:
    Hex Value: 0x0000
    Hex Value: 0x4222
    Hex Value: 0x00FF
    Hex Value: 0xFFAE
    Hex Value: 0x00FF

    The other interesting thing is that in the ABS screen, the alignment status reads "locked" as opposed to "OK".

    I know the steering control module came from an RS4, would it be this?
    #1
  2. Ads

    Ads

    [Nov 24, 2014]

  3. Watty
    Offline

    Watty ..... (_!_) Sarah's A3s #1 Fan

    Joined:
    Sep 8, 2007
    Messages:
    404
    Likes Received:
    0
    [Aug 14, 2010]
    Hi Mate, just trying to help as I've just had the G85 fault on an A3 8P.

    Try this. Sit in the car, engine running, turn wheel one full turn right, the back to central continuing one full turn left, then back to centre and drive SLOWLY forward (although mine was in reverse), and it should calibrate itself.
    #2
  4. Wrath
    Offline

    Wrath Well-Known Member

    Joined:
    Apr 7, 2009
    Messages:
    1,189
    Likes Received:
    41
    [Aug 15, 2010]
    Thanks Watty, unfortunately it didn't work so I still have that irritating ABS error cropping up. B5NUT provided a lot of assistance and did mention that the RS4 has two ECU's and maybe this has caused issues.
    #3
  5. 1wheelonly
    Offline

    1wheelonly cabriolet VCDS Map User

    Joined:
    Oct 14, 2007
    Messages:
    2,081
    Likes Received:
    7
    [Aug 15, 2010]
    make doubley sure that the modules are connected to gether correctly, i have had a couple of issues of people with bent pins on the sensor !!!!! therefore not connected correctly !!!!!!!!
    worth a look
    my ring and module is from an rs4 for my flatbottom and havent had any issues.
    is the angle sensor showing any readings in measuring blocks when you turn the wheel ?
    #4
  6. Wrath
    Offline

    Wrath Well-Known Member

    Joined:
    Apr 7, 2009
    Messages:
    1,189
    Likes Received:
    41
    [Aug 15, 2010]
    I need to borrow some torx drivers off B5NUT to take the cowling off to check everything is plugged in. The angle sensor does show readings when the wheel is turned but I can't complete the calibration as it reads "alignment status locked". At least I know that an RS4 module should be fine.
    #5
  7. Watty
    Offline

    Watty ..... (_!_) Sarah's A3s #1 Fan

    Joined:
    Sep 8, 2007
    Messages:
    404
    Likes Received:
    0
    [Aug 16, 2010]
    Ok, sorry mate. Forgot to say, but when doing that I did have the vagcom /vcds cable plugged in on laptop loaded up with the steering wheel fault open. Best of luck with it and also 1wheelonly knows his stuff.
    #6
  8. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,471
    Likes Received:
    1,262
    [Aug 16, 2010]
    Yeap as Lea says this sounds like the parts are misaligned & pins bent as its not seeing the module plugged in I'd say, take apart & check & reassemble carefully, this seems to happen fairly easily on the 8E IMHO, seen fair few of these type threads in the past.
    #7
  9. Wrath
    Offline

    Wrath Well-Known Member

    Joined:
    Apr 7, 2009
    Messages:
    1,189
    Likes Received:
    41
    [Aug 16, 2010]
    Well, I found out what the reason was. The top part of the slipring that is an actual separate module, I didn't put it on, turns out this is the G85!?! Put it back in, cleared that fault but still no cruise control and ABS lights were coming on intermittently this morning.

    Now fitted a SWCM from an S-Line but haven't hooked up VCDS yet. At least I'm well versed in getting the steering wheel off :wacko:
    #8
  10. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,471
    Likes Received:
    1,262
    [Aug 16, 2010]
    Ah that would do it for sure.
    #9

Share This Page