1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Shuddering after 2500 revs?

Discussion in 'A4/S4 forum(B5 Chassis)' started by jonnycraig, Jan 31, 2011.

  1. jonnycraig
    Offline

    jonnycraig Member

    Joined:
    Jun 27, 2009
    Messages:
    157
    Likes Received:
    0
    [Jan 31, 2011]
    Ive been noticing this over the past few days since getting the car, when sitting at around 2500 (or up to) the car is fine and drives fine. Accelerate to over take or drive with slightly higher revs the engine shudders like lack of fuel or air in the lines, not massively but its quite scary in the outside lane :/

    I dont have the expertise to be able to check for air seeping in or if the pump is working properly under load. Has anyone experienced this before and have any ideas or should I start with the simple things like changing the fuel filter?

    Thank you

    JC
    #1
  2. Ads

    Ads

    [Sep 23, 2014]

  3. durham-dazzler
    Offline

    durham-dazzler New Member

    Joined:
    Jan 10, 2011
    Messages:
    22
    Likes Received:
    0
    [Jan 31, 2011]
    When were the plugs and leads last changed?
    My polo used to have the same problem - changed the plugs and leads and it went away!
    Not sure if it'll be that simple on an audi tho... I'm just about to change them on my a4 due to a misfire, so hopefully they'll be the cause of my problems too!
    #2
  4. jonnycraig
    Offline

    jonnycraig Member

    Joined:
    Jun 27, 2009
    Messages:
    157
    Likes Received:
    0
    [Jan 31, 2011]
    Wish it was as easy as plugs and leads on a TDI lol :) Ill have a look for any visible signs of diesel leaking at the injectors but thats as much as I think I can do for now.

    Good luck with your A4
    #3
  5. terrya4
    Offline

    terrya4 New Member

    Joined:
    Feb 21, 2010
    Messages:
    3
    Likes Received:
    0
    [Jan 31, 2011]
    sorry this isn`t the best advice or information but i`ll pass it on incase it helps.

    I`v got a 2005 2.0TDI A4 s line B7 which was behaving just exactly as you are describing, unfotunatley mine got quite a bit worse over a short period of time. I took it to my local specialist who done a diagnostic and came back with a number 1 misfire which he suspected to be down to an injector but recommended trying a much cheaper remedy of a fuel additive first.
    The short version of the story is I am currently waiting to get the car back from the garage afetr it was found to have 2 f**ked injectors which cost £468+vat each plus labour.

    Hope this isn`t your problem but the info might help
    #4
  6. jonnycraig
    Offline

    jonnycraig Member

    Joined:
    Jun 27, 2009
    Messages:
    157
    Likes Received:
    0
    [Jan 31, 2011]
    Lets hope the fuel additive will sort it and not end up possibly costing more than the car's worth!!

    **Update: Additive in the fuel now so just have to do a few runs to work and back and see if its made any difference :/
    Last edited: Jan 31, 2011
    #5
  7. jonnycraig
    Offline

    jonnycraig Member

    Joined:
    Jun 27, 2009
    Messages:
    157
    Likes Received:
    0
    [Feb 1, 2011]
    Just another quick update, I drove the 34 odd miles to work this morning on a nearly full tank of fuel and the additive in there. Think its a little bit better but prob need to do a few miles for the additive to do its job.

    JC
    #6

Share This Page