1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

S4 1998 Central Locking Pump

Discussion in 'A4/S4 forum(B5 Chassis)' started by tonybolony, Oct 14, 2010.

  1. tonybolony
    Offline

    tonybolony Member

    Joined:
    Mar 18, 2010
    Messages:
    124
    Likes Received:
    1
    [Oct 14, 2010]
    Just got a pump replacement on ebay from an A4 , mine just does not work. Anyway fitted replacement, and first time i did it it worked, and the alarm armed also (via key) , then try to unlock and was ok, but now , try lock or unlock driver door with key and nothing, except maybe the fuel filler locks and unlock, then tried key in boot and heard pump make noise but no door action.

    I am now stressed, confused etc etc.

    Any help is really appreciated
    #1
  2. Ads

    Ads

    [Oct 1, 2014]

  3. Blue_Thunder
    Offline

    Blue_Thunder Active Member

    Joined:
    Feb 1, 2007
    Messages:
    1,708
    Likes Received:
    9
    [Oct 14, 2010]
    Checked the vac lines to make sure they haven't popped off the pump?
    #2
  4. tonybolony
    Offline

    tonybolony Member

    Joined:
    Mar 18, 2010
    Messages:
    124
    Likes Received:
    1
    [Oct 14, 2010]
    no they are on the pump ok, are there any other lines i can check?
    #3
  5. tonybolony
    Offline

    tonybolony Member

    Joined:
    Mar 18, 2010
    Messages:
    124
    Likes Received:
    1
    [Oct 14, 2010]
    ok here is the update, never thought a car could wind me up so lol.

    Turn key, central locking activates, also activates alra it seems, turn key to open doors, only door that unlocks is the one i use the key on, then the indicators flash like mad and the pump makes a clicking sound (guessing a relay for the indicators) , i am really stuck now and have no idea what to do :(, feel like i just wasted £70
    #4
  6. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,621
    Likes Received:
    320
    [Oct 14, 2010]
    Did the part number match exactly?

    Some pumps (facelift?) wont unlock the doors from the key, they will only unlock the doors from the remote.

    If you unlock with the key, and open the door, the alarm will go off (ie flashing lights, not sure why you not getting honking, but the siern could easily be fubar)

    Open the door and turn the ignition on, and the alarm should stop and all the doors should unlock.
    #5
  7. tonybolony
    Offline

    tonybolony Member

    Joined:
    Mar 18, 2010
    Messages:
    124
    Likes Received:
    1
    [Oct 14, 2010]
    i did try that, and the flashing kept going even though the engine started, i dont know if its and exact part number match as the original non working pump doesn't have the base on it with the part number (great hey!). I have put my original non worker pump back in now, also my window are no longer working, and my CD / Trip display has vanished (though pressing reset has brought that back). Part Number on the replacement pump is 8LO 862 257 P

    Whole thing is going from bad to worse!
    Last edited: Oct 14, 2010
    #6
  8. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,621
    Likes Received:
    320
    [Oct 14, 2010]
    OK that part number is listed against a 1998 S4.

    Is it possible the door microswitches are faulty? Craigs S4 will only unlock from the passenger side if you use the key, as the microswitch in the drivers door is dead. Open the drivers door and the rest of the car stays locked and the alarm will go off.

    Have you tried scanning the unit for fault codes?
    #7
  9. olds_kool
    Online

    olds_kool Active Member VCDS Map User

    Joined:
    Jul 21, 2007
    Messages:
    1,072
    Likes Received:
    4
    [Oct 14, 2010]
    8L0 'P' is a late a3 pump (but exactly the same as facelift a4 pump)

    correct part number for a 98 a4/s4 with remote locking would be 8L0 'G' (or 'H' without remote locking)

    if you have a remote fob? it can be coded to work with the pump and in theory would unlock all the doors (but wont work alarm siren)
    at the moment the pump is operating correctly as far as i can tell from your description but its in the wrong car and designed to be used with a remote fob
    #8
  10. tonybolony
    Offline

    tonybolony Member

    Joined:
    Mar 18, 2010
    Messages:
    124
    Likes Received:
    1
    [Oct 16, 2010]
    how do i recode the pump? , yes i have 2 remote fobs, and also the master key. Do i need any special hardware to code the pump?
    #9
  11. evilscotsman
    Offline

    evilscotsman Space Cowboy

    Joined:
    May 1, 2008
    Messages:
    1,350
    Likes Received:
    12
    [Oct 17, 2010]
    fully unlocked vag com / vcds needed mate afaik
    #10
  12. olds_kool
    Online

    olds_kool Active Member VCDS Map User

    Joined:
    Jul 21, 2007
    Messages:
    1,072
    Likes Received:
    4
    [Oct 17, 2010]
    if you have 2 keys then its easy

    remote fob coding

    1. insert key into ignition and turn on (turn one notch do not start car) does not matter what type of key as long as it is coded to the immobiliser i.e capable of starting car

    2. insert second key (fob type) into drivers door lock and turn to lock car

    3. press unlock button on fob once (indicator may flash), wait six seconds press unlock button again, car will unlock, remove key

    4. open door and remove key from ignition, close door and press lock/unlock buttons on fob, car should now lock/unlock


    to code a second fob

    follow steps 1 + 2 using second fob to be coded to lock drivers door then press unlock button twice, wait six seconds and press unlock again, then go to step 4

    up to four keys can be coded to the pump, for third key you would press unlock 3 times, wait 6 seconds etc.... if you code key two but only press once it would replace key one as you would be storing it in position one
    #11
  13. tonybolony
    Offline

    tonybolony Member

    Joined:
    Mar 18, 2010
    Messages:
    124
    Likes Received:
    1
    [Oct 18, 2010]
    wow will give that a try, thanks very much
    #12
  14. tonybolony
    Offline

    tonybolony Member

    Joined:
    Mar 18, 2010
    Messages:
    124
    Likes Received:
    1
    [Oct 18, 2010]
    just wanted to say thanks for the help, my car is now full operational on the CL etc.

    When the Alarm goes off though its just flashing lights, no horn, is there a way to get the siren going?
    #13
  15. olds_kool
    Online

    olds_kool Active Member VCDS Map User

    Joined:
    Jul 21, 2007
    Messages:
    1,072
    Likes Received:
    4
    [Oct 18, 2010]
    yes, fit the correct pump
    #14
  16. tonybolony
    Offline

    tonybolony Member

    Joined:
    Mar 18, 2010
    Messages:
    124
    Likes Received:
    1
    [Oct 18, 2010]
    lol ok, well i can live with no horn for now then :)
    #15
  17. audia4q
    Offline

    audia4q New Member

    Joined:
    Nov 30, 2013
    Messages:
    2
    Likes Received:
    0
    [Nov 30, 2013]
    hey, i can't figure out whats going on with mine. i got a problem with my power windows and locks and sunroof. i checked all the fuses and i tryed to check the relays. i'v switched the around can't still can't seem to find the problems, i just can't see this all not working at one time. please give me some kind of idea with this. i'v tryed to look at books, but it just gives me the wiring, i can't seems to figure it out. i just need someone who know's about audi's and i'm not the person that know's, so please and ideas on this.
    #16
  18. audia4q
    Offline

    audia4q New Member

    Joined:
    Nov 30, 2013
    Messages:
    2
    Likes Received:
    0
    [Nov 30, 2013]
    hey, i can't figure out whats going on with mine. i got a problem with my power windows and locks and sunroof. i checked all the fuses and i tryed to check the relays. i'v switched the around can't still can't seem to find the problems, i just can't see this all not working at one time. please give me some kind of idea with this. i'v tryed to look at books, but it just gives me the wiring, i can't seems to figure it out. i just need someone who know's about audi's and i'm not the person that know's, so please and ideas on this.
    Last edited: Nov 30, 2013
    #17
  19. Bradderz_1988
    Offline

    Bradderz_1988 Dont replace it, Upgrade it !!

    Joined:
    Aug 19, 2010
    Messages:
    3,246
    Likes Received:
    110
    [Nov 30, 2013]
    Have you checked the pump in the boot ?? Whip it off and check for any corrosion on the circuit board etc or any signs of something thats frazzled, or any signs that waters got in it !!

    all the above is controlled through the CL Pump in the boot also check to see if you have any power supply at the pump !!
    #18
  20. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,621
    Likes Received:
    320
    [Nov 30, 2013]
    As above, either the fuse has blown or the pump is dead. The pump provides an "OK" signal to the window and sunroof motors to allow them to open.
    #19

Share This Page