1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Running Issues at Cold

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by Funkyfin2000, Feb 22, 2011.

  1. pj123
    Offline

    pj123 Member

    Joined:
    Oct 5, 2010
    Messages:
    296
    Likes Received:
    9
    [Mar 23, 2011]
    I have a PD 130 AWX and when its been cold overnight the car has the same symptoms as you have for the first couple of seconds. Something i'd like to sort also. My thoughts have always been that the injectors need cleaning. I also have an old shape S3 and the others on that forum swear by removing the injectors an using an ultrasonic cleaner to clean them.

    Link here..

    Postal cleaning service
    #41
  2. ADC74
    Offline

    ADC74 Master Baker

    Joined:
    Jan 7, 2011
    Messages:
    146
    Likes Received:
    1
    [Mar 23, 2011]
    TBH Rich I have still not got round to booking it in, but when I do you'll be the first to know :thumbsup:


    I've basically got my priorities all fooked up & gone & bought some new alloys. And I'm still trying to source some door blades that don't require a second mortgage :haha:
    #42
  3. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Mar 23, 2011]
    Fair enough dude....well either way be good to see if we can get to the bottom of it....asking my mechanics opinion now on what to do next...
    #43
  4. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Apr 3, 2011]
    ADC - How about trying this. I've found that putting the ignition on for a min or so before starting improves it...or turning the car on and off constantly on the ignition seems to make a big difference.....might be worth trying yourself.

    Car is going to BVr for a week to see if they can get to the bottom of it!! :(
    #44
  5. scottie 81
    Offline

    scottie 81 Member

    Joined:
    Mar 24, 2010
    Messages:
    57
    Likes Received:
    0
    [Apr 3, 2011]
    Think you should give feathers diesel a call mate they are suppose to be shot hot with pd engines mines off on sat there
    #45
  6. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Apr 4, 2011]
    Whats up with yours Scottie??? Same problem? Be interested if you get to the bottom of it....

    West Yorkshire is a long way to go :)
    #46
  7. bizza25
    Offline

    bizza25 Member

    Joined:
    Jun 9, 2010
    Messages:
    50
    Likes Received:
    1
    [Sep 21, 2011]
    any one ever get to the bottom of this one lads?
    #47
  8. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Sep 22, 2011]
    Scottie did you get this sorted?

    I didn't get to the bottom of it, but my car now has a bit of a knocking/tapping and still smokes heavily.

    Its going in to BVR Automotive Stoke in the next few days for diagnosis. I have a feeling it could be Camshaft issues :( :(
    #48
  9. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Sep 22, 2011]
    ADC or PJ did you get yours sorted?

    Once question, those with the same or similiar issue....did you ever have your Clutch or DMF changed?

    My car is also starting to eat a bit of oil...only a little bit though
    #49
  10. espen22
    Offline

    espen22 New Member

    Joined:
    Dec 6, 2011
    Messages:
    20
    Likes Received:
    1
    [Dec 6, 2011]
    Hi!

    Did you get this sorted out ?

    Having the same problem on my passat AVF, and its driving me insane...

    Did a lot of research, and finally found a tandem pump test procedure. it seems like my tandem has a faulty backpressure regulator or some other leaks inside due to that its worn. This lets air in the system and gives you low pressure to the injectors at cold starts.
    And it will smoke and have low power too.

    So i am going to do some final tests before ordering that 200£ piece of a pump.

    If you found something else that causes this problem please let me know.

    Link to tandem pump test (its a usa car, but still same pump...) : http://pics.tdiclub.com/data/517/PD_fuel_delivery_check.pdf

    Mine failed on the check where you hook off the retur line and let the liftpump run.
    #50
  11. marktdisport
    Offline

    marktdisport Active Member

    Joined:
    Jul 14, 2011
    Messages:
    1,195
    Likes Received:
    15
    [Dec 6, 2011]
    it may be worth having the timing checked these syntoms could be seen if its incorrect...... cheap option to start aswell
    #51
  12. espen22
    Offline

    espen22 New Member

    Joined:
    Dec 6, 2011
    Messages:
    20
    Likes Received:
    1
    [Dec 6, 2011]
    Timing checked with vagcom 0-0,6 on idle. marks are there too, and the pd wont run if you miss out with more than say 3mm to each side.
    Car runs fine, and like the others it has no starting issues unless cold after staying overnight.

    Idling correction (block 13 vag-com) are good. PD status even, only the fuel flow trough injectors are some off, but in range there too.
    #52
  13. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Dec 7, 2011]
    Espen, thanks for this you are fantastic.

    I still have the same problem and just got worse now its really cold.

    Have you tried putting the ignition on constantly on off on off before starting, i find this usually helps and also may back up the theory on the tandem, as you keep forcing a flow of fuel as you are priming the lift pump presumably.

    I might just pop to my mechanics today with your guide and get mine checked!!!!!

    He did mention it could be the tandem pump....where can you get them for £200? I thought they were about £400! I did have the internal seal of mine replaced incase it was leaking internally but that wasn't the case!!!!

    Any more thoughts would be great!
    #53
  14. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Dec 7, 2011]
    The other thing, is the car really chattery if you pull away quickly after starting, its almost struggling to run, sounds awful.

    It has to be a fuel pressure thing, funny it worse in the winter though. The fuel must be thicker in colder weather!?
    #54
  15. espen22
    Offline

    espen22 New Member

    Joined:
    Dec 6, 2011
    Messages:
    20
    Likes Received:
    1
    [Dec 8, 2011]
    I did a test, mounted a check valve on retur line from tandem, this check valve has around 0.2 bar of backpressure
    I have had 2 cold morning starts now, and both were good...(cyceling ignition 2 times to build pressure)
    So that points to that the tandem pump is the problem.

    all you reading this, remeber i have ruled out all other possible errors on the engine, so i am now only left with the tandem/injectors.
    Dont start changing tandem first, unless you have done a good diagnose. you might end up spending alot and discovering that your fault was somwhere else.

    Fueltemp and coolant temp are wery important sensors for the ecu to determin how it should set ignition and fuelling on cold starts.
    Also if your Car is Remapped(chiptuned) BADLY You can have all sorts of problem since the bad remappers often do flash in files from other cars and that is not good for engine management.
    #55
  16. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Dec 8, 2011]
    Any idea where you get the check valves from? My mechanic wasn't able to get stuff the right size etc?

    Only thing I could do is take it to Audi to check the pressures as they will have the right equipment to do this.

    My mechanic also put it down to a pressure issue or injectors....everything else has been checked down to camshaft etc etc

    Getting a price today for tandem pump reknewal...probably be best part of £350 i would think!

    No map on my car....
    #56
  17. PhilW
    Offline

    PhilW Member

    Joined:
    Jul 7, 2010
    Messages:
    182
    Likes Received:
    4
    [Dec 9, 2011]
    Funkyfinm have you checked timing via vag com like espen22 has done?

    Another thing to try is to disconnect the EGR valve, pull the vac line off it and plug it with a golf tee.

    I had terrible running problems with a dodgy EGR valve and/or solenoids along with my timing out due to a bad timing belt change.
    #57
  18. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Dec 9, 2011]
    Hi Phil,

    Will check that.

    Where exactly is the vac line to the EGR? Sorry for sounding thick, do you have a pic?

    Will see if that makes a difference but I think with everything goin on, its more serious than that, either Injector related or Tandem pump. Funny, I've never had any vag com logs on anything to do with injector etc etc

    Timing has all been checked and is all spot on.

    Rich
    #58
  19. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Dec 9, 2011]
    I will certainly double check with Vag Com, can you tell me what values to check and what the tolerances should be?
    #59
  20. PhilW
    Offline

    PhilW Member

    Joined:
    Jul 7, 2010
    Messages:
    182
    Likes Received:
    4
    [Dec 9, 2011]
    Block 004 i think it is, syncro angle. Spec im sure is between -3 to +3°.

    This top hat will be sticking out of your engine cover on the top left hand corner.

    http://img155.imageshack.us/img155/2182/dsc00068bx.jpg

    Do the same as the photo.

    Also pull the hose off and look inside the EGR to see if its sooted up.
    #60
  21. espen22
    Offline

    espen22 New Member

    Joined:
    Dec 6, 2011
    Messages:
    20
    Likes Received:
    1
    [Dec 9, 2011]
    Hi, while youre in there, check block 13 (idle correction), block 19 (pd status) and block 23.
    It might be worth checking fueltemp and coolant temp on cold engine, they should read the same as outside temp!

    You Audi guys, have you tried that lightswitch trick. turn your lightswitch fully on before starting... Not kidding here, think this one made some sleepless nights for the VAG engineers :)

    I can send you the ebay link to where i bought the checks, they were cheap.. you can do the same test if you just block the hose before leaving the car in the evening(bend and clamp it with something or use one of those clamps for hose blocking...). the tandem has a built in overpressure valve so it should live a cold start with blocked retur, just dont run with it as your fueling system is looping fuel inside tandem and fueltemps will be extreme....
    #61
  22. espen22
    Offline

    espen22 New Member

    Joined:
    Dec 6, 2011
    Messages:
    20
    Likes Received:
    1
    [Dec 9, 2011]
    Did you get my answer with the adress where you can get that pump cheaper?
    #62
  23. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Dec 10, 2011]
    Thanks Phil, will try that over night and see if it makes a jot of difference.

    I doubt it will, the whole EGR valve and manifold has been off for a clean!

    It's got to be either injectors or fuel supply/pressure like espen says.
    #63
  24. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Dec 10, 2011]
    Hi Espen,

    If you have the ebay link for the check valves from etc, the right size for the AVF engine that would be great. Can you post it up.

    In terms of checking a price on the pump. £415 fitted from my mechanic, or through: germanautopartsdirect.co.uk I can get it £250 delivered (genuine audi apparantly but checking that!) and £35 fitted by my mechanic. Must be quite an easy part to change I guess.

    I will do some logging with VAG com on those blocks you mention. But I think it's already been done by mechanic and everything was in spec.

    Espen - in terms of checking the tandem wear, can I just un do no 3 inlet on the fuel filter and block it and turn on the ignition (you mentioned about powering the lift pump) Can I not just run the igition in stead. I wouldn't run the car like that of course.

    Rich
    #64
  25. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Dec 10, 2011]
    Can anyone give me the part number as well for the fuel pump for AVF car?

    Audi A4 Quattro 1.9tdi AVF engine code.

    Are the originals Bosch items?
    #65
  26. espen22
    Offline

    espen22 New Member

    Joined:
    Dec 6, 2011
    Messages:
    20
    Likes Received:
    1
    [Dec 10, 2011]
    liftpump or tandempump you need the numbers for?
    #66
  27. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Dec 11, 2011]
    tandem please dude, you need the chassis number?
    #67
  28. espen22
    Offline

    espen22 New Member

    Joined:
    Dec 6, 2011
    Messages:
    20
    Likes Received:
    1
    [Dec 12, 2011]
    038 145 209Q is the AVF tandem OEM
    #68
  29. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Dec 12, 2011]
    Thanks mate, not sure whether to bite the bullet and try it.

    Have you ordered one yet?
    #69
  30. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,804
    Likes Received:
    343
    [Dec 12, 2011]
    Sounds more like glow plugs to me, especially if cycling the ignition a few times helps as mentioned a few posts ago, as this means the pre-heat will occur for longer, putting more heat into the cylinders.

    Only takes a crappy connection on the glow plug on one cylinder to have it start lumpy and belch black smoke.

    If it was fuel pressure leaking back it would fix itself within seconds of starting, or simply crank for longer until the pressure built up, rather than taking 10-15seconds.
    Last edited: Dec 12, 2011
    #70
  31. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Dec 12, 2011]
    Ive not had trouble cranking at all, did at the beginning when i bought the car, but a new set of plugs fixed that. going to get the plugs changed again at next service just for piece of mind but doubt make any difference.

    Mine cranks up straight away no problem. Just runs lumpy and chucks out acres of smoke, then 20secs later runs smooth.

    ESN - whats the headlight trick you keep talking about?
    #71
  32. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,804
    Likes Received:
    343
    [Dec 12, 2011]
    You've got a glow plug in each cylinder, which helps the fuel mixture to combust when the engine is first started. Sure if all of them were knackered it would be a complete pig to start, but if only one plug had a bad connection, the engine would still start instantly because the other 3 cylinders will fire as they should, and the engine will run, if somewhat lumpy, on 3 cylinders. The one cylinder with the faulty plug wont be hot enough to properly burn the fuel, and so that one cylinder belches smoke until enough heat builds up in the cylinder to properly combust.

    Cycling the ignition means the plugs put more heat into the engine, before you attempt to start it, reducing the problems.

    It could be a bad connection to the plug so its not receiving full power, or simply a dead plug.

    I dont believe theres any way a fuel pressure issue would persist for 20seconds after starting the engine. Jumper the fuel pump for 60seconds then try starting if you want to prove to yourself thats not the issue.
    #72
  33. espen22
    Offline

    espen22 New Member

    Joined:
    Dec 6, 2011
    Messages:
    20
    Likes Received:
    1
    [Dec 12, 2011]
    New glow plugs, and all are tested on cold engine out of the hole, they all glowed like stars...
    My glowtime was also extended with vag com to be 100% sure that the plugs are not the issue. that was one of the first thing i checked when the problem started.
    Now only one thing can make this a glow plug problem, its if the connections goes bad when i put them in place.. but i am doing a test with my thermolaser, shooting each plug next time i glow the car and check if they all heat up evenly.

    If you dont think fuelling can cause this problem, you need to study the complexity of the PD engine, as fuelpressure/timing is wery wery important to starts and how the car runs, only a small ammount of air from a bad tandem will cause problems, and might use a good run to get out.

    As i stated earlier, i have done all tests and are down to leaking pd seals or bad pressure from the tandem, as soon as i have my adaptor for the pressure tester i will be able to see how the fuelpressure is on cold engine. if its jumping up and down at start, thats air in the system, if its under limit, that means the injectors are not getting enough pressure to dust the diesel, and thats really a good source for hard starts and smoke...
    #73
  34. espen22
    Offline

    espen22 New Member

    Joined:
    Dec 6, 2011
    Messages:
    20
    Likes Received:
    1
    [Dec 12, 2011]
    Some audis have had this funny error, hard to start, and if you turn your lightswitch fully on so that headlights are on when you start the car, then it was ok.. Solution was to change the headlight switch.

    So to test this, turn your headlight switch fully on before you start the car and see if it makes a difference.
    #74
  35. stu_m
    Offline

    stu_m Well-Known Member VCDS Map User

    Joined:
    Oct 25, 2009
    Messages:
    1,442
    Likes Received:
    36
    [Dec 13, 2011]
    I've had this problem and you only need to put the side lights on for it to start

    After about 3 to 4 months of doing this everything works as it should now without the lights turned on so I think its a bad connection in the switch causing it and has rectified its self with use!
    #75
  36. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Dec 13, 2011]
    Thanks guys I thought that might be what it was.....tried it and it seems to help a little but barely noticeable and could be just in my head!

    Espen, when will you be changing the Tandem? You waiting for some more kit to arrive at the moment?

    I could bite the bullet and go for it and have it here ready for my service on 3rd Jan......but it might not arrive in time......was going to wait until we see if yours if fixed that way.

    What worries me is my smoke is actually quite blueish not just white.......

    don't think its glow plugs at all, cycling the ignition isn't making a blind bit of difference any more for my car....the glow plug light comes on for about 2 secs and then whizzes off.

    Again with all of this, no VAG com errors have ever been reported, and it's been doing it for the past year or so and not got much worse....Tandem or Injectors!
    #76
  37. espen22
    Offline

    espen22 New Member

    Joined:
    Dec 6, 2011
    Messages:
    20
    Likes Received:
    1
    [Dec 13, 2011]
    Hi, did the tandem pressure test today.
    Bad news, pressure is way above limit (3-4 bars) and peaks the gauge (7 bars) on 1500 rpm.

    The pressure is also uneven, the needle is pinning up and down, so it has to be related to the injectors somehow.

    So if i trust my gut feeling i would say that i have leaking injector seals...

    Ordering new seals today, as the pds are famous for leaking on those seals, i would guess changing them is a good idea anyway...

    will keep you posted on this one :)
    #77
  38. stu_m
    Offline

    stu_m Well-Known Member VCDS Map User

    Joined:
    Oct 25, 2009
    Messages:
    1,442
    Likes Received:
    36
    [Dec 13, 2011]
    Don't order the seals from audi find a bosch dealer and get them they will cost less then half for the same kit I replaced all mine for about 30 quid due to a leak but I didn't have starting trouble!
    #78
  39. Funkyfin2000
    Offline

    Funkyfin2000 Member

    Joined:
    Sep 1, 2005
    Messages:
    465
    Likes Received:
    4
    [Dec 13, 2011]
    Hi guys,

    Are the seals a big labour job? I guess they are....

    I will grab a quote for injector seals through germanautopartsdirect.co.uk as genuine but half the price!

    Well I have ordered the Tandem and I think will just change it in my case anyway just so it's done! Its not a bad price at £250 really.

    Rich
    #79
  40. stu_m
    Offline

    stu_m Well-Known Member VCDS Map User

    Joined:
    Oct 25, 2009
    Messages:
    1,442
    Likes Received:
    36
    [Dec 13, 2011]
    The seals are easy to replace but you also have to replace all the rocker bolts too as they are stretch bolts and are about 60 for the lot!

    The hardest part is getting the injector's out you need a slide hammer really I made one up its easy if your any good with a welder
    #80

Share This Page