1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rough running v8

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by hondansxr, Dec 11, 2012.

  1. hondansxr

    hondansxr New Member

    Joined:
    Oct 26, 2012
    Messages:
    19
    Likes Received:
    1
    hi guys just picked up s4 2003 off flee bay there is no eng mag light coming on ,on ign or any time but airbag light is on .. have done a diagnostic check as it is running like its on 5 cylders (rough vibrating) 1st fault was camshaft sensor then no.3 cylinder cleared ran smooth for 10 sec then rough again .. did full diagnostic and central air flap motor fault and conrol module incorrect chassis ??????
    help
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. gen.heinz guderian

    gen.heinz guderian Well-Known Member
    Regional Rep VCDS Map User

    Joined:
    Jun 24, 2011
    Messages:
    1,346
    Likes Received:
    125
    can you post log of the scan?
     
  4. hondansxr

    hondansxr New Member

    Joined:
    Oct 26, 2012
    Messages:
    19
    Likes Received:
    1
    "A" camshaft pos timing over advanced performance (bank 1 ) p0011
    just thought of something car ran fine reved /sounded ok then i did less than 100 yrds to petrol station and i put 60 quids worth of super unleaded (noticed the norm unleaded out of action ) could it have doggy fuel in it ????
     
  5. gen.heinz guderian

    gen.heinz guderian Well-Known Member
    Regional Rep VCDS Map User

    Joined:
    Jun 24, 2011
    Messages:
    1,346
    Likes Received:
    125
    how long you had the car?
     
  6. hondansxr

    hondansxr New Member

    Joined:
    Oct 26, 2012
    Messages:
    19
    Likes Received:
    1
    2 pm today drove from london to midlands
     
  7. gen.heinz guderian

    gen.heinz guderian Well-Known Member
    Regional Rep VCDS Map User

    Joined:
    Jun 24, 2011
    Messages:
    1,346
    Likes Received:
    125
    try some vpower or octane booster
     
  8. hondansxr

    hondansxr New Member

    Joined:
    Oct 26, 2012
    Messages:
    19
    Likes Received:
    1
    it was v power ? got some octane booster in garage will try that .
     
  9. hondansxr

    hondansxr New Member

    Joined:
    Oct 26, 2012
    Messages:
    19
    Likes Received:
    1
    will camshaft sensor make it run sound awful ?
     
  10. gen.heinz guderian

    gen.heinz guderian Well-Known Member
    Regional Rep VCDS Map User

    Joined:
    Jun 24, 2011
    Messages:
    1,346
    Likes Received:
    125
    not sure on a petrol,i had camshaft position sensor play up on my van, took 50+ cranks to start it with foot on accelerator, but once started it ran ok.
     
  11. gen.heinz guderian

    gen.heinz guderian Well-Known Member
    Regional Rep VCDS Map User

    Joined:
    Jun 24, 2011
    Messages:
    1,346
    Likes Received:
    125
    has the EML light come on?
     
  12. AlexGSi2000

    AlexGSi2000 Well-Known Member
    VCDS Map User

    Joined:
    Feb 14, 2012
    Messages:
    1,430
    Likes Received:
    183
    A few coilpacks faulty maybe?
     
  13. hondansxr

    hondansxr New Member

    Joined:
    Oct 26, 2012
    Messages:
    19
    Likes Received:
    1
    just undone the fuel pipe and spilt some om a kitchen tissue after a few minutes the tissue is still stained and when you rub it it feels slippy . should nt fuel just evap ?????
     
  14. gen.heinz guderian

    gen.heinz guderian Well-Known Member
    Regional Rep VCDS Map User

    Joined:
    Jun 24, 2011
    Messages:
    1,346
    Likes Received:
    125
    did it drive ok before you refuelled?
     
  15. adamss24

    adamss24 Well-Known Member

    Joined:
    Jul 3, 2007
    Messages:
    3,707
    Likes Received:
    230
    It looks like you put v power diesel, however you should not been able to fit the nozzle in the filler but it can be done...
     
  16. hondansxr

    hondansxr New Member

    Joined:
    Oct 26, 2012
    Messages:
    19
    Likes Received:
    1
    would it not show on a diagnostic if coil packs were failing
     
  17. hondansxr

    hondansxr New Member

    Joined:
    Oct 26, 2012
    Messages:
    19
    Likes Received:
    1
    what would a tiny bit of diesel do to the engine ...misfire?
     
  18. Greeny233

    Greeny233 Active Member

    Joined:
    Mar 17, 2011
    Messages:
    837
    Likes Received:
    172
    If you'd put diesel in it, it would have white smoke billowing out the back. Coil packs are quite common for going, I may be wrong but I thing there was an Audi recall for S4 coil packs.
     
  19. fallmonk

    fallmonk Turbo Sport

    Joined:
    Jun 27, 2004
    Messages:
    1,864
    Likes Received:
    4
    Greeny is right there is a coil pack recall on that year don't assume because of the age it's been done , my 52 plate hadn't done ! Might be your problem and better yet its a freebie from Audi
     
  20. AlexGSi2000

    AlexGSi2000 Well-Known Member
    VCDS Map User

    Joined:
    Feb 14, 2012
    Messages:
    1,430
    Likes Received:
    183
    When I was a coilpack down on my 1.8T it didnt show on VAG-COM.
     
  21. jutlis 3.0

    jutlis 3.0 Member

    Joined:
    Jun 6, 2011
    Messages:
    211
    Likes Received:
    4
    vvt unit faulty
     
  22. Google AdSense Guest Advertisement



    to hide this advert.
  23. jutlis 3.0

    jutlis 3.0 Member

    Joined:
    Jun 6, 2011
    Messages:
    211
    Likes Received:
    4
    mine was very similar and i ended up changing chains/guides/tensioners and cam adjusters
     
  24. docurley

    docurley Moderator
    Staff Member Moderator

    Joined:
    Dec 12, 2003
    Messages:
    3,937
    Likes Received:
    36
    Buy a coil pack (always good to have a spare) and swap them out one by one and see if she runs better or try taking one off at a time and see if the engine note changes if it dose not then you have a bum coil pack.
     

Share This Page