1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

misfire on boost help please

rob_1986 Jul 4, 2013

  1. rob_1986

    rob_1986 New Member

    27
    0
    1
    oh i see i been reading up about it today and it says some of the 1.8 20v turbos do have them strange lol and no rattles at all its a very smooth car no misfire now u can here the turbo abit more now just not giving the boost it should :( tried to get to the actuator today to see if it would move but i would have to take turbo off to get to it as its in a tight place but ill take the exhaust off tomoz and check the penny valve to see if its still there
     
  2. Bradderz_1988

    Bradderz_1988 Dont replace it, Upgrade it !!

    3,958
    240
    63
    Well mine was still there but i dont no how it was still there mine was showing 6psi of boost as it wouldnt seal the port flush due to it being totally knackered !!

    heres mine lol

    [​IMG]
    [​IMG]
     
  3. boost-addict

    boost-addict Well-Known Member

    1,000
    39
    48
    You wonder how many times some one has to say take some pictures!

    I just wonder if its had a poor remap and its gone do-dally and the systems fighting the chip?

    Either way i thought my clutch and wheel bearing ahead of me was bad!

    A mate of mine had a no boost problem turnt out to be a **** penny valve and he also tried almost every thing. Well he gave up sold it to some one with some savvy they removed the turbo and found that to be the case.
    Any way im sure a family member or friend will let you borrow a camera. Even if its a phone. They can email or facebook it to you 99.99% of people have fb someone sure one of your friends or family has a phone with a camera and internet and facebook.

    Good luck any way. But by sounds of it
    You only got pipe work. Turbo or even collapsed cat or even mapping to go and you could be slim on suggestions!

    Unless thinking. As a sugestion
    The fpr which is the fuel pressure regulator has broken an just returning all the fuel pressure back to the tank. Which could explain misfire too???
     
  4. Sulli79

    Sulli79 Active Member

    541
    37
    28
    image.jpg When mine didn't boost this was the problem, the penny valve is still attached so no rattle, but the arm has deformed so it didn't quite seal properly.
     
  5. rob_1986

    rob_1986 New Member

    27
    0
    1
    hey just had the exhaust down pipe off and i can confirm the wastegate flap is good and the actuator valve does move but pretty stiff which is normal i have decided to but a boost gauge so i will see what happens when i install that atleast i know was psi it will be running and sorry i dont have pics is caus am always working and family are too but i will getsome in the next day or so cheers
     
  6. Oranoco

    Oranoco Well-Known Member

    3,970
    405
    83
    Just picking up on something you said about driving turbo cars before. The 150bhp 1.8T does not come on boost hard like other turbo cars. At the time also owning an Escort and a Fiesta RS Turbo I was terribly disappointed in how it delivered the power during the test drive. Very smooth but soooo boring.
     
  7. rob_1986

    rob_1986 New Member

    27
    0
    1
    right back again got the boost gauge and set it up i used a tpiece and put it between inlet manifold and fuel pressure reg took the car for a drive and its only got to -5psi the boost gauge its self starts from -15 and goes to 30psi
     
  8. boost-addict

    boost-addict Well-Known Member

    1,000
    39
    48
    Is the gauge second hand. Sounds faulty.
    The gauge should sit at 0 with the car of and some were around -20psi at idle.
     
  9. rob_1986

    rob_1986 New Member

    27
    0
    1
    no its brand new its the 2nd one i have tried on idle the gauge sits at -15 and when i rev it goes to -5 well confused now
     
  10. Sulli79

    Sulli79 Active Member

    541
    37
    28
    Deffo time to get some photos up, where you have teed in and your n75 etc
     
  11. rob_1986

    rob_1986 New Member

    27
    0
    1
    right i put the tpiece in between the fuel pressure reg and the inlet manifold and for the n75 i have removed it and left it electronically plugged in then capped the pipes of then i have put a pipe from actuator to turbo housing tomoz i am going to put the boost gauge into the dump valve line as i seen on another forum that is a good place for it too
     
  12. Bradderz_1988

    Bradderz_1988 Dont replace it, Upgrade it !!

    3,958
    240
    63
    Doesnt matter if its on the fpr or dv line if its vacuumed/boosted they will give the same reading !! When you drive the car under load what readings are you getting as you wont create boost at idle !!

    PICTURES PICTURES PICTURES PICTURES :banghead:
     
  13. rob_1986

    rob_1986 New Member

    27
    0
    1
    lol ill try it tomoz and get u some pictures up :)
     

Share This Page