1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ESP Light on !!!

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by Digger1, Dec 28, 2010.

  1. Digger1
    Offline

    Digger1 Member

    Joined:
    Feb 23, 2010
    Messages:
    439
    Likes Received:
    1
    [Dec 28, 2010]
    OK my car was a little slow starting yesterday morning and the ESP light stayed on all the way to work about 5 miles from where I live,,, 9 hours later car started fine and after a short time the light went off.
    Started this morning fine then about 4 miles from home ESP light came on so when I stopped at some traffic lights I turned the ign; off and started it back up after a short time it went off again... :wtf:

    Anybody else had this ? early signs off battery failure possibly ?
    #1
  2. Ads

    Ads

    [Sep 17, 2014]

  3. unknownmonkey
    Offline

    unknownmonkey New Member

    Joined:
    Oct 22, 2010
    Messages:
    10
    Likes Received:
    0
    [Dec 28, 2010]
    brake light switch
    #2
  4. Mike B
    Offline

    Mike B Member

    Joined:
    Jul 10, 2007
    Messages:
    776
    Likes Received:
    8
    [Dec 29, 2010]
    Mine is doing this but I think that it may be an ABS fault cos it did not seem to cut in on locking up in the snow.Will have it scanned but do not think it is something simple like the brakeswitch
    #3
  5. Digger1
    Offline

    Digger1 Member

    Joined:
    Feb 23, 2010
    Messages:
    439
    Likes Received:
    1
    [Dec 29, 2010]
    mines been working as normal in the snow, and I've done over 50 miles now without the light coming back on, but still had it scanned the only fault code it's showing is steering angle sensor ! thing is snow,ice,salt & grit aren't the best ingredients for elec; connections and sensors,,, may just wait to see if it comes back on now the white stuffs gone !
    #4
  6. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,800
    Likes Received:
    499
    [Dec 29, 2010]
    brake switch and fooked batt can cause it
    get a scan
    #5
  7. Mike B
    Offline

    Mike B Member

    Joined:
    Jul 10, 2007
    Messages:
    776
    Likes Received:
    8
    [Dec 31, 2010]
    Just scanned no faults also charged battery made a few short trips and no show for the light so will wait and see what happens
    #6
  8. Digger1
    Offline

    Digger1 Member

    Joined:
    Feb 23, 2010
    Messages:
    439
    Likes Received:
    1
    [Jan 2, 2011]
    Yeah I reckon a short drop in battery power and the module just throws up the ESP light mines still not come back on...
    #7

Share This Page