1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine, Traction and EPC light

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by stevehall, Dec 4, 2008.

  1. stevehall
    Offline

    stevehall Member VCDS Map User

    Joined:
    Aug 26, 2008
    Messages:
    300
    Likes Received:
    0
    [Dec 4, 2008]
    Help…

    On my way to work this morning they Engine, Traction and EPC light came on. Then the car seemed under powered and rough…

    I pulled over and turned the car off, when I re-started the car the lights came back on within a few seconds!

    I have a 2005 A4 2.0T
    #1
  2. Ads

    Ads

    [Sep 23, 2014]

  3. stevehall
    Offline

    stevehall Member VCDS Map User

    Joined:
    Aug 26, 2008
    Messages:
    300
    Likes Received:
    0
    [Dec 4, 2008]
    Just taken my car to volksmaster and they have plugged it into the computer.. They say its due to a faulty accelerator and the kick down is stuck down...

    Its strange that it only breaks when the cruise stick is pulled forward...

    Lets hope this fixes it... Its going in on Saturday morning!
    #2
  4. stevehall
    Offline

    stevehall Member VCDS Map User

    Joined:
    Aug 26, 2008
    Messages:
    300
    Likes Received:
    0
    [Dec 8, 2008]
    Well it was fixed for a few hours... this morning on my way to scotland i was happy driving on cruise control and after about 2 hours all the power went and then the lights back on!

    Anyone help?
    #3
  5. jwhat
    Offline

    jwhat Member VCDS Map User

    Joined:
    Oct 20, 2006
    Messages:
    540
    Likes Received:
    1
    [Dec 8, 2008]
    Bring it back and see if something else came up? Or someone else might have another specialist they could recommend?!
    #4
  6. stevehall
    Offline

    stevehall Member VCDS Map User

    Joined:
    Aug 26, 2008
    Messages:
    300
    Likes Received:
    0
    [Dec 8, 2008]
    Yeah its going back in on Thursday for the day... Hope they can fix it! Bloody Computers eh!!

    I did a google on it, and found so many diff things it could have been - just scared myself so stopped!!

    Its amazing, every thime i think im going to have a quiet month and save some money and not pay for anything on car something goes wrong - Its like it knows and gets upset if its not having money spent on it!

    Lets hope nothing goes wrong in the new year as i gotta tax it!
    #5
  7. stevehall
    Offline

    stevehall Member VCDS Map User

    Joined:
    Aug 26, 2008
    Messages:
    300
    Likes Received:
    0
    [Oct 6, 2009]
    The fault has come back! :(

    I only get the fault when its raining heavy and i have the cruise stick pulled forward...

    Any idea's?

    Where is the cruise control unit? Need to check its not getting wet.
    #6
  8. stevehall
    Offline

    stevehall Member VCDS Map User

    Joined:
    Aug 26, 2008
    Messages:
    300
    Likes Received:
    0
    [Oct 12, 2009]
    I have now got the codes off vag com.

    Address 01: Engine Labels: 06F-907-115-AXX.lbl
    Part No SW: 8E0 910 115 J HW: 8E0 907 115 C
    Component: 2.0l R4/4V TFSI 0080
    Revision: --H02--- Serial number:
    Coding: 010C0003190F0120
    Shop #: WSC 00411 210 91522
    1 Fault Found:
    008504 - Accelerator Position Sensors (G79) / (G185): Implausible Correlation
    P2138 - 008 - Implausible Signal - Intermittent
    Freeze Frame:
    Fault Status: 00101000
    Fault Priority: 0
    Fault Frequency: 3
    Mileage: 138469 km
    Time Indication: 0
    ddress 02: Auto Trans Labels: 09L-927-760.lbl
    Part No SW: 8E1 910 156 A HW: 09L 927 156
    Component: AG6 09L 2.0TFSI RdW 0080
    Revision: --H01--- Serial number: 4027397
    Coding: 0000001
    Shop #: WSC 06325 000 00000
    1 Fault Found:
    18269 - Throttle Position Sensor (G79): Error Message from ECU
    P1861 - 000 - - - Intermittent
    Freeze Frame:
    Fault Status: 00110000
    Fault Priority: 0
    Fault Frequency: 3
    Reset counter: 28
    Mileage: 138469 km
    Time Indication: 0
    Address 03: ABS Brakes Labels: 8E0-910-517.lbl
    Part No SW: 8E0 910 517 C HW: 8E0 614 517 BB
    Component: ESP8 quattro H04 0180
    Revision: 00000000 Serial number: 00000000000000
    Coding: 0004528
    Shop #: WSC 06325 000 00000
    1 Fault Found:
    01314 - Engine Control Module
    013 - Check DTC Memory - Intermittent
    Freeze Frame:
    Fault Status: 00101101
    Fault Priority: 2
    Fault Frequency: 4
    Reset counter: 2
    Time Indication: 0
    #7
  9. stevehall
    Offline

    stevehall Member VCDS Map User

    Joined:
    Aug 26, 2008
    Messages:
    300
    Likes Received:
    0
    [Oct 22, 2009]
    Had this fault again in the rain. Pulled over turned cruise off then started her up and all ok.
    #8
  10. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,321
    Likes Received:
    1,229
    [Oct 22, 2009]
    ABS fault is just the engine dtc mate, so thats irrelvant atm, let me have a look later for any info, in meantime sure others will add.

    Need to check where these sensors are, might be inside the pedal, elsawin should advise.
    #9
  11. stevehall
    Offline

    stevehall Member VCDS Map User

    Joined:
    Aug 26, 2008
    Messages:
    300
    Likes Received:
    0
    [Oct 22, 2009]
    CHeers Fella.

    Going to take a look at the codes tonight and see if they have changed or if i can get anymore information on it and then i will post them up!

    Thanks again for all your help!

    Steve
    #10
  12. stevehall
    Offline

    stevehall Member VCDS Map User

    Joined:
    Aug 26, 2008
    Messages:
    300
    Likes Received:
    0
    [Oct 22, 2009]
    Here are all my fault codes.... Please help!

    Address 01: Engine Labels: 06F-907-115-AXX.lbl
    Part No SW: 8E0 910 115 J HW: 8E0 907 115 C
    Component: 2.0l R4/4V TFSI 0080
    Revision: --H02--- Serial number:
    Coding: 010C0003190F0120
    Shop #: WSC 00411 210 91522
    1 Fault Found:
    008504 - Accelerator Position Sensors (G79) / (G185): Implausible Correlation
    P2138 - 008 - Implausible Signal - Intermittent
    Freeze Frame:
    Fault Status: 00101000
    Fault Priority: 0
    Fault Frequency: 2
    Mileage: 144020 km
    Time Indication: 0
    Freeze Frame:
    RPM: 1535 /min
    Load: 11.0 %
    Speed: 73.0 km/h
    Temperature: 96.0°C
    Temperature: 17.0°C
    Absolute Pres.: 980.0 mbar
    Voltage: 13.970 V
    Readiness: 0000 0000
    -------------------------------------------------------------------------------
    Address 02: Auto Trans Labels: 09L-927-760.lbl
    Part No SW: 8E1 910 156 A HW: 09L 927 156
    Component: AG6 09L 2.0TFSI RdW 0080
    Revision: --H01--- Serial number: 4027397
    Coding: 0000001
    Shop #: WSC 06325 000 00000
    1 Fault Found:
    18269 - Throttle Position Sensor (G79): Error Message from ECU
    P1861 - 000 - - - Intermittent
    Freeze Frame:
    Fault Status: 00110000
    Fault Priority: 0
    Fault Frequency: 2
    Reset counter: 35
    Mileage: 144020 km
    Time Indication: 0
    Freeze Frame:
    RPM: 1568 /min
    RPM: 1760 /min
    RPM: 2208 /min
    (no units): 13.0
    (no units): 23.0
    Temperature: 63.0°C
    T.B. Angle: 60.0°

    -------------------------------------------------------------------------------
    Address 03: ABS Brakes Labels: 8E0-910-517.lbl
    Part No SW: 8E0 910 517 C HW: 8E0 614 517 BB
    Component: ESP8 quattro H04 0180
    Revision: 00000000 Serial number: 00000000000000
    Coding: 0004528
    Shop #: WSC 06325 000 00000
    1 Fault Found:
    01314 - Engine Control Module
    013 - Check DTC Memory - Intermittent
    Freeze Frame:
    Fault Status: 00101101
    Fault Priority: 2
    Fault Frequency: 4
    Reset counter: 24
    Time Indication: 0
    Freeze Frame:
    Hex Value: 0x4A00
    Hex Value: 0x4006
    Hex Value: 0x00FF
    Hex Value: 0xFFAB
    Hex Value: 0x00FF
    #11
  13. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,321
    Likes Received:
    1,229
    [Oct 23, 2009]
    Well been checking & elsawin shows the sensors in the wiring side but doesnt show within the workshop guide, I reckon they're inside the pedal tbh, also been reading some forums & some people seem to think its related to the coolant sensor aswell, cant see how but hey anythings worth a read, but check through measuring blocks in engine 01 with vagcom & see if you can find the G79 block that you can test if its reading the thottle sensor with pedal presses, believe you can do without engine started, check this & also google where is G79 sensor.

    http://forums.tdiclub.com/showthread.php?t=202660

    I'll continue to look mate, but check these things out cause if it isnt sensing in measuring blocs then could be wiring or the pedal again, you sure they stuck new one on the car?

    You also say its only when its wet, so this would possibly suggest wiring is getting wet & shorting out somewhere, maybe a wire has been damaged somewhere, check where the pedal wires go & follow through with a torch & see if you can see anything at all mate, cause if was sensor it would do dry or wet imho tbh, also you say its with cruise but it only does when wet with cruise & doesnt happen straight away, this seems to point me to wiring again & shorting somewhere, the power loss is most likely a safety factor tbh.


    http://www.ross-tech.com/vag-com/m_blocks/060-069.html

    http://www.ross-tech.com/vag-com/m_blocks/

    As I said mate after chekcing more info, the sensors have a safety factor so if one fails other is there & if they both dont match up then car is put into limp mode, guess it stops the car from shooting of when pedal is faulty, if you get me, this thread also advises like I have, wiring, pedal:

    http://www.tt-forum.co.uk/forum/vie...ghlight=&sid=c948b39934619c78a66f3e2300853dd5
    Last edited: Oct 23, 2009
    #12
  14. stevehall
    Offline

    stevehall Member VCDS Map User

    Joined:
    Aug 26, 2008
    Messages:
    300
    Likes Received:
    0
    [Oct 23, 2009]
    Thanks for your reply.

    Yes its really strange. Can runs fine when its dry, but as soon as we get some rain and i have the cruise stick pulled forward i get the fault, stop turn cruise off and then restart the car and its all fine.

    Yeah it had a new pedal installed...
    #13
  15. stevehall
    Offline

    stevehall Member VCDS Map User

    Joined:
    Aug 26, 2008
    Messages:
    300
    Likes Received:
    0
    [Nov 25, 2009]
    Well.. Thought i would give an update on this...

    I have been driving round the past few weeks with the cruise turned off, and my car has just had a service, and they commented that the plenum chamber was blocked.

    Thought i would try cruise again in the rain last night and it worked well!

    Meybe this chamber being blocked caused things to get wet?
    #14
  16. jwhat
    Offline

    jwhat Member VCDS Map User

    Joined:
    Oct 20, 2006
    Messages:
    540
    Likes Received:
    1
    [Nov 25, 2009]
    Is that around the battery? I've heard the drains can get blocked there and water can make its way into the cabin? maybe onto you clutch switch or convenience module? Glad you got it sorted.
    #15

Share This Page