1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

coolant leak thinking it may be water pump ? please help

Discussion in 'A3/S3 Forum (8L Chassis)' started by JA50N, Oct 6, 2013.

  1. JA50N
    Offline

    JA50N Member

    Joined:
    Mar 14, 2012
    Messages:
    85
    Likes Received:
    0
    [Oct 6, 2013]
    I am having a real hard time at moment and things just keep getting worse now to top it off the S3 has developed a leak.
    The leak is dripping (constant drips) from bottom of crank pulley i have wheel off and am currently checking it and presume it is probably dripping from the water pump but cannot see anything wet to side or above crank pulley.
    I removed top cam belt cover and looks to be a wet in there weather oil water or from past hard to say the back of engine looks wet about half way up but this could be from driving and the water coolant being splashed as its only dripping from bottom of the crank pulley when parked.

    Any help advice pointers welcome also if it is the water pump (sods law these where replaced with the cam belt when i bought car) a recommended place around south Yorkshire nottinghamshire to get this done (yes it would get a cam belt again) and an idea of price would also help as i have to many things going on to do it myself at this time.

    thank you
    #1
  2. Ads

    Ads

    [Dec 29, 2014]

  3. JA50N
    Offline

    JA50N Member

    Joined:
    Mar 14, 2012
    Messages:
    85
    Likes Received:
    0
  4. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User

    Joined:
    Apr 26, 2004
    Messages:
    12,778
    Likes Received:
    325
    [Oct 8, 2013]
    sounds like waterpump to me.
    #3
  5. Nilz
    Offline

    Nilz Defo worth the wait :)

    Joined:
    Apr 9, 2006
    Messages:
    10,379
    Likes Received:
    470
    [Oct 8, 2013]
    See if you can pressure test it from the coolant tank.

    Mine was leaking recently, it was a hairline crack in a pipe on the side of the engine, I changed that and was still loosing coolant, it ended up being the waterpump that was leaking, so got the cambelt and waterpump all replaced at the same time.
    #4
  6. JA50N
    Offline

    JA50N Member

    Joined:
    Mar 14, 2012
    Messages:
    85
    Likes Received:
    0
    [Oct 12, 2013]
    Cheers
    think this is probably the case need somewhere to get it repaired I am in South Yorkshire if anyone knows of a reliable and trustworthy garage
    #5
  7. Andrew@A.L.D
    Online

    Andrew@A.L.D May add NOS to 600+bhp?

    Joined:
    Jun 19, 2009
    Messages:
    3,556
    Likes Received:
    374
    [Oct 13, 2013]
    #6

Share This Page