1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Barely any boost! DV/ N75 valve failed for a second time!

Discussion in 'A3/S3/Sportback (8P Chassis)' started by akash_sky1, Dec 30, 2010.

  1. akash_sky1
    Offline

    akash_sky1 Active Member

    Joined:
    Nov 14, 2009
    Messages:
    1,191
    Likes Received:
    0
    Noticed over the last couple of days, when accelerating esp from low revs, the revs would build quite jerkily and the boost would waver quite noticeably, but then go back to normal as the revs rose.

    Now today as i drove the car the problem got worse, to the point where there is virtually no boost at all. You can hear the turbo spool a tiny bit thru the intake at 2k revs but then after that no spool and no boost :-(.

    Pretty much the same thing happend before and was cured with a new diverter valve (revised metal piston D version) and then a new N75 valve, as the new DV valve was causing overboost.
    Just wondering has anyone had one of these piston type revision D valves fail, or have their N75 valve fail for a second time?
    Both parts have only been on since April, but have seen some hard use on this car.

    Is it worth me upgrading to a Forge diverter valve and a strengthened N75 spring while I'm at it?

    Also fitted my BSH PCV fix today, which was fairly straightforward, and noticed a fair bit of oil in the PCV hose that joins the intake manifold to the cylinder head, now with this fitted much less of this crud will be going back into my intake and I should gain 1-2 PSI of boost under load, however due to the boost problem above I can't test this out properly untill the valve/s are sorted.

    Any help appreciated.
    #1
  2. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep

    Joined:
    Jul 8, 2008
    Messages:
    8,697
    Likes Received:
    21
    my BSH dont give me more boost
    yes the DV can fail mine did but im pushing quite a bot of boost
    im useing forge now and not had a prob with it
    N75 should chuck a code
    #2
  3. akash_sky1
    Offline

    akash_sky1 Active Member

    Joined:
    Nov 14, 2009
    Messages:
    1,191
    Likes Received:
    0
    My old one already failed as it was crappy rubber diaphragm one, wanted to know if anyones had a new style updated one fail as well as may have oCcured here?
    #3
  4. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep

    Joined:
    Jul 8, 2008
    Messages:
    8,697
    Likes Received:
    21
    as above yes my new piston type failed
    now im on the forge
    #4
  5. akash_sky1
    Offline

    akash_sky1 Active Member

    Joined:
    Nov 14, 2009
    Messages:
    1,191
    Likes Received:
    0
    Ok cheers, so if the diverter valve has failed AGAIN where's the cheapest place to get hold of a Forge one? Seem to be about £140-150 in most places
    #5
  6. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep

    Joined:
    Jul 8, 2008
    Messages:
    8,697
    Likes Received:
    21
    to get the best price just look around
    thats the goin rate for them
    #6
  7. akash_sky1
    Offline

    akash_sky1 Active Member

    Joined:
    Nov 14, 2009
    Messages:
    1,191
    Likes Received:
    0
    ok ta, shame it happend so late too late to order to beat VAT now i think, esp when i dont know if thats even the faulty part.
    What mods have you done to yours btw?
    #7
  8. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep

    Joined:
    Jul 8, 2008
    Messages:
    8,697
    Likes Received:
    21
    mines the a4 b7
    but full stage 3
    #8
  9. akash_sky1
    Offline

    akash_sky1 Active Member

    Joined:
    Nov 14, 2009
    Messages:
    1,191
    Likes Received:
    0
    Ok the problem has gone away boost is back to normal, wonder if theres a loose contact somewhere as my ride is pretty bumpy with H&Rs on standard shocks.
    #9

Share This Page