1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Audi A4 2.0 Fsi needs some help.

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by Gaz1987, Sep 10, 2011.

  1. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    First off Hi everyone im new to the forum I have looked on some bits before and decided to finally join :)

    I was hoping someone could help me out.

    I have an Audi A4 2.0 FSI Sport 2004 B6.

    Now when I brought it had a fair few problems one being a new engine needed so I decided to get a replacement used engine with what they told me had 60k on. So that was fitted back in January I think it was. Various other things were changed such as coil packs etc.

    Now I have been experiencing this first problem pretty much since the new engine was fitted took it back to the garage but they are useless to say it nicely and they wont ever see my car again let alone touch it. Thats another story.
    Basically sometimes my car will start to judder horribly and other times it is not so bad being very minor but either way it does it. Sometimes I can actually get out of the car and the car will be shaking. It is most noticeable when idling and there is a tiny bit of movement on the needle but it very minor and not like you would see on a missfire. Whilst idling if you put the clutch in it makes no difference. On the odd occasion the car will start and the rev needle will be in limbo land as if the car wants to die or just start to pick up you can hear the car sound as if its just about to die but it will stay like that for as long as the car will tick over unless the accelerator is tapped. I would really like to get to the bottom of this as its driving me mad.
    I have taken it too a few garages that cannot find the problem and I have now been told to take it to Audi but to be honest I was really hoping not to do that when the problem is unknown as I just dont have the cash for what they charge.

    The second problem is a not as old. The car when locked would randomly start beeping and all lights flashing sometimes I could unlock the car and relock without any problems other times it would stop and start to beep a few minutes after locking it again. Then that suddenly stopped. Then after a few months it started again but was not so bad only on random occasions it would do it. Im pretty sure that I disabled the interior motion detectors a few times and the problem still happened.

    Any help would be appreciated.
    Last edited: Sep 10, 2011
    #1
  2. S3 GAZ
    Offline

    S3 GAZ Member

    Joined:
    Dec 17, 2006
    Messages:
    360
    Likes Received:
    1
    Sounds like the vibration could be the engine mounts. Perhaps they were damaged during the engine swap.
    #2
  3. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    Hi thanks for the reply.

    Im no expert but I dont think it is the mounts as when I had a new coil pack and all codes wiped off the car ran really smooth and nice for a week or 2 then it started again. Also a few weeks ago I had my aircon re-gassed and that added a fault code so once a fuse was replaced and the code wiped the car ran nice again for a few days then back juddering. When the car is juddering very bad you can actually see the car shaking thats the whole of the A4 and if sitting in it you can feel it a lot.

    Something I just remebered is if I was to let air in to the engine by lifting the dipstick while the car is running it will sound rough and jiggle about also.
    Last edited: Sep 10, 2011
    #3
  4. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    Can anyone help?
    #4
  5. quattrojames
    Offline

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,882
    Likes Received:
    18
    Engine breather?
    #5
  6. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    I was thinking that but surely the garages should have picked that up, anyone know of anywhere to get a breather set for a decent price?

    Any ideas on the alarm issue?

    Many thanks
    #6
  7. quattrojames
    Offline

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,882
    Likes Received:
    18
    The alarm might be a damaged wire in the door hinge possibly.

    Have you had the car scanned at all?
    #7
  8. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    I have but nothing was found on the alarm side of things, there was a code for an air leak but I didnt get the code it was thought that was an old code from when the mass airflow meter was replaced I think the last time my car went in all codes were wiped so anything that comes up now will be new and relevant.

    If there is someone in the area that is interested in helping me out with the problem I will be very interested to talk with you and it would be nice if you are able to do the work on it for me as I dont have a VAG system and im not a mechanic.
    #8
  9. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    Update on the alarm issue.

    The last two nights have been pretty much the same the first night the car was left from around 5pm all night locked. Then at around 10pm just decided to set the alarm off. I unlocked and locked again after about 10minutes the alarm started going again soni tried a further few times even opening all the doors and closing then re-locking for the alarm to go off once it was armed.
    I also disabled the 2 switches at the side of the drivers side door but the alarm still went off.

    The second night it was left from around 8pm all night locked until the alarm started sounding at around 5am so I had to leave the car unlocked all night.

    If anyone can help it would be great.
    #9
  10. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    Can anyone recommend a good garage that knows about Audi's in the Midlands or Birmingham area?
    #10
  11. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    Anyone at all?
    #11
  12. swarcup
    Offline

    swarcup Active Member

    Joined:
    Sep 9, 2009
    Messages:
    1,284
    Likes Received:
    1
    Mine was doing this alarm thing and was traced to a duff glass break sensor. I dont know where it is though.
    #12
  13. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    Thanks for your reply the car is in a garage at the moment hopefully it will get sorted.

    Does anyone know if there was ever a recall on the alarms or anything else with the 2004 B6 model?
    #13
  14. swarcup
    Offline

    swarcup Active Member

    Joined:
    Sep 9, 2009
    Messages:
    1,284
    Likes Received:
    1
    Coilpacks and plenum chamber grommets are 2 recalls that im aware of
    #14
  15. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    Ok will be ringing Audi up when I get time to see if they owe me any recalls.
    #15
  16. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    I had my car looked at and its not the breather pipes I had the throttle body cleaned while it was in the garage too but no change with regards to the juddering any other ideas would be helpful.
    Last edited: Oct 30, 2011
    #16
  17. Stubie
    Offline

    Stubie Member

    Joined:
    May 19, 2011
    Messages:
    136
    Likes Received:
    0
    Midland vw in cannock or vw rescue in wombourne ! used them both in the past with no problems !
    #17
  18. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    cheers may give them a try.
    #18
  19. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    If anyone else can think of an explaination in the mean time im all ears.
    #19
  20. Digger1
    Offline

    Digger1 Member

    Joined:
    Feb 23, 2010
    Messages:
    439
    Likes Received:
    0
    You say it's not the breather pipes,,hhmm, I have the same car with the same engine and have had this fault,, it turned out to be a plastic breather hose that runs from the right side of the rocker cover into the grey plastic inlet-box to the right of it,, if you lift the fsi engine cover of it's immediately in front of you there's two, the plastic hose has a textured pattern of rings witch become brittle and leak air from fine cracks in it...
    #20
  21. marktdisport
    Offline

    marktdisport Active Member

    Joined:
    Jul 14, 2011
    Messages:
    1,195
    Likes Received:
    2
    was the coilpacks ebay cheapys m8 !!! they could be failing again or a dodgy plug

    i use midland vw only speak to jody he's the gaffa.....
    #21
  22. Digger1
    Offline

    Digger1 Member

    Joined:
    Feb 23, 2010
    Messages:
    439
    Likes Received:
    0
    possibly but would have thought it would be missing right through the revs not just on tick-over,,,

    GAZ, the two breathers i mentioned can only be checked by removing the inlet box , which involves removing the expansion container etc, so not cheap to get checked,and I'm not saying that's defo going to cure your problem,just that it cured the same symptons on my 2.0 FSI
    #22
  23. marktdisport
    Offline

    marktdisport Active Member

    Joined:
    Jul 14, 2011
    Messages:
    1,195
    Likes Received:
    2
    not always m8 if one is slower breaking down......
    #23
  24. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    There is no missfire there is a little movement on revs on tickover occasionly but not like it is when there is a miss.
    #24
  25. Gaz1987
    Offline

    Gaz1987 New Member

    Joined:
    Sep 10, 2011
    Messages:
    17
    Likes Received:
    0
    So since having a new water pump and cambelt change the judder has gone :) I had all breathers checked just incase too and now the car is driving very well. I am still yet to find out about the alarm problem but it has been locked for a few days without any problems now but could it be a possibility that a leaking water pump could have got some electrics wet that made the alarm go off randomly?
    #25

Share This Page