JMB RetrofitsEM Tuning
Results 1 to 9 of 9
  1. #1
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Wiltshire
    Posts
    346

    ARG!!! Another fault!

    Ok, so I pulled out my battery last night to remove the rubber bungs in the chamber and put it all back together. Also changed pollen filter while I was there. Now today I seem to have an intermittent airbag fault.

    01221 - Crash Sensor Side Airbag; Driver Side (G179)
    011 - Open Circuit - MIL ON

    Now when it says "drivers side" does it mean actually drivers side, or european drivers side (our passenger)?

    I say intermittant as I was driving to uni this morning and the airbag light was coming off and on. So I decided to park up at the uni car park and pulled out my VAGCOM and cleared all codes. Unfortunatly all other codes cleared fine, but the airbag came back instantly.

    I do have a crappy wiring via the door to the car (I will have a look in there tongiht to see if there are any loose wires) as sometimes the drivers door speaker goes fubar when I move the bundle gently. Could this be the cause?

    If I need to repalce any parts, I dont mind, but I want to figure out whats going on first.

    Would any diy write ups be any use to anyone when I figure out what the problem is? Cheers guys!

    You might find I might have to do this at the stand on saturday!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Sandra's Avatar
    MODERATOR

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Scotland
    Posts
    15,487
    Hi, i hope you find the fault and get it fixed quickly. A write up would be much appreciated. I will set up a faqs thread for you all to start using and help others with the same chassis as yourselves. Enjoy the rest of your day and thank you in advance for any write up it would be very much appreciated. x
    Audi-sport.net Lanyards & Stickers
    To find Audi-Sport-Net members with VCDS check out the MAP


  4. #3
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Wiltshire
    Posts
    346
    Does anyone have the part number for a replacement driviers door wiring harness for the B7 S4?

  5. #4
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,113
    If the door loom is dodgy, then more than likely its this, as the G179 is the door sensor for side airbag.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  6. #5
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Wiltshire
    Posts
    346
    cool. Well I'll pull the harness out this afternoon, and see if I can repair it. Bit of decent soldering and it should be good until I can get the part number and source a replacement.

  7. #6
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,113
    Just don't add to much solder to the airbag wires as it will increase resistance & then may flag error still, I don't think you need to replace it tbh, they can be repaired properly as looms are usually expensive, trust me.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  8. #7
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Wiltshire
    Posts
    346
    Good point. Will have a good inspectio first.

  9. #8
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Wiltshire
    Posts
    346
    Ok, so currently have the car stripped. What I did was:

    1. Removed the kick panel on the drivers side
    This is done by pulling at the plastic trim by the door jam on the floor upwards. There are 2 metal clips holind it in.
    Remove the plastic side panel of the dashboard
    Pull the plastic trim connecting to the kick plate going down the door jam - 2 metal clips.
    2. Use a plastic trim removal (or screwdriver if you are careful) and lift the rubber wire grommet from inside the door jam. This will unlclip and will expose the wiring butt connectors.

    My connectors were not locking together properly for some reason. It looks like it was disconneceted previously and reconnected wrong as the locking tab seems broken. Moving the connectors ment that they were not fully engaged causing wiring shorts. As they will no longer lock, I had to zip-tie them securly together. I refitted the rubber grommet and tested the wiring. All seems good now.

    I am now about to do a vagcom check to confirm for errors.

    My writeups are not the best, so if anyone wants to expand or re-explain (or just ask questions), please do!

  10. #9
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Wiltshire
    Posts
    346

 

 

Similar Threads

  1. Another fault code!!!!
    By jay1 in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 10th December 2012, 19:54
  2. Another Fault code.
    By Bradderz_1988 in forum A4/S4 forum(B5 Chassis)
    Replies: 13
    Last Post: 21st March 2012, 19:57
  3. Yet Another Fault Code Thread..
    By Reesy in forum A3/S3 Forum (8L Chassis)
    Replies: 8
    Last Post: 1st February 2011, 18:12
  4. Another fault. airbag this time...
    By Jonion in forum A4/S4 forum(B5 Chassis)
    Replies: 8
    Last Post: 16th November 2010, 21:10
  5. Following on from the rusty doors. Another Audi design fault?
    By Markb in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 9th September 2005, 23:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO