AH FabricationsJMB Retrofits
Results 1 to 25 of 25
Like Tree2Likes
  • 1 Post By Richardesty
  • 1 Post By Richardesty

Thread: 'How to' photo guide - replacing your Fuel Temperature Sensor on the 2.0 TDi BRD

  1. #1
    Richardesty's Avatar
    loves quattro

    Status
    Offline
    Join Date
    Oct 2008
    Location
    Louth
    Posts
    753

    'How to' photo guide - replacing your Fuel Temperature Sensor on the 2.0 TDi BRD

    As the title says - here's a quite 'How to' photo guide - replacing your Fuel Temperature Sensor on the 2.0 TDi BRD engine.

    I've recently replaced mine having done some reading up on here, thought it may be the cause of some recent starting issues and general 'rough' running. That said, my temp gauge was always reading normal at just under 90c.

    Here's how I did it....

    1 - buy the replacement sensor and o-ring - I went for an OEM version from my local Audi Dealer:



    2 - open your bonnet (see instruction manual):



    3 - remove the engine cover - it just lifts off with some firm upward pressure:



    4 - locate the existing Fuel Temperature Sensor - on a high level hose at the rear of the engine bay, adjacent to the battery:



    5 - un-clip the electrical connector:



    6 - remove the clip which holds the sensor in place - carefully prize it away with a flat screwdriver:



    7 - pull the sensor away from the 'holder' noting that the original o-ring may stay in the hole (remove this too). The new one is on the left.
    Then clean the opening with a cloth:




    8 - push the new sensor and o-ring into the hole, and replace the green clip:



    9 - Replace the electrical connector, then start the engine to test for leaks.

    10 - Replace the engine cover and close the bonnet.

    Having done a few runs it seems to have cured my starting problems and smoothed out the power delivery.

    Not bad for £38 and about 4 minute work, including taking the photos!

    Rich
    Last edited by quattrojames; 9th August 2012 at 19:27.
    tr3m5 likes this.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Wrath's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    North East, UK
    Posts
    1,185
    Nowt showed in VCDS?
    Nathan

    Red Audi A4 B7 S-Line with Leather/Alcantara interior

    Current Mods: Painted Brake Calipers, Gear-driven oil shaft assembly, RS4 grille, Debadged, B8 MFSW, Cruise Control, RS4-style Fog Surrounds, Satin Black Cupra R Splitter, RS4 RARB, Clear Corner headlights, 2011 RNS-e, MTEC Drilled and Grooved Brake Discs.

  4. #3
    Richardesty's Avatar
    loves quattro

    Status
    Offline
    Join Date
    Oct 2008
    Location
    Louth
    Posts
    753
    Not a dickie bird.....and it was serviced a month or so ago and Audi didn't report any issues, even though I asked them to check out the rough idle and poor starting.
    Baz8878 likes this.

  5. #4
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    North Wales
    Posts
    209
    Richard - Was yours difficult to start only the first time or at anytime after that also. I ask because mine ticks over a bit rough and the first start is always slow - after that it starts fine for the rest of the day. If your symptoms were the same I'll give this a go. Thanks

  6. #5
    Richardesty's Avatar
    loves quattro

    Status
    Offline
    Join Date
    Oct 2008
    Location
    Louth
    Posts
    753
    Quote Originally Posted by mm707 View Post
    Richard - Was yours difficult to start only the first time or at anytime after that also. I ask because mine ticks over a bit rough and the first start is always slow - after that it starts fine for the rest of the day. If your symptoms were the same I'll give this a go. Thanks
    Yeah pretty much so, although some first starts were worse than other and therefore needed a second attempt #embarassing

  7. #6
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,510
    nice guide just changed mine
    couldnt find the lil fukker
    as it was pointing downwards
    just got mine from TPS £15.98 inc for sensor o-ring and a new clip

  8. #7
    madstaff's Avatar
    Neutral

    Status
    Offline
    Join Date
    Apr 2012
    Posts
    74
    Is this a 'coolant temperature sensor' or a 'fuel temperature sensor' as it looks as though its fitted in the fuel line??
    Audi A4 Avant 2.0TDi S-Line Special Edition

  9. #8
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,510
    hmm you have got me thinking now
    cos it stank of Diesel

    **** just checked with a lad at audi is is the FTS
    Last edited by bez101; 6th August 2012 at 21:22.

  10. #9
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,510
    but both parts are the same
    sois the CTS same part as the FTS ?

  11. #10
    madstaff's Avatar
    Neutral

    Status
    Offline
    Join Date
    Apr 2012
    Posts
    74
    Its a generic temperature sensor, doesn't matter if its sensing the temperature of diesel or coolant.

    I just wanted to clarify that it was actually the 'fuel temperature sensor' that was being changed.
    Audi A4 Avant 2.0TDi S-Line Special Edition

  12. #11
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,510
    i was changeing the coolant tem sensor
    but saw this guide
    and thanks for pointing it out iv just changed the sensors back around and ill be puting it in the right place tmoro
    back of the engine where is should go
    and iv done so many on petrols but with it been diesel i just went with the guide

  13. #12
    madstaff's Avatar
    Neutral

    Status
    Offline
    Join Date
    Apr 2012
    Posts
    74
    Do you know what number measuring block the values for the fuel temp sensor can be found??

    I have a Snap-On Solus which can view measuring blocks but you have to know which number as where to look, there is no actual description.
    Audi A4 Avant 2.0TDi S-Line Special Edition

  14. #13
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,510
    ill ask my mate tmoro i know hes got a solus so he might know

  15. #14
    madstaff's Avatar
    Neutral

    Status
    Offline
    Join Date
    Apr 2012
    Posts
    74
    Quote Originally Posted by bez101 View Post
    ill ask my mate tmoro i know hes got a solus so he might know
    Found it mate so dont worry about it.

    Group 007, Fuel temp - n/a - Intake air temp - Coolant temp
    Audi A4 Avant 2.0TDi S-Line Special Edition

  16. #15
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,510
    no probs

  17. #16
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,510
    rich the CTS it to the left of the 1 you did
    and very well hidden
    oh and get someone with skinny arms its a rite ****in killer.

  18. #17
    Richardesty's Avatar
    loves quattro

    Status
    Offline
    Join Date
    Oct 2008
    Location
    Louth
    Posts
    753
    ******!

    Thanks Bez, I thought it was too easy to be true!!!!

    Ive now located the bleeder and swapped it out - need to top my coolant up as a result tho.

    I'd best re title the thread!

  19. #18
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,510
    i did it with a hot engine
    and god did i burn my arm

  20. #19
    Richardesty's Avatar
    loves quattro

    Status
    Offline
    Join Date
    Oct 2008
    Location
    Louth
    Posts
    753
    Quote Originally Posted by bez101 View Post
    i did it with a hot engine
    and god did i burn my arm
    I didn't want to admit that bit!

    Damn - I can't change the title of the thread.....

    Apologies everyone!

  21. #20
    quattrojames's Avatar
    Moderator

    Status
    Online
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,856

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    Lol at this thread

    I've edited it, Rich are you happy with how it is now?
    Ingolstance Read about my A6 HERE.

  22. #21
    Richardesty's Avatar
    loves quattro

    Status
    Offline
    Join Date
    Oct 2008
    Location
    Louth
    Posts
    753
    Cheers James, that'll do

  23. #22
    Neutral

    Status
    Online
    Join Date
    May 2012
    Posts
    93
    hi bez
    i still cant find coolant sensor even with the picture! could you give me a bit more detail as to the position?
    thanks

  24. #23
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Aveiro, Portugal
    Posts
    3
    Hi,
    I also have faulty reading on my temperture guage and can't find my CTS on my BRD engine.
    Can anyone help me out?

    Thanks

  25. #24
    SL11CKK's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2011
    Location
    Barking & London
    Posts
    637

    Re: 'How to' photo guide - replacing your Fuel Temperature Sensor on the 2.0 TDi BRD

    The coolant sensor should have 4pins/wires going into it like mine

  26. #25
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Aveiro, Portugal
    Posts
    3
    is the CTS green?

 

 

Similar Threads

  1. 2.5TDi Coolant Temperature Sensor (G62) Replacement Guide
    By quattrojames in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 1
    Last Post: 7th April 2013, 07:14
  2. Engine Coolant Temperature Sensor (G62)
    By gaanrowl in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 4
    Last Post: 1st December 2009, 09:55
  3. Price please on a Coolant Temperature Sensor
    By impster in forum Parts Requests
    Replies: 1
    Last Post: 17th August 2009, 21:11
  4. Engine coolant temperature sensor
    By liam_mcf in forum A4/S4 forum(B5 Chassis)
    Replies: 18
    Last Post: 21st April 2009, 10:08
  5. coolant temperature sensor problem.
    By nu boy in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 30th April 2008, 15:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO