Monster MotorsportEM Tuning
Results 1 to 14 of 14

Thread: Oil Warning?

  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Nov 2008
    Location
    Darlington, England
    Posts
    181

    Oil Warning?

    Hi,
    I was driving today after doing 350 miles and on the last 20 miles a red warning light of an Oil can with the words OIL came on my dash. So I stopped checked the oil lvl which was full and checked for back pressure and water lvl etc. All seemed fine so I drove home.

    I then went out for a meal and when I came back from the meal as the engine was cold the oil light never came on. Then after about 2 mins it came on when the engine had approached temp.

    The light means low oil pressure but any suggestions as to what it could be?

    It flicked on and off after I drove after the meal until it reached temp and then stayed on. It goes off when you stop the engine and will come on again after a min or so of driving or if you get it on boost.

    I havent changed my oil for about 18 months or so (Using 15w 30 semi synthetic), so I know that wont help. But I think it could be a faulty oil pressure sensor or maybe a loose wire as I drove with this light on for at least 70 miles and the car seems ok.

    There are no visible leaks that I can see.
    Any help would be much appreciated

    Thanks
    Andy
    Audi A4 1.8T Sport 2002, Superchipped, Custom Intake And Heat Shield, Stainless 4 Branch Manifold, Forge DV, HID's,

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    simon.m's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    2,746
    i dont no to much about the 18t but i read on here they suffer with oil sludge in the sump this maybe conected or may not just a thought mate and also i see you have not changed the oil in 18mts i can safly say change it asap the car will thank you for it and it really dont matter what oil you have put in it 18mths is to long mate ;-)

  4. #3
    paul20v's Avatar
    Audi fanatic

    Status
    Offline
    Join Date
    May 2009
    Location
    S.Wales
    Posts
    1,108
    Quote Originally Posted by simon2004 View Post
    i dont no to much about the 18t but i read on here they suffer with oil sludge in the sump this maybe conected or may not just a thought mate and also i see you have not changed the oil in 18mts i can safly say change it asap the car will thank you for it and it really dont matter what oil you have put in it 18mths is to long mate ;-)
    There history would suggest this
    and i have to agree 18months is far too long without an oil change on a 1.8T.
    You could get the oil pressure checked but i wouldnt drive the car till you have sorted it out .

  5. #4
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    jesus, dont ignore oil pressure lights! get it checked with a guage. does it sound more rattly at all?

  6. #5
    swarcup's Avatar
    5th Gear
    Breakout Champion

    Status
    Offline
    Join Date
    Sep 2009
    Location
    beverley,East yorkshire
    Posts
    1,270
    1.8t with low oil pressure warning could get costly. GET IT looked at as there is oil sludge issues with these engines as simon said already
    2.5tdi Avant Q S 180 - 19" RS6 reps - chrome mirrors - ambient light package - cruise and dis retrofit - chrome side repeaters - front sline lowr conversion with cupra r splitter - rear lower valance with twin cut outs and exhaust tips - rs4 rear antiroll bar - puddle and footwell lights - sline door blades - fully colour coded - b8 autodimming mirror on custom window adapter - geuine aero wiper upgrade - genuine heated mirror upgrade

  7. #6
    4th Gear

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Lincolnshire
    Posts
    722
    When my oil pressure warning light came on, the red flashing oil can symbol was accompanied by 3 long and loud beeps, and the word 'stop' below it.

    The handbook does say though that if you've got a red flashing oil can, but the oil level is ok, then you shouldn't drive it or even idle it until it has been checked.

    The good news is that as long as you haven't driven it with an oil starved head, it should be ok once the pump and/or strainer is replaced.

    I accompanied my recovered vehicle to a local Audi centre where I observed one of the techs start the car, listen to the loud rattle from the head, turn it off and declared the oil pump/pickup issue. He reassured me that as long as I hadn't driven it like that (I hadn't) then it should be ok, which it was.

    Before I owned the car, it had been on long life servicing. My issue came to a head because one of the first things I did was to use some engine flush and then change the oil. Within less than a mile of doing this on the drive to check everything was ok, I had my issue. Apparently the flush had dislodged loads of crap, which had blocked the strainer...

    I'm kind of glad it did though, at least I've got a new pump and strainer and a clean sump now, so hopefully it won't happen again, especially as I change the oil every 6000 or 6 months.

    So, definitely get yours looked at ASAP, get it recovered to a good VAG specialist. I guess if you're lucky, it's just the oil pressure switch or some other electrical gremlin. Good luck!
    Audi S3 - 2002MY - Denim Blue - Gone
    VW Polo GTI - 2011MY - Candy White - Here

  8. #7
    Higgsy's Avatar
    Hard To Spin

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Jockland
    Posts
    95
    I had this problem a couple of weeks back, the DIS was reading oil pressure and a red oil can came up, i thought it might have been the pressure transmitter or switch but it turned out that the B6 with the 1.8T engine has a nasty habit of the strainer beside the oil pump getting clogged with s**t.

    I was advised that after long journeys leaving the car running for 5 mins before turning it off as if you dont do this the hot oil from the turbo will carbonise and clog the strainer up giving an oil pressure warning.

    If you catch it soon enough you should be fine but if it persists you could starve the engine of oil.

    The only way to check is to get the sump off and if it turns out to be the strainer you might as well change the pump too as it might have been damaged due to starvation.

    Hope this helps and good luck with it.
    2004 A4 Avant 190 (6) S'Line 1.8Tq | 18'' RS4s, GIAC Stage 1+, 007P, Miltek cat, ambient lights, Black Grill Mod, Jetex high flow filter, Gateway 100, Number Plate LEDs, DIS, Turbosmart 30psi Boost Gauge, 230bhp on a cold day!! much more to come next year!!

    Future Mods | Drilled discs, milltek exhaust, red stuff pads, coilovers, in other words ...... $$$$$$$$$$!!

  9. #8
    1st Gear

    Status
    Offline
    Join Date
    Nov 2008
    Location
    Darlington, England
    Posts
    181
    Just been to the garage and they never had time to check it but they said the same thing that the oil pick up is probably blocked with sludge due to not changing the oil. They said to take the sump off and clean the oil pickup and then change the oil.

    My engine isnt making any rattles or knocks its running fine. Trouble I have is I cant put the car off the road as I need it for work so I would have to fix it in 1 session. Im good at mechanics so I know I can do everything but im thinking can I just get away with changing the oil?
    and maybe not remove the sump as I might need an engine hoist to get to the sump nuts (Not sure yet as I havent had a look).

    Im going to buy a new water pump/oil pump and timing belt kit as thats not been done either and I will do it at some point but I was hoping to do it in better weather when my other car is running round march time.

    What do you think?

    Thanks for the help
    Audi A4 1.8T Sport 2002, Superchipped, Custom Intake And Heat Shield, Stainless 4 Branch Manifold, Forge DV, HID's,

  10. #9
    simon.m's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    2,746
    this is just me mate but if you want to keep this car do the job proply dont cut any corners as it will cost you in the long run

  11. #10
    4th Gear

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Lincolnshire
    Posts
    722
    I think the problem with just changing the oil is that if your strainer/pick up is partially blocked, then an oil change won't unblock it.

    To remove the sump, you have to drop the subframe. If you've got a ramp/pit, it shouldn't be too onerous especially if you're ok working on cars. If you're going to do your own cam belt then I assume you are.
    Audi S3 - 2002MY - Denim Blue - Gone
    VW Polo GTI - 2011MY - Candy White - Here

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    Nov 2008
    Location
    Darlington, England
    Posts
    181
    Thanks, I changed the oil and ran it up to temp and it appears to have solved the issue. Im not certain yet though as I havent been out for a good ride. Im going out later and I suppose that will be the test. I dont plan on cutting corners but I do need to extend the time I have before I do the engine as I need my other car on the road. So if it will be ok until March I will change both pumps and the belt at that point. I will probably drop the oil again and have another change.

    If the light comes on then I have no choice but to do the whole job straight away which I will.

    Its a slight problem having to remove the subframe as I dont have a ramp or pit and I would have to do it on axle stands which are on my other car at present.

    I have no problem with removing its just going to take me alittle longer to do it.
    Audi A4 1.8T Sport 2002, Superchipped, Custom Intake And Heat Shield, Stainless 4 Branch Manifold, Forge DV, HID's,

  13. #12
    Higgsy's Avatar
    Hard To Spin

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Jockland
    Posts
    95
    I agree
    Quote Originally Posted by simon2004 View Post
    this is just me mate but if you want to keep this car do the job proply dont cut any corners as it will cost you in the long run
    2004 A4 Avant 190 (6) S'Line 1.8Tq | 18'' RS4s, GIAC Stage 1+, 007P, Miltek cat, ambient lights, Black Grill Mod, Jetex high flow filter, Gateway 100, Number Plate LEDs, DIS, Turbosmart 30psi Boost Gauge, 230bhp on a cold day!! much more to come next year!!

    Future Mods | Drilled discs, milltek exhaust, red stuff pads, coilovers, in other words ...... $$$$$$$$$$!!

  14. #13
    Az
    Az's Avatar
    Hard slammed!

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Hertfordshire
    Posts
    1,023
    I had the same symptoms a while back, was very intermittent, and the oil level was fine as I'd only had it serviced a few weeks before hand, so i got Russell automotive centre (vag specialists) to check it out. They did an oil pressure test and that was 100%, so they checked out all the sensors and wiring and found it to be a dodgy connection to the oil pressure sensor. They re-wired it for me and I haven't had any issues what so ever with it since. Cost me about 35 iirc.
    B6 A4 2.5 V6 TDi Quattro Sport

    Dolphin Grey I 210 BHP Remap I KW V1 Coilovers I 19"x9.5" all round BBS LM reps I RS4 Anti Roll Bar Kit I S4 Front and Rear Bumpers I Votex side skirts I S4 Aluminium Mirrors I S4 Rear Spoiler I S4 Style Tailpipes I USDM S4 licence plate blank I 6000k HID's I 18 SMD DRL's I Cupra R Splitter I Full RS4 black leather with white stitch optional bucket seat interior I RS4 black headlining I TT S Line FBMFSW I Aluminium Trim I Reverse camera I Full DIS I Cruise Control

  15. #14
    Neutral

    Status
    Offline
    Join Date
    Jan 2010
    Posts
    70
    Does anyone know where the oilsensor is located, i have the same problem on my 3.0 V6.... and have run the car for more than 500kms now with this light on and off... it still runs good!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO