Sky InsuranceBadger5
Page 1 of 2 12 LastLast
Results 1 to 40 of 45
  1. #1
    tobycruse's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    UK
    Posts
    287

    Unhappy HELP - Car in very bad way....

    I just went out for a drive, a quick blast near by on a dual carriage way. Got to a set of lights and pulled away, the car stuttered a bit and then got worse.

    The car will now not go past 4000rpm and will only build 5psi of boost. I have had a quick look in the engine bay and all the hoses seem to be secure.

    The car will still drive but it feels like 80% of the power is missing and someone moved the limiter to 4000rpm.

    What could this be? Really worried its something bad.... Any advice would be much appriacated.
    Who said speed kills!?!?....But dangerous driving on the other hand....
    Ibis White S3 Sportback - ?bhp - ?lb/ft (Being Fixed)
    Mods: LED's Throughout, Milltek TBE, Revo S2+, Forge CAI (Gold), K&W V3's 25mm, H&R ARB's, Powerflex Bushes, Autotech HPFP, Sachs Clutch, Forge DV, Jonny's PCV Mod, Defi Boost Gauge, Pro Alloy Intercooler, 18" OZ Alleggerita's, NGK Iridium Spark Plugs, VI Performance Monitor, Road Angel Pro Connected
    Full OEM Springs and Shocks for sale from 2008 S3 CLICK ME

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,073
    Limp mode by sounds of it Toby, get vagcom on it, disconnect battery for few mins then reconnect see if it does anything to rectify.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  4. #3
    tobycruse's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    UK
    Posts
    287
    The engine warning light hasn't come on, still worth disconnecting the battery?
    Who said speed kills!?!?....But dangerous driving on the other hand....
    Ibis White S3 Sportback - ?bhp - ?lb/ft (Being Fixed)
    Mods: LED's Throughout, Milltek TBE, Revo S2+, Forge CAI (Gold), K&W V3's 25mm, H&R ARB's, Powerflex Bushes, Autotech HPFP, Sachs Clutch, Forge DV, Jonny's PCV Mod, Defi Boost Gauge, Pro Alloy Intercooler, 18" OZ Alleggerita's, NGK Iridium Spark Plugs, VI Performance Monitor, Road Angel Pro Connected
    Full OEM Springs and Shocks for sale from 2008 S3 CLICK ME

  5. #4
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,073
    Wont do it any harm mate, but get vagcom on it, assume you have vag.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  6. #5
    tobycruse's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    UK
    Posts
    287
    There also seems to be a tapping/knocking noise coming from the engine bay once every 6 to 8 seconds. Sounds a bit like metal expanding and contracting with heat but I have never heard it before.
    Who said speed kills!?!?....But dangerous driving on the other hand....
    Ibis White S3 Sportback - ?bhp - ?lb/ft (Being Fixed)
    Mods: LED's Throughout, Milltek TBE, Revo S2+, Forge CAI (Gold), K&W V3's 25mm, H&R ARB's, Powerflex Bushes, Autotech HPFP, Sachs Clutch, Forge DV, Jonny's PCV Mod, Defi Boost Gauge, Pro Alloy Intercooler, 18" OZ Alleggerita's, NGK Iridium Spark Plugs, VI Performance Monitor, Road Angel Pro Connected
    Full OEM Springs and Shocks for sale from 2008 S3 CLICK ME

  7. #6
    A3simon's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Nov 2006
    Location
    Aberdeen
    Posts
    980
    i had something similar when i fitted the autotech pump internals as they seized up might be that


    2009 Suzuki GSXR1000K9 SE in White
    2012 Triumph Speed Triple R in Black
    2012 RS3 in Racing Mica Blue
    2012 A1 TFSI in Misano red (shared with mum)

  8. #7
    tobycruse's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    UK
    Posts
    287
    Just disconnected the battery for 3 minutes, the car is still in limp home mode. Now the car says there is an ESP fault and power steering fault, but these come up when the battery is disconnected I'm sure. Still no fault codes coming up, any other ideas guys?

    Should i take it back to Audi or AmD to fix?
    Who said speed kills!?!?....But dangerous driving on the other hand....
    Ibis White S3 Sportback - ?bhp - ?lb/ft (Being Fixed)
    Mods: LED's Throughout, Milltek TBE, Revo S2+, Forge CAI (Gold), K&W V3's 25mm, H&R ARB's, Powerflex Bushes, Autotech HPFP, Sachs Clutch, Forge DV, Jonny's PCV Mod, Defi Boost Gauge, Pro Alloy Intercooler, 18" OZ Alleggerita's, NGK Iridium Spark Plugs, VI Performance Monitor, Road Angel Pro Connected
    Full OEM Springs and Shocks for sale from 2008 S3 CLICK ME

  9. #8
    S3 Big Andy's Avatar
    Stealth Beast Baby Yay

    Status
    Offline
    Join Date
    Feb 2008
    Location
    Bramley Hants
    Posts
    707
    Amd sounds like a turbo problem, hope its not blown!
    Phantom Black, Revo, 450+ BHP , Milltek Evom's, Autotech fuel pump, RS4 brakes 18" Pro Race 1.2 team Dynamics, H&R ARB's, Bilstein PSS10's, Forge Twintercooler, GT3071R, RS4 Injectors, Helix racing clutch, Custom downpipe de-catted straight pipe to back box, 12.6second 1/4 mile! 4.03 sec's 0-60 This isnt just any car, this, THIS WAS the Stealth Beast!!
    Gone but not forgotten
    VCDS GONE TOO
    http://www.andyoram.co.uk





  10. #9
    A3simon's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Nov 2006
    Location
    Aberdeen
    Posts
    980
    yeah those lights always come on when the battery has been disconnected
    it does sound like the problem i had with the autotech pump


    2009 Suzuki GSXR1000K9 SE in White
    2012 Triumph Speed Triple R in Black
    2012 RS3 in Racing Mica Blue
    2012 A1 TFSI in Misano red (shared with mum)

  11. #10
    tobycruse's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    UK
    Posts
    287
    Ok, what ever it is. Is the car ok to drive in this state?

    I'm getting DV broken from one forum and pump broken from another!
    Who said speed kills!?!?....But dangerous driving on the other hand....
    Ibis White S3 Sportback - ?bhp - ?lb/ft (Being Fixed)
    Mods: LED's Throughout, Milltek TBE, Revo S2+, Forge CAI (Gold), K&W V3's 25mm, H&R ARB's, Powerflex Bushes, Autotech HPFP, Sachs Clutch, Forge DV, Jonny's PCV Mod, Defi Boost Gauge, Pro Alloy Intercooler, 18" OZ Alleggerita's, NGK Iridium Spark Plugs, VI Performance Monitor, Road Angel Pro Connected
    Full OEM Springs and Shocks for sale from 2008 S3 CLICK ME

  12. #11
    3rd Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    south yorkshire
    Posts
    628
    sounds like a turbo problem to me no boost lack of power

  13. #12
    tobycruse's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    UK
    Posts
    287
    It takes about 40 minutes to get to AmD, is it ok to DRIVE the car in this state?
    Who said speed kills!?!?....But dangerous driving on the other hand....
    Ibis White S3 Sportback - ?bhp - ?lb/ft (Being Fixed)
    Mods: LED's Throughout, Milltek TBE, Revo S2+, Forge CAI (Gold), K&W V3's 25mm, H&R ARB's, Powerflex Bushes, Autotech HPFP, Sachs Clutch, Forge DV, Jonny's PCV Mod, Defi Boost Gauge, Pro Alloy Intercooler, 18" OZ Alleggerita's, NGK Iridium Spark Plugs, VI Performance Monitor, Road Angel Pro Connected
    Full OEM Springs and Shocks for sale from 2008 S3 CLICK ME

  14. #13
    A3simon's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Nov 2006
    Location
    Aberdeen
    Posts
    980
    should be fine if you dont have any warning lights and you keep it low revs


    2009 Suzuki GSXR1000K9 SE in White
    2012 Triumph Speed Triple R in Black
    2012 RS3 in Racing Mica Blue
    2012 A1 TFSI in Misano red (shared with mum)

  15. #14
    tobycruse's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    UK
    Posts
    287
    Quote Originally Posted by A3simon View Post
    should be fine if you dont have any warning lights and you keep it low revs
    Thanks Simon, i have been doing just that and it seems to be ok.

    Will take it to AmD first thing tomorrow, will write up as soon as i know what's wrong! Finger's crossed its either the DV or the HPFP.

    Thanks for all your help guys, will report back soon!
    Who said speed kills!?!?....But dangerous driving on the other hand....
    Ibis White S3 Sportback - ?bhp - ?lb/ft (Being Fixed)
    Mods: LED's Throughout, Milltek TBE, Revo S2+, Forge CAI (Gold), K&W V3's 25mm, H&R ARB's, Powerflex Bushes, Autotech HPFP, Sachs Clutch, Forge DV, Jonny's PCV Mod, Defi Boost Gauge, Pro Alloy Intercooler, 18" OZ Alleggerita's, NGK Iridium Spark Plugs, VI Performance Monitor, Road Angel Pro Connected
    Full OEM Springs and Shocks for sale from 2008 S3 CLICK ME

  16. #15
    A3simon's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Nov 2006
    Location
    Aberdeen
    Posts
    980
    if you take it above 4k does it feel like the car is stuttering and wont rev any higher


    2009 Suzuki GSXR1000K9 SE in White
    2012 Triumph Speed Triple R in Black
    2012 RS3 in Racing Mica Blue
    2012 A1 TFSI in Misano red (shared with mum)

  17. #16
    Iggu's Avatar
    5th Gear

    Status
    Offline
    Join Date
    May 2008
    Location
    Here
    Posts
    1,224
    Toby - I've just replied on the other forum but its a 10sec job to check the DV. If you have the green spring with your Forge it may have collapsed (you need the yellow one for remapped cars). If so its a 6 fix ... at least checking it now would rule this possibility out (or in).
    Phantom Black S3, RNS-E with SDS Hack , BOSE, Sunroof, iPod, ITG CAI, Forge DV, Milltek TBE, Revo Stage 2+, Autotech HPFP, Sachs clutch, Lamin-X, BBS Pescaras, H&R springs, H&R ARBs, NGK Iridium Plugs, Vagcom.

  18. #17
    N8
    N8's Avatar
    Kowalski Details

    Status
    Offline
    Join Date
    Jul 2007
    Location
    Salford, Manchester
    Posts
    17,133

    My Social Networking

    Add N8 on Facebook Visit N8's Instagram Channel
    Hope you get it sorted Toby.

  19. #18
    tobycruse's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    UK
    Posts
    287
    Just had a look inside the DV, you are right, i have the GREEN spring. Though the spring looks perfectly ok, it doesn't look like it has collapsed.

    Also, upon starting the car, it turns over about 3 to 4 times rather than starting straight away. Would this be a symptom of the DV spring as well?

    How do i get the yellow spring?
    Who said speed kills!?!?....But dangerous driving on the other hand....
    Ibis White S3 Sportback - ?bhp - ?lb/ft (Being Fixed)
    Mods: LED's Throughout, Milltek TBE, Revo S2+, Forge CAI (Gold), K&W V3's 25mm, H&R ARB's, Powerflex Bushes, Autotech HPFP, Sachs Clutch, Forge DV, Jonny's PCV Mod, Defi Boost Gauge, Pro Alloy Intercooler, 18" OZ Alleggerita's, NGK Iridium Spark Plugs, VI Performance Monitor, Road Angel Pro Connected
    Full OEM Springs and Shocks for sale from 2008 S3 CLICK ME

  20. #19
    tobycruse's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    UK
    Posts
    287
    Just ordered the yellow spring from Forge...... Hope its the solution!
    Who said speed kills!?!?....But dangerous driving on the other hand....
    Ibis White S3 Sportback - ?bhp - ?lb/ft (Being Fixed)
    Mods: LED's Throughout, Milltek TBE, Revo S2+, Forge CAI (Gold), K&W V3's 25mm, H&R ARB's, Powerflex Bushes, Autotech HPFP, Sachs Clutch, Forge DV, Jonny's PCV Mod, Defi Boost Gauge, Pro Alloy Intercooler, 18" OZ Alleggerita's, NGK Iridium Spark Plugs, VI Performance Monitor, Road Angel Pro Connected
    Full OEM Springs and Shocks for sale from 2008 S3 CLICK ME

  21. #20
    2nd Gear

    Status
    Offline
    Join Date
    Aug 2008
    Posts
    408
    good luck toby hope its something silly m8

  22. #21
    Ash B's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2008
    Location
    Cardiff
    Posts
    5,806
    Hi Toby

    Sorry to hear about your problem with the car. Hope that its nothing major and just that you need a yellow spring from forge. Let us know how you get on at AMD.

    Ashley
    Dark Vader Half sibling - MyThread

  23. #22
    warren_S5's Avatar
    Moderator

    Status
    Offline
    Join Date
    Oct 2007
    Posts
    7,157
    Can you chuck the the original DV back on to remove that issue from the equation?

    The metallic sound doesn't sound promising.

    Be fascinating to see what this is, and keep my fingers crossed for you that all is well after the diagnosis. We don't want 2 S3's going down in as many weeks.
    Audi S5 3.0V6T Coupe Black Edition

  24. #23
    s3
    s3

    Status
    Offline
    Join Date
    Dec 2008
    Location
    stoke
    Posts
    50
    i would say this is definately a turbo issue. I had exactly the same thing happen just before xmas last year. I was driving normally and then there was no power, was very flat, revs very slow to build up, think i has 2psi boost.....
    I continued tried everything and the more times i tested the car on the road and the engine was running it started to get noisier and eventually so noisy i had it towee in the garage.
    If i was you i would leave driving to a minimal and maybe get it towed in etc.....
    I feel for you as i know exactly how i felt last year when mine blew.

    good luck and keep us informed

    andy

  25. #24
    kaz219's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Manchester/Liverpool Uni
    Posts
    1,796
    If its a turbo issue, you could knacker the engine by driving it.

    When my turbo blew on my tdi, a scraping noise would come from the engine every few secs - the shaft had snapped...

    I wouldnt drive it, keep an eye on oil and tow it down to AMD (if the DV issue doesnt fix it).

    Hope you get it fixed..
    Audi A3 S-Line DSG - sold
    Golf Mk4 Autograph - sold
    Currently Vtec'in around in an Accord Type R :P

    For Sale: ST3 Remap Console - PM Me :P
    Vagcom'd too

  26. #25
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,520

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    When my turbo blew using the car to travel 1.5 miles to get to a safe place to stop, used the whole sumps worth of oil. So be aware of that if you choose to drive it.

    I honestly cannot see the spring making any difference as the fault would more likely be not holding boost, unless the spring was FUBAR which you say it's not.

    The poor starting can be attributed to safe mode, you need to get the car scanned and post results. Maybe you have dropped a coil pack? is she still running smooth?

  27. #26
    kaz219's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Manchester/Liverpool Uni
    Posts
    1,796
    Quote Originally Posted by Byzan A4 View Post
    When my turbo blew using the car to travel 1.5 miles to get to a safe place to stop, used the whole sumps worth of oil. So be aware of that if you choose to drive it.
    There's the issue of the oil usage and the issue of the debris from the turbo going back into the engine and wrecking it - i honestly wouldnt drive it mate...

    I turned mine off straight away and debris still got to the intercooler (there were big chunky bits too - a whole blade of the propeller!)
    Audi A3 S-Line DSG - sold
    Golf Mk4 Autograph - sold
    Currently Vtec'in around in an Accord Type R :P

    For Sale: ST3 Remap Console - PM Me :P
    Vagcom'd too

  28. #27
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,073
    Have you scanned it with vagcom as yet Toby?

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  29. #28
    S3 Big Andy's Avatar
    Stealth Beast Baby Yay

    Status
    Offline
    Join Date
    Feb 2008
    Location
    Bramley Hants
    Posts
    707
    It could be a stock map turning back on I did have this proplem with mine once I had disconnected the battery, and mines revo!
    Phantom Black, Revo, 450+ BHP , Milltek Evom's, Autotech fuel pump, RS4 brakes 18" Pro Race 1.2 team Dynamics, H&R ARB's, Bilstein PSS10's, Forge Twintercooler, GT3071R, RS4 Injectors, Helix racing clutch, Custom downpipe de-catted straight pipe to back box, 12.6second 1/4 mile! 4.03 sec's 0-60 This isnt just any car, this, THIS WAS the Stealth Beast!!
    Gone but not forgotten
    VCDS GONE TOO
    http://www.andyoram.co.uk





  30. #29
    tobycruse's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    UK
    Posts
    287
    Odd that when i got it back from Audi it was running fine. Only 2 days later did the fault appear. I did tell the garage NOT to re flash the ecu.... Im sure if they had the car would have been like that out of the garage? Anywho, AmD have already deduced that it isnt a software problem..... The search continues......
    Who said speed kills!?!?....But dangerous driving on the other hand....
    Ibis White S3 Sportback - ?bhp - ?lb/ft (Being Fixed)
    Mods: LED's Throughout, Milltek TBE, Revo S2+, Forge CAI (Gold), K&W V3's 25mm, H&R ARB's, Powerflex Bushes, Autotech HPFP, Sachs Clutch, Forge DV, Jonny's PCV Mod, Defi Boost Gauge, Pro Alloy Intercooler, 18" OZ Alleggerita's, NGK Iridium Spark Plugs, VI Performance Monitor, Road Angel Pro Connected
    Full OEM Springs and Shocks for sale from 2008 S3 CLICK ME

  31. #30
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,073
    So thats a no then???

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  32. #31
    Iggu's Avatar
    5th Gear

    Status
    Offline
    Join Date
    May 2008
    Location
    Here
    Posts
    1,224
    Just had a thought Toby - you been through any deep puddles recently and kept your foot down ? Possible hydrolock of the turbo given the Forge CAI you have ?
    Phantom Black S3, RNS-E with SDS Hack , BOSE, Sunroof, iPod, ITG CAI, Forge DV, Milltek TBE, Revo Stage 2+, Autotech HPFP, Sachs clutch, Lamin-X, BBS Pescaras, H&R springs, H&R ARBs, NGK Iridium Plugs, Vagcom.

  33. #32
    10blazin's Avatar
    HYPERDRIVE NEEDED

    Status
    Offline
    Join Date
    Dec 2008
    Location
    gorton
    Posts
    3,272
    whay about a coil lol ... i no it may sound daft but my car ran like a bag of poo when one went ...but as your saying its the turbo ??? you got a ny lights on the dash engine light or anything

  34. #33
    tobycruse's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    UK
    Posts
    287
    No engine warning lights. Just wont go past 4000rpm and about a 90% loss of power. A bit like driving a 1.0L!
    Who said speed kills!?!?....But dangerous driving on the other hand....
    Ibis White S3 Sportback - ?bhp - ?lb/ft (Being Fixed)
    Mods: LED's Throughout, Milltek TBE, Revo S2+, Forge CAI (Gold), K&W V3's 25mm, H&R ARB's, Powerflex Bushes, Autotech HPFP, Sachs Clutch, Forge DV, Jonny's PCV Mod, Defi Boost Gauge, Pro Alloy Intercooler, 18" OZ Alleggerita's, NGK Iridium Spark Plugs, VI Performance Monitor, Road Angel Pro Connected
    Full OEM Springs and Shocks for sale from 2008 S3 CLICK ME

  35. #34
    10blazin's Avatar
    HYPERDRIVE NEEDED

    Status
    Offline
    Join Date
    Dec 2008
    Location
    gorton
    Posts
    3,272
    im really cack on cars but when my coil went , only one by the way it was like a 1.4 to it was really bad i thought the car was dead serious , and it turned out to be a 40 pound coil i couldnt believe it when roadside turned up went pop done and drove off i was one happy man .....

  36. #35
    Staz's Avatar
    is a retronaut

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Bristol (mostly)
    Posts
    6,168
    I somehow completely missed this thread Toby.

    I knew a guy who complained of a similar problem (although I don't think as bad) and as has been said above it turned out he had the wrong spring in his DV. He fitted it himself and didn't know any different.

    Has yours arrived yet?
    8P2 S3

    For advice on Air Con problems please read my FAQs.
    To find ASN members with VCDS check out the MAP.

  37. #36
    gavsteryoung's Avatar
    Neutral

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    56
    as you have the 09 facelift.... do the revs get stuck at the same rpm that the engine does if you just leave it in neutral and put your foot down?

    Could it be related to that?

    Not sure how this rev limiter works, wheather there's an actual micro switch or if it detects your in a gear... does the DIS show what gear your in still?

    Did the older non facelift S3's have this torque limiter in 1st gear?
    2009 Audi S3 Sprint Blue
    1999 Audi S4 2.7 Bi-Turbo Ming Blue (gone but never forgotton)
    1998 Audi A4 1.8 SE Silver
    1995 VW Vento 2.0GL Ming Blue
    1988 VW Jetta 1.6TX Red

  38. #37
    tobycruse's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    UK
    Posts
    287
    The car is being diagnosed today by AmD. I pray it isn't something complicated, big and expensive!

    Will report back as soon as I hear anything....
    Who said speed kills!?!?....But dangerous driving on the other hand....
    Ibis White S3 Sportback - ?bhp - ?lb/ft (Being Fixed)
    Mods: LED's Throughout, Milltek TBE, Revo S2+, Forge CAI (Gold), K&W V3's 25mm, H&R ARB's, Powerflex Bushes, Autotech HPFP, Sachs Clutch, Forge DV, Jonny's PCV Mod, Defi Boost Gauge, Pro Alloy Intercooler, 18" OZ Alleggerita's, NGK Iridium Spark Plugs, VI Performance Monitor, Road Angel Pro Connected
    Full OEM Springs and Shocks for sale from 2008 S3 CLICK ME

  39. #38
    6th Gear

    Status
    Offline
    Join Date
    Feb 2008
    Posts
    2,817
    good luck for it mate,
    2000 AMK S3, Revo'd, forge 007p, B8's, H&R's, tarox g88's, ferrodo ds2500's, and in the fastest colour



  40. #39
    tdisportuk's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2009
    Location
    UK
    Posts
    459
    good luck mate hope its not major!

  41. #40
    5th Gear

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Staffordshire
    Posts
    1,241
    any news mate?

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO