AH FabricationsMonster Motorsport
Results 1 to 12 of 12
Like Tree2Likes
  • 2 Post By <tuffty/>

Thread: esp light then engine management ??? :S

  1. #1
    Neutral

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Prudhoe, Northumberland
    Posts
    40

    esp light then engine management ??? :S

    had the car out today for about 70 mile run...had the esp off and everything was ok then the car decided to cut out so restarted it and this happened on and off for few minutes! then esp light stayed on even when i tried to turn it off. so drove home everything was ok until i restarted the car again and now have the engine management light on...anyone guess what is wrong please? its an 03 bam s3 by the way with minor mods

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Sandra's Avatar
    MODERATOR

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Scotland
    Posts
    14,342
    Have you done a vcds scan for any possible fault codes?
    Smaller (Local) Events
    Audi-Sport.net online magazine.
    Audi-sport.net Lanyards & Stickers
    To find Audi-Sport-Net members with VCDS check out the MAP.





  4. #3
    Neutral

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Prudhoe, Northumberland
    Posts
    40
    not yet im doing that tomorrow as i dont have a scanner to hand im just very inpatient lol

  5. #4
    Sandra's Avatar
    MODERATOR

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Scotland
    Posts
    14,342
    Quote Originally Posted by finny View Post
    not yet im doing that tomorrow as i dont have a scanner to hand im just very inpatient lol
    Fair enough. If you dont have your own vcds cable, check out the vcds map for users near you. Hope you get it sorted out soon. x
    Smaller (Local) Events
    Audi-Sport.net online magazine.
    Audi-sport.net Lanyards & Stickers
    To find Audi-Sport-Net members with VCDS check out the MAP.





  6. #5
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,027
    As said mate, need to read the fault codes as this could be a number of things... normally if the ESP light stays on and the CEL then comes on its the MAF...

    This will help you work out the codes...
    IMPORTANT! - When posting asking for help... - PLEASE READ BEFORE POSTING (UPDATED)

    <tuffty/>
    Sandra and phil miller like this.
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  7. #6
    Neutral

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Prudhoe, Northumberland
    Posts
    40
    sound il see what it brings up and get back to you mate

  8. #7
    phil miller's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Sep 2012
    Location
    Devon
    Posts
    843
    As Paul has said MAF all day long dude
    ​Wish Rachel would let me have my TDI mk5 back


  9. #8
    Neutral

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Prudhoe, Northumberland
    Posts
    40
    ok ok where did you two buy these crystal balls lol? no on a serious note:

    17939 camshaft adjustment open circuit?

    16717 knock sensor signal too high

    16712 same again knock sensor

    16486 mass air flow signal too low

    please dont tell me my car is dying?

    also showed up brake ligh switch which could be fault with esp?

  10. #9
    Neutral

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Prudhoe, Northumberland
    Posts
    40
    oh and 01314 engine control module something?

  11. #10
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,027
    Category:Fault Codes - Ross-Tech Wiki

    Look at the link above for fault code explanations...

    For example....
    01314 - Ross-Tech Wiki

    Sounds like a load of wiring issues potentially... have you cleared them to see what comes back?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  12. #11
    Neutral

    Status
    Offline
    Join Date
    Feb 2013
    Location
    Prudhoe, Northumberland
    Posts
    40
    excuse my ignorance but im no good at all when it comes to all this...ive cleared them yeah but the light has just came back on due to MAF which il replace next week but as for the others i dont have a clue?

  13. #12
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,027
    Quote Originally Posted by finny View Post
    ok ok where did you two buy these crystal balls lol?
    I am THAT good

    Quote Originally Posted by finny View Post
    17939 camshaft adjustment open circuit?
    17939/P1531/005425 - Ross-Tech Wiki
    VVT is either unplugged or there is a break in the wiring... check that the VVT tensioner is plugged in...

    Quote Originally Posted by finny View Post
    16717 knock sensor signal too high
    16717/P0333/000819 - Ross-Tech Wiki

    I have had this with sensor 1 before and I fixed mine be rewiring to the ECU...

    Quote Originally Posted by finny View Post
    16712 same again knock sensor
    16712/P0328/000808 - Ross-Tech Wiki
    Not the same knock sensor... this is sensor 1, the previous code is sensor 2...

    Quote Originally Posted by finny View Post
    16486 mass air flow signal too low
    16486/P0102/000258 - Ross-Tech Wiki

    MAF sensor... normally associated with a duff sensor... worth getting a new (Bosch/genuine) one if you don't know the history of the one on there currently...

    Quote Originally Posted by finny View Post
    also showed up brake ligh switch which could be fault with esp?
    implausible signal? code would help... normally a dodgy switch...

    Considering the sensor codes, it could be also related to a bad earth or other dodgy wiring... there is a collection of earths under the battery tray that get corroded... worth checking there... also check the loom where there injectors etc all cumulate... this could reveal damage to the loom (can happen if for example some ham fisted lout fitted a clutch and trapped the wires or something)

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

 

 

Similar Threads

  1. Coil Light Flashing & Engine Management Light
    By vik007 in forum A3/S3/Sportback (8P Chassis)
    Replies: 1
    Last Post: 3rd December 2012, 19:43
  2. Engine Management & ESP warning light problem.
    By Barry#1 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 6
    Last Post: 19th May 2010, 13:58
  3. ESP light then Engine Management light
    By V6Pete in forum A3/S3/Sportback (8P Chassis)
    Replies: 7
    Last Post: 10th March 2010, 08:50
  4. Engine management + ESP light on...Help!!
    By Pooch121 in forum A3/S3 Forum (8L Chassis)
    Replies: 7
    Last Post: 15th July 2009, 17:45
  5. Engine management light and ESP light on
    By AndyS3 in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 13th June 2005, 14:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO