Xtrons Headunit...

AK47UK

Registered User
If I understood you correctly you connected the rear speakers RCA to the RCA connection that was working and you had rear audio at a level that you would expect so that proves the speakers and car wiring is ok. I don't believe you would need to amp the RCA signal so simply splitting the working RCA connection and using this to hook up all the speakers should work. You can try local shops or if not go to eBay.
 

pezza1892

Registered User
The unit is in!! I took all your advice AK47UK and bought the splitter to split the decent connection, now it all works - the only problem I have now is that the unit doesnt sit square in the dash, how frustrating!!! any ways to sort this out as it is a proper nuisance - cant the mounting brackets be changed so it fits snug or any ways to modify it so it fits how it should?

Thanks Alot
 

AK47UK

Registered User
I assume you mean the bottom of the unit isn't held in place? I had the same problem and upgraded to a Zenec before I had time to look into it. One thing I did notice as I packaged my xtrons to sell it on was the metal retention clips weren't bent out very far so maybe try bending them further out. Other than that I seem to remember there being a screw thread on the centre of the rear panel, a lot of headunits screw a stud into that and if there isn't a hole in the same place inside the dash for it to sit you could drill one as long as you checked it wasn't going to damage anything. It will line up with a bit of plastic iirc.
 

McCann

Registered User
Guys, im looking at buying a Xtrons unit for my Audi a4 B7, how have you found it? don't really fancy paying top whack for one, but also don't want to waste £300!
 

axelmann

Registered User
Hi I have one of these headings but the bottom doesn't stay in place, really annoying, has anyone fixed it place somehow??
 
Top