Wireless CarPlay

D.C. Christopher

Registered User
I know there’s now a VCDS/OBDEleven solution for 2020 model year A4/S4/A5/S5 models but for earlier model years or for people who don’t want to buy a VCDS/OBDEleven dongle (which comes in handy quite often), the CarPlay2Air dongle is on sale for the next three days for $99 (as opposed to the usual $159): https://cplay2air.com/products/cpla...y-android-auto-module-and-mirror-link-feature

It bears to note that there’s now a firmware update that supports cars with USB-C ports, like the 2020 model year ones. You just have to use an adapter if you absolutely must plug into the port under the armrest.
 

HMG1K

Registered User
I can't see an option for wireless Carplay in OBDeleven for the B9.5 of B9 A5s. Is it a long code option or in the 'quick apps'?

Can it be done in Carista?
 

harvsurrey

New Member
@thorpemark1 .

Trying to get Android auto working and have followed your instructions obviously selecting both carplay and android auto adaptions when required and seems to have all been stored (using ObdEleven)

When I search in WiFi on my phone ( Samsung S21 Ultra ) the only network I see is the one the car transmits for the Cubictelecom networks which are obviously the built in paid services.

Should I be doing anything else as I can't see the 5ghz network ( yes marked as visible in adaptions)
Also tried changing the channel from 149 to 40 but still no luck .

Really thought I would set my mind to sorting this once I had my new phone on Friday.

Slightly frustrated but unsurprised it's not worked as these things are never simple.

Hoping to sort so I can also have the unit not disconnect my teams audio connection so I can be on conference calls in the car.

Help !! ( if anyone has any idea)

Sent from my SM-G998B using Tapatalk
 

thorpemark1

Registered User
Have the adaptation been done in both 5F and 75 modules (with the bonnet up ) ?

Some have said they needed to leave the car a couple of hours before changes in 75 took effect.

I didn’t need to connect to the WiFi.
Make sure you remove the Bluetooth connection from your phone and the mmi.

Try rebooting the mmi. - long press power button.

When I re-pair the iPhone over Bluetooth it the asks if I’d like to use CarPlay over wireless.
(The initial negotiation is done over Bluetooth. I guess this then instructs you phone to connect over WiFi )

Let me know how you get on.
Are you using obdeleven. ? Have you entered the security access codes before adaptation of each module?

There is an option in odb to soft reboot the 75 module but I don’t recall where it is. I’ll try and check when I get a moment.


Sent from my iPad using Tapatalk
 

harvsurrey

New Member
OK I might have missed some things when coding.
I do have Obd11 Pro and have not been asked to input any security codes.
I did make all of your changes in both 5f and 75.
Did a full MMi reboot , and did have the bonnet open.
When I went back to check all the coding was as per the changes.

I will now pop back in the car and connect bluetooth again and see what happens.

Other than having to input any security code I have followed your instructions to the letter with the addition of checking the android auto options.

Couple of hours across the Internet and nothing had shead any light so many thanks for replying.

I have previously managed to code in 2 phones to simultaneously work on Bluetooth OK.

Sent from my SM-G998B using Tapatalk
 

harvsurrey

New Member
@thorpemark1 so I moved the car away from the house and any conflicting wifi .

I do now see 2 audi networks on a WiFi scan as seen in the pics.

Not sure if my connected devices promt has changed ? Maybe I do have wireless carplay sorted but not android auto.

See attached pics
4a87f2c98bfb28e587e0b4dea63eeacd.jpg
fef7e4f993a578a5c28d04851a74920d.jpg
097ec4ab8e37f42851fa3358414383f5.jpg


Sent from my SM-G998B using Tapatalk
 

thorpemark1

Registered User
Looks like what I see for CarPlay.

Have you paired re paired you phone with Bluetooth. ?

It’s actually asking you to connect with Bluetooth

It then shows up for me ( CarPlay )

I’m guessing as I don’t have android, and didn’t set it.

There are 2 place to set google android auto. One in 5f , one in 75. They are both under Smartphone configuration.

bd4085af9d7e1320cfb0a7b27b192d1e.jpeg



Sent from my iPad using Tapatalk
 

harvsurrey

New Member
I will check both are connected in 5f and 75 for android auto.
Confusingly doing some reading about first connection on android auto it says you have to use the USB connection and then unplug it .
Then it should stay connected and reconnect wireless on next try

Sent from my SM-G998B using Tapatalk
 

harvsurrey

New Member
@thorpemark1

OK so I took out the carplay option to both say no and this removes the message to connect via audi_388 blah blah ....

Android auto is still left as on .

Now reading up on connecting android auto it suggests first connection is done via cable.
However the minute I connect the cable the MMI disconnects and greys out the Bluetooth.
I suspect there may be a setting to stop that happening. (Maybe)

I can go into the app on the phone and it asks me to connect to Bluetooth which I do but alas nadda.

Frustratingly close I am sure , as I am sure if I had an iPhone it would connect wirelessly.

Maybe some more searching.


Sent from my SM-G998B using Tapatalk
 

HMG1K

Registered User
Looks like what I see for CarPlay.

Have you paired re paired you phone with Bluetooth. ?

It’s actually asking you to connect with Bluetooth

It then shows up for me ( CarPlay )

I’m guessing as I don’t have android, and didn’t set it.

There are 2 place to set google android auto. One in 5f , one in 75. They are both under Smartphone configuration.

bd4085af9d7e1320cfb0a7b27b192d1e.jpeg



Sent from my iPad using Tapatalk

What's your screen grab in / from? Is it long coding or in OBD / Carista? Looks simple to try!
 

thorpemark1

Registered User
@thorpemark1

OK so I took out the carplay option to both say no and this removes the message to connect via audi_388 blah blah ....

Android auto is still left as on .

Now reading up on connecting android auto it suggests first connection is done via cable.
However the minute I connect the cable the MMI disconnects and greys out the Bluetooth.
I suspect there may be a setting to stop that happening. (Maybe)

I can go into the app on the phone and it asks me to connect to Bluetooth which I do but alas nadda.

Frustratingly close I am sure , as I am sure if I had an iPhone it would connect wirelessly.

Maybe some more searching.


Sent from my SM-G998B using Tapatalk

I assuming android auto is working over cable. ?


Sent from my iPad using Tapatalk
 

harvsurrey

New Member
I assuming android auto is working over cable. ?


Sent from my iPad using Tapatalk
Yes all works fine .

If I remember I banged my head against the wall when I first set up dual phone and then next day it worked.

Time to walk away and go into my pain cave to train for an hour , frustration levels high

Sent from my SM-G998B using Tapatalk
 

Evgeny Knafel

New Member
Ok, my adventure continues. Two things happened meanwhile: I received the OBD11 module and my car went for a service and the mmi software was update to 3281.
Now I can't see the 5ghz wifi again... Tried playing with all the settings in 75 and 5f (now I can access it) bit the new wifi doesn't show up....
Any ideas?
 

Attachments

  • Screenshot_20210201-175413.jpg
    Screenshot_20210201-175413.jpg
    744.5 KB · Views: 68
  • Screenshot_20210201-175143.jpg
    Screenshot_20210201-175143.jpg
    699.5 KB · Views: 65
  • Screenshot_20210201-175129.jpg
    Screenshot_20210201-175129.jpg
    710.3 KB · Views: 72

thorpemark1

Registered User
75 module can take a while to update settings, , I think it needs to fully power down ..
There is an option to Soft, reset the module which is like letting the car power off and go to sleep. Or you can just lock the car and wait a while.

This is from the OBDeleven site :
"Reset function is used to reset control unit, it will send reset command after you press OK button.
Ignition off/on reset is same as switch ignition off remove the key and switch it on.
Hard reset is same as disconnect power from control unit.
Soft reset is same as switch ignition off and wait until car goes to sleep."

There is also a setting somewhere that's says same name for 2.5 and 5ghz networks, if that's set to yes, you won't see 2 different networks , both the 2.5 and 5 will use the same name ...

Heres some feedback from another forum where I posted my steps, It does seem the 75 module needs some time to power cycle/ shutdown/restart before it takes the settings.. I'd tried various things over a few days to get it working initially, so I never noticed this, as it may have already done it from a previous attempt..

"As far as the coding, I followed Thorpey’s instruction in this thread exactly. I didn’t try any other parameters or change anything else except the things that he had outlined for both modules. Everything worked perfectly, and I ended up with two visible SSIDs: MyNetwork and MyNetwork_5Ghz. I didn’t add the 5Ghz part, it just appeared after I did the coding. One thing you need to know is that, after your reboot the MMI, you will need to walk away for a while and leave the car alone before trying to do any wireless CarPlay pairing. You will see a brief message flash telling you that the wifi settings need to be configured for your country. This appears to be related to the turning on of the 5Ghz radio. When you come back, everything should be working as expected"
 

Evgeny Knafel

New Member
I did wait for a few days now :)
The message about reconfiguiring the wifi appears every time I turn off and back on the wifi in mmi settings. Maybe after the firmware update they added something to the firmware that block 5ghz in specific countries....
 

harvsurrey

New Member
I had a breif look again yesterday and still no joy.
Whilst I am fairly sure if I leave the carplay settings checked that works but Android auto not so.
I should stick the carplay checks back in as well as AA and see if that helps .

I can't see anything else that would affect AA over and above CP

Sent from my SM-G998B using Tapatalk
 

thorpemark1

Registered User
I did wait for a few days now :)
The message about reconfiguiring the wifi appears every time I turn off and back on the wifi in mmi settings. Maybe after the firmware update they added something to the firmware that block 5ghz in specific countries....

What country are you in ? I'm on Firmware 3281 and it works..
in module 75 my settings show the same as yours except my channel number for 5Ghz is 149 .
Have you set the smartphone configuration in Module 75 ? I don't see that in your pictures.
 

Evgeny Knafel

New Member
Yes, car play and android is enabled. But I'm one step before that, can't see 5ghz. Although I did see it before (probably before the upgrade)
 

Attachments

  • Screenshot_20210201-192926.jpg
    Screenshot_20210201-192926.jpg
    516.4 KB · Views: 64
  • Screenshot_20210201-193501.jpg
    Screenshot_20210201-193501.jpg
    463 KB · Views: 68
  • IMG_20210201_193632.jpg
    IMG_20210201_193632.jpg
    819.6 KB · Views: 71

thorpemark1

Registered User
Yes, car play and android is enabled. But I'm one step before that, can't see 5ghz. Although I did see it before (probably before the upgrade)

I would change your 5ghz channel back to the default 149 , which is licensed for outdoor use, in BAND C , with higher output power (up to 4000mW , and for point to point links .
You are on channel 40 at the moment , which is for indoor use only , and lower output power .

@harvsurrey would also suggest using the default channel 149 if you changed to 40
 

Evgeny Knafel

New Member
The problem is that my phone (oneplus 7pto) doesn't work with 149. I learned it the last time I tried and got 5ghz working with channel 40
 

thorpemark1

Registered User
The problem is that my phone (oneplus 7pto) doesn't work with 149. I learned it the last time I tried and got 5ghz working with channel 40

Don’t know about android phones really. The google specs say you need to be on android 11.

A quick search shows someone on Reddit saying this about the one plus.

On the phone, I launched the Android Auto app-->hamburger menu-->settings-->version tap this 10 times, then got a new option "Wireless projection".


Sent from my iPad using Tapatalk
 

harvsurrey

New Member
I will try again this weekend .
I definitely have Android 11 and a brand new s21 ultra.

Will set things back up with android and carplay checked.

I could see the 5ghz network at the weekend but think there are some quirks on Android Auto first setup

Sent from my SM-G998B using Tapatalk
 

thorpemark1

Registered User
I will try again this weekend .
I definitely have Android 11 and a brand new s21 ultra.

Will set things back up with android and carplay checked.

I could see the 5ghz network at the weekend but think there are some quirks on Android Auto first setup

Sent from my SM-G998B using Tapatalk

I'm talking from a iPhone point of view here but the same is true for android I believe , make sure you have deleted any bluetooth connections to the car on both the mmi and the phone .

You may see the 5ghz network but do not connect to it , the initiation needs to be done by bluetooth . Repair your phone to the MMI via bluetooth and it should give the option of using android auto wirelessly , or using the MMI , select wirelessly .
The bluetooth connection will instruct the phone to connect to the wireless network .

I have access to a Samsung A40 , I'm not sure if it supports wireless android auto , but if I can get hold of it I will try and test ..
 

GenerationGav

Registered User
Appreciate everybody trying to get this running natively, but there's a product coming out which will allow you to retrofit Android Auto Wireless into your car; here
Yes it's indiegogo, but the units are starting to be shipped and the guy who's made this also made a software version which I've tested, so absolutely to be trusted.
 

Vertigo1

Registered User
So just to update on this topic. I picked up my MY2021 A5 SB today (built in W37) and it does have wireless carplay! Worked right away with no issues.

I presume you don't have the Phone Box wireless charger so does that mean that's not required for wireless Carplay?

Is the Phone Box only available on the Vorsprung now? Can't see it as an option on any other model.
 

SaceDK

Registered User
I presume you don't have the Phone Box wireless charger so does that mean that's not required for wireless Carplay?

Is the Phone Box only available on the Vorsprung now? Can't see it as an option on any other model.
Sorry I have missed answering this one. My car is DK spec and that includes "Phone Box Light" - So I do have the wireless charger.
 
Top