Wireless CarPlay

Aaron Wiles

Registered User
Considering buying the Carplay2air adapter as they confirmed it will work with my Pioneer CarPlay headunit.
 

Attachments

  • 46316310-1BE3-4938-9532-FF28A0E18E3A.jpeg
    46316310-1BE3-4938-9532-FF28A0E18E3A.jpeg
    437.8 KB · Views: 275

D.C. Christopher

Registered User
https://www.slashgear.com/audi-mib-3-infotainment-system-my2021-cars-whats-new-11620100/

This article supports what I believe is the case with 2020 A4/S4 models. Long story short, the new update didn't make much of a difference. What may eventually make a difference is upgrading to the highest subscription (Connect Plus?). That will "unlock" 5G WiFi which is what's needed to power wireless CarPlay. A bit sheisty but perhaps worth the wait. I'm anyway going to keep carrying Audi Connect services, might as well see if that gives me "native" Wireless CarPlay.
 

leedodds1

Registered User
It’s a shame it doesn’t work out the box. I’ll be taking delivery of my S4 2020 this week and was really looking forward to using wireless carplay as my current B9 A4 is cabled.
 

Aaron Wiles

Registered User
Bought this adaptor from Audi-Retrofits, set up was easy and working perfectly :smirk:
 

Attachments

  • 090B89FD-EFB9-4637-9D30-5F297F96F6E5.jpeg
    090B89FD-EFB9-4637-9D30-5F297F96F6E5.jpeg
    465.9 KB · Views: 241
  • 5F00B7F8-CDA5-45DC-969D-397441933F96.jpeg
    5F00B7F8-CDA5-45DC-969D-397441933F96.jpeg
    370.8 KB · Views: 235

SaceDK

Registered User
According to the German online configurator wireless carplay should be supported from MY2021. My dealer also told the same but will have to wait until I get the car to confirm that it’s actually the case.
 

leedodds1

Registered User
According to the German online configurator wireless carplay should be supported from MY2021. My dealer also told the same but will have to wait until I get the car to confirm that it’s actually the case.

I tried and couldn't get it working. I followed a tutorial from a A6 and wasn't prompted for the wireless option.
 

SaceDK

Registered User
That will explain it then, it's fine plugging in on long drives but it would be great for those short trips as CarPlay loaded 200x quicker than in my 2017 A4.

What do you have on order?

I haven't used it in a few years but I think I'll give it a try when I get this car.

It's an A5 SB I have on order but the changes apply to both A4 and A5 (at least for the Danish market).
 

D.C. Christopher

Registered User
Problem solved! Traded in the 2020 S4 for a 2019 e-tron, even if it means “****” in French!

Check out a 2019 or 2020 Q7, Q8, e-tron, etc. You will quickly find out that the MIB3 screen found in the S4 is actually a step down from the MIB2+ screen in the 2019s. The latter is faster, more technologically advanced, etc. I doubt the S4 will ever get much attention (Wireless CarPlay, etc.). The whole situation is a joke. I got lucky and found a replacement vehicle that checked all the boxes and thanks to its unsellability didn’t cost me much more than I already paid for the S4. Imagine getting a $85K car for $60K. Some people think the e-tron is not worth it but I bet they’ve never driven one. That car is LOADED and drives amazingly well. The only downside is the range but I’d rather have one problem to deal with than several.
 

thorpemark1

Registered User
After a lot of playing around I have just activated Wireless Carplay in my MY20 a4 , I tried following guides for the A6 / A7 which did not work. The options are slightly different to make the MIB3 work , I'll update fully when I work out which options were required, and test a bit more but for now it seems to be working great .
 

thorpemark1

Registered User
OK , after a few week of trying different things , here's what works on my 2020 A4 , use at your own risk :S

This is what I did ,( with weeks in between ).
Initially made adaptations to module 5F - (Having found out what I have today , I'm not even sure these need to be made , these were things quoted for previous models of Audi (Non MIB3 ) A3 / A7 / A6 , and some of the settings in the other modules contradict values in this module, so not even sure it is doing any thing with these values )
I think this should work with A4/S4 , A5/S5 MIB3 models.
Before doing this delete the phone pairing in bluetooth and CarPlay in Audi interface (long hold and delete ) , I also removed the car from my phone bluetooth (again maybe not necessary)
Make sure your bonnet / Hood is up/open for changes to take effect .

MODULE 5F

---------------------------------------------------------------
Adaptation
Control unit: 5F Multimedia
Name: WLAN settings
Values:
5_ghz_wlan:
Old value: Off
New value: On
Mileage: 1691 km
Date: 2020-07-23 16:55

---------------------------------------------------------------
Adaptation
Control unit: 5F Multimedia
Name: Smartphone configuration
Values:
Apple_car_play_wireless:
Old value: Off
New value: On
Mileage: 1691 km
Date: 2020-07-23 16:56

---------------------------------------------------------------
Adaptation
Control unit: 5F Multimedia
Name: function_configuration_connectivity
Values:
Mirror_link:
Old value: Off
New value: On
Mileage: 1691 km
Date: 2020-07-23 16:59

---------------------------------------------------------------
Adaptation
Control unit: 5F Multimedia
Name: function_configuration_connectivity
Values:
WIFI_Hotspot_5GHz:
Old value: Off
New value: On
Mileage: 1705 km
Date: 2020-07-24 17:01

---------------------------------------------------------------

The following are new changes I found today , after scanning though all the available adaptations , these seem to have made the difference , and I now see the 5ghz network and wireless car play is working (seems too simple) .

MODULE 75 Telematics

Adaptation

Control unit: 75 Telematics
Name: Emergency call module and communication unit, configuration
Values:
WLAN 5GHz:
Old value: Off
New value: On
Mileage: 1965 km
Date: 2020-08-14 14:54

---------------------------------------------------------------
Adaptation
Control unit: 75 Telematics
Name: Smartphone configuration
Values:
Apple CarPlay Wireless:
Old value: Off
New value: On
Mileage: 1965 km
Date: 2020-08-14 14:53

---------------------------------------------------------------

Now reboot the MMI , (Long hold on volume / power button , until the mmi starts up again )
Connect to the (hopefully) new SSID network / Hotspot YOURCAR_5ghz (enable hotspot in connection manager/wifi to see this)
Pair phone through Audi Smart phone interface bluetooth , it should as if you was to use Carplay

Let me know how it goes ..
 

Frankiejr26

A4 40 TFSI BE ordered 29th June
Awesome! So if the MY2021 doesn’t get wireless CarPlay as standard then we should be able to follow the above to enable it. I am really looking forward to trying this out! Do you have any photos of it working?
 

thorpemark1

Registered User
Awesome! So if the MY2021 doesn’t get wireless CarPlay as standard then we should be able to follow the above to enable it. I am really looking forward to trying this out! Do you have any photos of it working?

Here you go (if the video works, Pictures wouldn't really show it )

(I had to cut out a part where I skip to Apple Dashboard menu as it shows my exact location , which id rather not share :) )

 

Frankiejr26

A4 40 TFSI BE ordered 29th June
Here you go (if the video works, Pictures wouldn't really show it )

(I had to cut out a part where I skip to Apple Dashboard menu as it shows my exact location , which id rather not share :) )


Great work, you know in iOS 14 you no longer have to have the app open on the phone to display on the screen.

Edit: I just noticed it is touch screen, does this mean it is a MY2021 as I thought you had to use a dial in MY2020??
 

thorpemark1

Registered User
Great work, you know in iOS 14 you no longer have to have the app open on the phone to display on the screen.

Edit: I just noticed it is touch screen, does this mean it is a MY2021 as I thought you had to use a dial in MY2020??

you don't have to have the app open in iOS13 , I was just trying to display it was wireless, otherwise I could have had a phone plugged in behind the scenes lol .

You can also display google maps on the Apple Car Play dashboard now (which used to be Apple maps only) , Think Google updated there app this week for that ,

Its a MY2020 but yes its the MIB3 touchscreen
 

Frankiejr26

A4 40 TFSI BE ordered 29th June
you don't have to have the app open in iOS13 , I was just trying to display it was wireless, otherwise I could have had a phone plugged in behind the scenes lol .

You can also display google maps on the Apple Car Play dashboard now (which used to be Apple maps only) , Think Google updated there app this week for that ,

Its a MY2020 but yes its the MIB3 touchscreen

Ah yes you are right that came with 13 not 14.


Sent from my iPad using Tapatalk
 

Frankiejr26

A4 40 TFSI BE ordered 29th June
[mention]thorpemark1 [/mention] So how are you finding wireless CarPlay now you have had it a few days?

And is your 2020 classed as the facelift version?


Sent from my iPad using Tapatalk
 

thorpemark1

Registered User
It’s great. No glitches or anything. Even fashioned a cheap concealed wireless charger under the centre console mat. With an old charger I had. Lol
9c64b1d2fea538a5196d401e767ecbf5.jpg


bea63742101f5668d8cc997c387882b1.jpg


b1c104e99b53a436c2d0a0fe8cd083de.jpg
 

Frankiejr26

A4 40 TFSI BE ordered 29th June
It’s great. No glitches or anything. Even fashioned a cheap concealed wireless charger under the centre console mat. With an old charger I had. Lol
9c64b1d2fea538a5196d401e767ecbf5.jpg


bea63742101f5668d8cc997c387882b1.jpg


b1c104e99b53a436c2d0a0fe8cd083de.jpg

Nice. Though I assumed wireless charging was standard on the facelift models! Do you have to spec it separately?


Sent from my iPhone using Tapatalk
 

Frankiejr26

A4 40 TFSI BE ordered 29th June
From what I can see you need the Audi phone box but that is only mentioned as standard in the vorsprung model and doesn’t show up as an optional extra for any other models.


Sent from my iPhone using Tapatalk
 

thorpemark1

Registered User
Mines a BE with comfort and sound , doesn’t come or didn’t come with the wireless Audi phone box. And it’s pretty expensive to retrofit just for wireless charging. (I’m not sure it even gives you additional antenna anymore )
 

Frankiejr26

A4 40 TFSI BE ordered 29th June
Mines a BE with comfort and sound , doesn’t come or didn’t come with the wireless Audi phone box. And it’s pretty expensive to retrofit just for wireless charging. (I’m not sure it even gives you additional antenna anymore )

Yeah my order is the same so will likely go down the same route as you and build something.


Sent from my iPhone using Tapatalk
 

SaceDK

Registered User
So just to update on this topic. I picked up my MY2021 A5 SB today (built in W37) and it does have wireless carplay! Worked right away with no issues.
 

Frankiejr26

A4 40 TFSI BE ordered 29th June
So just to update on this topic. I picked up my MY2021 A5 SB today (built in W37) and it does have wireless carplay! Worked right away with no issues.

Awesome Hopefully that is the same for A4 then


Sent from my iPad using Tapatalk
 

harvey.nott

Registered User
Question for wireless CarPlay and Android auto.
Does it still disable the bluetooth to the phone ?
The reason I ask is when I use wired android auto I lose my 2 phones connected to bluetooth which is a real pain.

Sent from my SM-G950F using Tapatalk
 

Evgeny Knafel

New Member
OK , after a few week of trying different things , here's what works on my 2020 A4 , use at your own risk :S

This is what I did ,( with weeks in between ).
Initially made adaptations to module 5F - (Having found out what I have today , I'm not even sure these need to be made , these were things quoted for previous models of Audi (Non MIB3 ) A3 / A7 / A6 , and some of the settings in the other modules contradict values in this module, so not even sure it is doing any thing with these values )
I think this should work with A4/S4 , A5/S5 MIB3 models.
Before doing this delete the phone pairing in bluetooth and CarPlay in Audi interface (long hold and delete ) , I also removed the car from my phone bluetooth (again maybe not necessary)
Make sure your bonnet / Hood is up/open for changes to take effect .

MODULE 5F

---------------------------------------------------------------
Adaptation
Control unit: 5F Multimedia
Name: WLAN settings
Values:
5_ghz_wlan:
Old value: Off
New value: On
Mileage: 1691 km
Date: 2020-07-23 16:55

---------------------------------------------------------------
Adaptation
Control unit: 5F Multimedia
Name: Smartphone configuration
Values:
Apple_car_play_wireless:
Old value: Off
New value: On
Mileage: 1691 km
Date: 2020-07-23 16:56

---------------------------------------------------------------
Adaptation
Control unit: 5F Multimedia
Name: function_configuration_connectivity
Values:
Mirror_link:
Old value: Off
New value: On
Mileage: 1691 km
Date: 2020-07-23 16:59

---------------------------------------------------------------
Adaptation
Control unit: 5F Multimedia
Name: function_configuration_connectivity
Values:
WIFI_Hotspot_5GHz:
Old value: Off
New value: On
Mileage: 1705 km
Date: 2020-07-24 17:01

---------------------------------------------------------------

The following are new changes I found today , after scanning though all the available adaptations , these seem to have made the difference , and I now see the 5ghz network and wireless car play is working (seems too simple) .

MODULE 75 Telematics

Adaptation

Control unit: 75 Telematics
Name: Emergency call module and communication unit, configuration
Values:
WLAN 5GHz:
Old value: Off
New value: On
Mileage: 1965 km
Date: 2020-08-14 14:54

---------------------------------------------------------------
Adaptation
Control unit: 75 Telematics
Name: Smartphone configuration
Values:
Apple CarPlay Wireless:
Old value: Off
New value: On
Mileage: 1965 km
Date: 2020-08-14 14:53

---------------------------------------------------------------

Now reboot the MMI , (Long hold on volume / power button , until the mmi starts up again )
Connect to the (hopefully) new SSID network / Hotspot YOURCAR_5ghz (enable hotspot in connection manager/wifi to see this)
Pair phone through Audi Smart phone interface bluetooth , it should as if you was to use Carplay

Let me know how it goes ..
I got a 2020 a4. Connected with vcds and changed the settings in 75 module (including enabling android auto wireless). Couldn't open adaptetion for 5f module as I don't have a security access code. Nothjng changed... Still see only 2.4 ghz wifi.
 

D.C. Christopher

Registered User
I got a 2020 a4. Connected with vcds and changed the settings in 75 module (including enabling android auto wireless). Couldn't open adaptetion for 5f module as I don't have a security access code. Nothjng changed... Still see only 2.4 ghz wifi.

You're almost there, Evgeny, don't lose faith! There is a default security access code you can enter and if that doesn't work you can calculate a "valid one" by entering some data from your car (like VIN, etc.). Just search online, you'll find what you need.
 

Evgeny Knafel

New Member
Ok, switched the 5 ghz channel to 40 (guess 149 is blocked on my phone) and now I see the 5ghz wifi. But android auto still demands usb cable. Will try with an iphone later.
Meanwhile, I found 5f code (20103) it claims to accept it but "adaptaion" menu is still greyed out...
 

thorpemark1

Registered User
I got a 2020 a4. Connected with vcds and changed the settings in 75 module (including enabling android auto wireless). Couldn't open adaptetion for 5f module as I don't have a security access code. Nothjng changed... Still see only 2.4 ghz wifi.

I used ODBEleven , it automatically enters the security code.
There is a setting for 5ghz SSID to be visible or not visible I recall. It does not have to be visible , It first negotiates by bluetooth, and then connects to the 5ghz network automatically , to initiate CarPlay wireless.
Make sure the bonnet is up when making changes , and make sure the MMI is rebooted following (some others have found they needed to leave the car a few hours before the change seemed to take effect, this perhaps relates to module 75)
 

thorpemark1

Registered User
Ok, switched the 5 ghz channel to 40 (guess 149 is blocked on my phone) and now I see the 5ghz wifi. But android auto still demands usb cable. Will try with an iphone later.
Meanwhile, I found 5f code (20103) it claims to accept it but "adaptaion" menu is still greyed out...

I also found this relating to 149 when researching how to get this working (its not a regular home use channel) .. Channel 149 does work for me .

"Band C (Channels 149 – 161)

If the 1000mW output power limit that Band B offers isn’t enough to suit your needs, then have no fear – Band C is here! Band C can be used with output powers of up to 4000mW (4W). There are some conditions however:

a) Band C can only be used for outdoor wireless
b) Band C can only be used for fixed wireless access (FWA) points (e.g point to point or point to multipoint links)
c) A light license is required for operation and must be purchased from Ofcom.
d) All hardware must conform to DFS (Dynamic Frequency Selection) standards and DFS must be enabled

Band C is 125MHz wide and allows for 4 x 20MHz channels to coincide without overlap or 2 x 40MHz channels."
 

thorpemark1

Registered User
I'll admit I have never tried Android Auto, Only have have iPhones , and the android I have isn't compatible. (or wasn't when I first did this, looks like they have expanded the list )
Do you have one of compatible android phones ?

  • Any smartphone with Android 11.0 and 5 GHz Wi-Fi. In the EU, smartphones must comply with additional regulatory requirements in order to use 5 GHz Wi-Fi in the car.
    • A Google or Samsung smartphone with Android 10.0.
    • A Samsung Galaxy S8, Galaxy S8+ or Note 8, with Android 9.0.
 

D.C. Christopher

Registered User
Ok, switched the 5 ghz channel to 40 (guess 149 is blocked on my phone) and now I see the 5ghz wifi. But android auto still demands usb cable. Will try with an iphone later.
Meanwhile, I found 5f code (20103) it claims to accept it but "adaptaion" menu is still greyed out...

20103 is allegedly correct for both 5F and 75. Just as thorpemark1 stated, some sources state that the hood has to be kept open (sounds dumb to me but, desperate times!). Don't worry about changing the channel, I believe 149 is an "outdoor" channel. The module 75 adaptations are what I was missing. I was getting the same MMI message as you "Please connect via WiFi or cable" even though I was connected via WiFi (but not 5GHz).

Good luck, man, you're almost there. Worst case scenario, just invest in an OBDEleven. If you have VCDS though, you really shouldn't have to.
 

D.C. Christopher

Registered User
Ok, switched the 5 ghz channel to 40 (guess 149 is blocked on my phone) and now I see the 5ghz wifi. But android auto still demands usb cable. Will try with an iphone later.
Meanwhile, I found 5f code (20103) it claims to accept it but "adaptaion" menu is still greyed out...

Wait, which phone and operating system do you have? Previously, only Google phones supported Wireless Android Auto. I believe as of Android 11 it's extended to all phones, but ... does your phone have Android 11? :sweatsmile:
 
Top