Wipers really annoying me now!

doublem_1

Registered User
I must be the only person with this problem I'm sure, do you think I need a new wiper mechanism?

What happens is when its dry the wipers are fine and stay more or less flat at the bottom of the screen, albeit pointing up a little high being anal about it.

But when its raining, on intermittent, they stop high up on the screen (i.e. above the black strip) and if i'm on the motorway doing 70mph it's even worse!! Literally half way up the screen, so much so that the intermittent wipe doesn't work, they just carry on on another cycle. It's embarrassing to say the least/
 

1animal1

The Clar!! it mouves!!!
not sure if its the same but my misus A3 mechanism was crimped , i took the C clip off and had no luck, gave to my mate whos a mechanic and he couldnt do it either - was an ebay jobby for £35 IIRC
 

a3tdi2001

Registered User
Aha, maybe the crimp was the reason I broke the spindle trying to "persuade" it to come out:) I bought a new one from Audi for around £35 + VAT I think it was last year.
 

Mpathe

1st gear
I managed to grease the mechanism up and works like new now tho mine were just working slow all the time.
 

doublem_1

Registered User
They arent slow. Does anyones elses wipers do this: on their downward travel they go past the black the strip and then back upwards slightly?
 
aero wipers :) think my old ones used to lift at high speeds but that was 6 years ago so lost in the mists of time and beer lol
 

Reesy

Well-Known Member
VCDS Map User
They arent slow. Does anyones elses wipers do this: on their downward travel they go past the black the strip and then back upwards slightly?

Had this on my old corsa, got the linkages changed and about 2 weeks after that, they finally started returning to the right place.
 
Top