Whistling like a kettle after CAI

TomSx

Registered User
Right, fitted my CAI and between 3-5k I get an annoying whistle like a kettle. Now I've put a full new set of jubilee's on it, double checked everything which I can only think leaves the maf? It sits in tight and I've also put some silicone around the outside, but still i'm getting the noise! Any ideas? lol
 

Jet2004uk

Registered User
I have the same issue with my Revo CAI, could be just one of them little anoying things you have to live with lol
 

Jet2004uk

Registered User
Yes very lol mine only does it when I boot it, its getting to the point where it is making me drive like Miss Daisy...OMG did I just say that :keule:
 

TomSx

Registered User
Same here. It also seems to only be between 3-5k when it's at it worst but then that' peak boooooooooost.
 

Jet2004uk

Registered User
I am hoping its normal, I dont seem to be suffering from any performance issues, you?
 

Mat1987

Registered User
I had this with my APR Carbonio but dont seem to get it with the Unitronic, just more of a whoosh then a whistle
 

TomSx

Registered User
I am hoping its normal, I dont seem to be suffering from any performance issues, you?

It's certainly going better than without it. I just really don't know where it could be coming from. Anyone know if you can buy the rubber maf seal? I really don't know how it could be leaking with the amount of silicone I've plastered on there though.

I had this with my APR Carbonio but dont seem to get it with the Unitronic, just more of a whoosh then a whistle

You're not getting the same as us then. I get plenty of whoosh, just a whistle too..lol
 

Jet2004uk

Registered User
I have no idea what part mine is whistling from, if you find it let me know lol
 

TomSx

Registered User
I have no idea what part mine is whistling from, if you find it let me know lol

I took the whole thing off yesterday, fitted everything again (with new jubilee's) taking as much time as possible. It's still there..
 

leshkin

Hold my beer...
VCDS Map User
I also have a much noisier intake. Sounds like Darth Vader is hiding under there. Not much whistling though.
 

S3DUST

Just add boost :D
I would say whistling is more likely to be the boost side rather than induction ! As the CAI is not under any boost pressure.

Have you checked you DV ? as i had a slight whistle a while back and it had a slight split in the diagram and i believe this was there before i fitted the Revo CAI but you can just hear it more with those fitted ! Also i take it its not a fluctuating hiss noise ? as this is the N75 valve venting boost and is normal this sound like if you had a small pipe in your hand under pressure and you came off and on the end blocking the flow with your finger...
 

sliced

Drive safe, stay alive.
I have the same issue with my Revo CAI, could be just one of them little anoying things you have to live with lol
your DV might be split :eek: mine was, and managed to get rid of the noise once i changed it
 

Tezgreig

Registered User
Certain cold air induction kits suffer with this problem. There is nothing you can do other than change it for a different cai. Think it is more prominent on kits which have a lot of alloy piping tho. You could potentially replace a section with a longer piece of silicon tubing
 

Cmw9

Registered User
I have this noise too after fitting my evoms CAI. I also have a boost gauge and i don't notice any drop in pressure when i hear the noise if the dv is split.
 

TomSx

Registered User
As above it's 100% not the dv on mine. Just an annoying noise. I have since lift it as little on the turbo end and it's made a huge difference.
 

TomSx

Registered User
I've got he carbonio ram air induction an it whistles too.
get used to it or ditch it.

Yeah I've got used to it now although I did find an old S2000 K&N filter in the cupboard so may fit that and see if it dies down over the foam ramair..lol
 
Top