What have you done to your Audi A4 B7 today?

I'm Just Rob.

Moderating or something,
Staff member
Moderator
VCDS Map User
Gold Supporter
Worse case, if I don't like the finished product it will go in the TT, it won't be wasted.
the gearlever/knob and fbsw only cost me £120 so I'm always going to quids in. :thumbs up:
 

Conneh

Member
CAM Follower :wtf:

ADB07610-0668-43AE-9C72-080DC4373C4E.jpeg
 

Donfero

Registered User
So a very bad week, after the accident and after I replaced all the parts, i ran the car for an hour to make sure there are no leaks. This morning i came to start it, it started shutdown and wouldn't start since. No faults on VCDs scan so i suspect fuel pump. Any good options for a fuel pump? Any ideas what might be the problem? Will the fuel pump show on a VCDs scan, or is there a way to test it?

Sent from my RMX2170 using Tapatalk
 

I'm Just Rob.

Moderating or something,
Staff member
Moderator
VCDS Map User
Gold Supporter
That’s one of the worse I’ve seen to date.
If you got away without any damage to the fuel pump plunger,cylinder head where the follower fits and anywhere else for the matter , you have the luck of the. Gods .
I’d still be doing the relays aswell.
 

Conneh

Member
That’s one of the worse I’ve seen to date.
If you got away without any damage to the fuel pump plunger,cylinder head where the follower fits and anywhere else for the matter , you have the luck of the. Gods .
I’d still be doing the relays aswell.
See my main thread Rob, few more pics and relays done!
 

i3oricua

Registered User
So a very bad week, after the accident and after I replaced all the parts, i ran the car for an hour to make sure there are no leaks. This morning i came to start it, it started shutdown and wouldn't start since. No faults on VCDs scan so i suspect fuel pump. Any good options for a fuel pump? Any ideas what might be the problem? Will the fuel pump show on a VCDs scan, or is there a way to test it?

Sent from my RMX2170 using Tapatalk
Slow down, don't buy parts yet. Does it crank and not start or does it not even crank?

Sent from my KB2005 using Tapatalk
 

i3oricua

Registered User
Cranks but doesn't start.

Sent from my RMX2170 using Tapatalk
Check for the three things an engine must have. Air, fuel, spark. Sounds like one if them is missing. VCDS should tell you if there is a fault with one or many sensors which may lead you to some severed wiring.

Check to see if fuel pump is priming. You should hear an audible pump prime when you open the driver's door.

Sent from my KB2005 using Tapatalk
 

Fully

Registered User
So a very bad week, after the accident and after I replaced all the parts, i ran the car for an hour to make sure there are no leaks. This morning i came to start it, it started shutdown and wouldn't start since. No faults on VCDs scan so i suspect fuel pump. Any good options for a fuel pump? Any ideas what might be the problem? Will the fuel pump show on a VCDs scan, or is there a way to test it?

Sent from my RMX2170 using Tapatalk

I had similar a few months back.
Car would turnover but not fire, but occasionally it would work fine and then randomly cut out and just turnover.
Thought it was the pump under the rear seat but ended up being a relay problem
 

Donfero

Registered User
Check for the three things an engine must have. Air, fuel, spark. Sounds like one if them is missing. VCDS should tell you if there is a fault with one or many sensors which may lead you to some severed wiring.

Check to see if fuel pump is priming. You should hear an audible pump prime when you open the driver's door.

Sent from my KB2005 using Tapatalk
Nothing on VCDs!! No faults.
Tested the fuel line and fuel is coming out when i open the door or start the car, so its not a fuel pump. Dont know what to do next!! Im all out of ideas..

Sent from my RMX2170 using Tapatalk
 

Donfero

Registered User
I had similar a few months back.
Car would turnover but not fire, but occasionally it would work fine and then randomly cut out and just turnover.
Thought it was the pump under the rear seat but ended up being a relay problem
Tested the fuel pump and its fine I guess. Would it still pump fuel if the relay was bad?? Its pumping fuel because I tested the fuel line.

Sent from my RMX2170 using Tapatalk
 

I'm Just Rob.

Moderating or something,
Staff member
Moderator
VCDS Map User
Gold Supporter
Nothing on VCDs!! No faults.
Tested the fuel line and fuel is coming out when i open the door or start the car, so its not a fuel pump. Dont know what to do next!! Im all out of ideas..

Sent from my RMX2170 using Tapatalk
Have you checked fuses and relays are all ok?
possibly an electrical issue.
Has the immobilizer been activated?
 

I'm Just Rob.

Moderating or something,
Staff member
Moderator
VCDS Map User
Gold Supporter
Maybe worth a look , ECU surge fuse (25a) under the ECU in addition to the ECU fuse in the box.
 

Fully

Registered User
Tested the fuel pump and its fine I guess. Would it still pump fuel if the relay was bad?? Its pumping fuel because I tested the fuel line.

Sent from my RMX2170 using Tapatalk
On mine were was no fuel getting to the filter when we checked under the bonnet, hence the pump query.
Garage tested the pump and it was fine when power put through it, that's when we found it was a faulty relay.
 

Donfero

Registered User
Update: Cleaned the spark plugs and coils and it started which indicates something very wrong with the engine. As it started I noticed a crack in the Turbo manifold!!!! How bad is that???

Sent from my RMX2170 using Tapatalk
 

I'm Just Rob.

Moderating or something,
Staff member
Moderator
VCDS Map User
Gold Supporter
Its not a good week chap, it can only get better though.
 

i3oricua

Registered User
Update: Cleaned the spark plugs and coils and it started which indicates something very wrong with the engine. As it started I noticed a crack in the Turbo manifold!!!! How bad is that???

Sent from my RMX2170 using Tapatalk
Ya, that's not good but can be fixed potentially. I would remove it and take it to a shop to see if it can repaired depending on the extent of the damage.

Sent from my KB2005 using Tapatalk
 

i3oricua

Registered User
Update: Cleaned the spark plugs and coils and it started which indicates something very wrong with the engine. As it started I noticed a crack in the Turbo manifold!!!! How bad is that???

Sent from my RMX2170 using Tapatalk
How's it run after you cleaned them up? Besides that air leak from the manifold sure it sound fine?

Sent from my KB2005 using Tapatalk
 

Donfero

Registered User
How's it run after you cleaned them up? Besides that air leak from the manifold sure it sound fine?

Sent from my KB2005 using Tapatalk
Seems to be ok, i haven't took it for a spin but it idles fine i guess. Should I change the Manifold?

Sent from my RMX2170 using Tapatalk
 

i3oricua

Registered User
Seems to be ok, i haven't took it for a spin but it idles fine i guess. Should I change the Manifold?

Sent from my RMX2170 using Tapatalk
If it's truly cracked then there will be an air leak and you will throw codes and get reduced performance and fuel mileage. Take it for a spin, might be fine. It will probably misfire or hesitate and you'll probably get a P0299 code or similar.

Any pics of said crack?

Sent from my KB2005 using Tapatalk
 

Donfero

Registered User
If it's truly cracked then there will be an air leak and you will throw codes and get reduced performance and fuel mileage. Take it for a spin, might be fine. It will probably misfire or hesitate and you'll probably get a P0299 code or similar.

Any pics of said crack?

Sent from my KB2005 using Tapatalk
Thats a bad crack!!
f43577875835bd5110ffa6327e67eeac.jpg


Sent from my RMX2170 using Tapatalk
 

i3oricua

Registered User
Thats a bad crack!!
f43577875835bd5110ffa6327e67eeac.jpg


Sent from my RMX2170 using Tapatalk
That looks weird. As if it's rusted through.

Sent from my KB2005 using Tapatalk
 

AvantAlexB7

Registered User
Its been the first time out for me in my Avant for over a week due to Covid isolation and the first things that immediately struck me where the vibrations from the engine mounts and also the rev hanging issue seems to have snuck up on me again, which is annoying. Going to swap the aftermarket clutch switch i fitted a couple of years back for a genuine item and go from there. Hopefully its just a faulty cheap part at fault.
 

I'm Just Rob.

Moderating or something,
Staff member
Moderator
VCDS Map User
Gold Supporter
Hope your getting over the dreaded bug ok Alex.
That aside, the good thing about not driving these cars , even for a short period is that you soon notice things that are not ideal or that have changed.
Those clutch switch's can vary in quality to be honest, i went with a non oe part but it was a good brand and has been fine for a few years now.
Maybe as soon as you are driving it daily the vibes will become less noticeable again.
 

I'm Just Rob.

Moderating or something,
Staff member
Moderator
VCDS Map User
Gold Supporter
Today i spent all day messing around with my cabin heat issues, or lack of heat to be more accurate.
haven't solved it either, just more irritated by it now than before i started, arghhhhhhhhhhhhhhhh.

One word comes to mind, codfanglers. lol
 

AvantAlexB7

Registered User
Hope your getting over the dreaded bug ok Alex.
That aside, the good thing about not driving these cars , even for a short period is that you soon notice things that are not ideal or that have changed.
Those clutch switch's can vary in quality to be honest, i went with a non oe part but it was a good brand and has been fine for a few years now.
Maybe as soon as you are driving it daily the vibes will become less noticeable again.
All good Rob thankyou.

I purchased my clutch switch from ECP, can't recall the brand but it wasn't expensive. However am i right in thinking there is 2, one in front and behind the pedal? I only swapped the "main" one.

The vibrations are also waiting to be sorted, the mounts are sat with the bilsteins waiting to be fitted still!
 

I'm Just Rob.

Moderating or something,
Staff member
Moderator
VCDS Map User
Gold Supporter
Hopefully collecting my rs4 fbsw silver trim work and gearknob silver parts that have been carbon finish hydro dipped tomorrow.
The chap is really helpful and his work looks brilliant from samples he showed me.
Probably going to get the rear bumper valance done aswell next week.
Just need to wait 2 weeks for the retrimmed wheel to be completed.

happy days.:yahoo:
 
Last edited:

I'm Just Rob.

Moderating or something,
Staff member
Moderator
VCDS Map User
Gold Supporter
Just ordered a new heater matrix as well, just to cover all bases.
 

Bobbytea

Registered User
Decided I need a new thermostat… in this cold weather I’m struggling to get near 60° while on the move.

Seems like it’s not a simple job on these beasties… alternator off jobby. Hmm…

Open to any advice.


Sent from my iPhone using Tapatalk
 

Bradderz_1988

Dont replace it, Upgrade it !!
How did you do this?
Bought a switch from breakers
471FF73E-059F-4EEE-9979-073724A7104F.jpeg

Then removed the dial from this switch, removed my dial added a suitable washer held by a smidge of super glue over the centre shaft to space it from the rotary shaft, then apply 2 blobs of super glue to either side of the dial shaft then put it onto the rotary shaft. Getting the dials off is the tricky part if i did it again id probably do a better job as i broke mine but fixed it with some plastic welding and the spring loaded pins from the breaker switch lol

it works and looks the part which is main thing just no release function so if you wanna remove it its done by the fuse panel access as if the switch release is broken.
 

Bradderz_1988

Dont replace it, Upgrade it !!
Next im doing all the window switches to the B8 ones and also the mirror switch
FEE1D66C-047A-4017-A4D0-A12D6251D54B.jpeg
 

I'm Just Rob.

Moderating or something,
Staff member
Moderator
VCDS Map User
Gold Supporter
Today the new Meyle header tank and cap arrived, revamped fbsw trims arrived too, just waiting on the replacement heater matrix on monday.

piccy of the trims though.

IMG_4313.JPG


make a change from silver, and when fitted with switches etc back on should look ok, well i like it.:thumbs up:
 

I'm Just Rob.

Moderating or something,
Staff member
Moderator
VCDS Map User
Gold Supporter
It will give the old wheel a new lease of life really . :thumbs up:
 

I'm Just Rob.

Moderating or something,
Staff member
Moderator
VCDS Map User
Gold Supporter
Looks great chap, certainly updates the dash area. :thumbs up:
 
Top