Visual ME7 Logger

g60leigh

Registered User
No but does look interesting. Are you using it? Just run off of a vcds cable?


Sent from my iPhone using Tapatalk
 

Chris90

Active Member
VCDS Map User
Not the easiest if using a road to log. Looks similar function to ECU plot.
 

Scullies

Registered User
I always had trouble getting a stable connection. Had to wire direct to the ECU from the OBD plug to facilitate this.

Ive had issues as well, mostly when I turn the key to start the car. Seems like the program looses signal and then stops logging. I would bump start the car to solve this issue :)

When you say wire direct to the ECU, do you mean the K-line? What did you do with the existing K-line that links from the cluster/ecu, did you cut that wire?
 

Broken Byzan

Photographic Moderator
Staff member
Moderator
VCDS Map User
I just removed the pin from the socket and ran one direct to the Kline at the ECU, then used a changeover switch to allow me to switch it back
 

IPG

Registered User
No need to get fancy with removing pins. Just need to get fancy with software.

I've had issues since day one until I let someone borrow my VCDS cable and he figured it out.

Setup me7visual logger as normal (edit the file marking which parameters you want)

Setup your cable and relevant drivers (put VCDS cable into dumb mode if using the genuine one)

Download Nefmoto

Now this is where the stupid bit comes in. Dunno why it's like this but it works.

Turn ignition on. Not starting engine.

Open Nefmoto. Connect at 38xxx baud rate (one of the lower ones)

Disconnect Nefmoto and MINIMIZE the window.

Open me7visual logger. Connect.
The prompt with "press C^ to stop" with the dots saying it's running should now be on screen.

Crank the engine and it SHOULD NOT want crack the shits and disconnect and you can crack on with logging all parameters at super high resolution no worries.

I like to do Back to back runs and filter them out in ecuxplot To view each one.

Lemme know how you go. Love me7logger vs VCDS for logging
 

jimmcgee

Registered User
you guys better watch out the VCD mafie dont kick your door in and smash up yer laptops for using free software that runs rings round anything else that logs ME7 :busted cop::rockwoot::racer:
 

Scullies

Registered User
Now this is where the stupid bit comes in. Dunno why it's like this but it works.

Turn ignition on. Not starting engine.

Open Nefmoto. Connect at 38xxx baud rate (one of the lower ones)

Disconnect Nefmoto and MINIMIZE the window.

Open me7visual logger. Connect.
The prompt with "press C^ to stop" with the dots saying it's running should now be on screen.

Crank the engine and it SHOULD NOT want crack the shits and disconnect and you can crack on with logging all parameters at super high resolution no worries.

I like to do Back to back runs and filter them out in ecuxplot To view each one.

Lemme know how you go. Love me7logger vs VCDS for logging

That procedure doesn't work for me, I am convinced there is something dodgy with the wiring harness in my car.
When I start the car and begin to drive off, I can hear a relay click. This was causing my multimaps to switch maps each time I started and drove off. Was very annoying but Bill sorted that out by raising the required throttle % to change maps.

So I have gone down the route of the direct K-line, OBD straight to the ECU.
Now I can use the Visual logger and it will connect once the engine is running.
 

Stuart B

Registered User
It's got to be good for a laugh - maybe try and sort out this comms problem with these 8L's by stepping through the handshake code - as you have said it still works but you needed to change the comm port attributes to something basic first - then use another tool which probably changes them to the correct settings for this program?
it's been years since I actually tried talking to other devices, I don't even think USB existed in those days.
 

IPG

Registered User
I Just discovered that you can do this by changing a value in the .ecu file that you need to make. So it tries several settings. You can hear the cluster attempt the connection a couple of times before it works.

Just finding that information was a little convoluted and then applying it took a couple of tries
 

Stuart B

Registered User
with comm port handshakes both sides usually "retrain" to find a common handshake speed - well at least it did with modems in the olden days that was the noise you used to hear starting from the top speed and lowering until a handshake is achieved.

it might be something like this, but also some interfaces need the check bit etc and if I remember rightly some cables and ports had an extra wire for full-duplex (I think) so traffic could go both ways concurrently.

I will probably fail but it is only - for fun ;-)
 
  • Like
Reactions: IPG

Shoomakan

Grand Nagus
  • Like
Reactions: IPG

Stuart B

Registered User
I have to use internet explorer in spite of my kids demands. I actually use edge for some sites. If the browser is slow I just buy a new laptop ;) and using google chrome means that every device in my house see's my internet history so that leaves Firefox. But I am not still in the 90s wanting to load images from the bottom up.
On my phone I use 'frost"
 

2stroke

Registered User
I have two AUDI's with Bosch ME 7.5

Can someone explain what OBD2 cable I should buy and were to download this ME7 Logger program ?
 

desertstorm

Moderator
Staff member
Moderator
VCDS Map User
Hi welcome to the site, are you the same 2stroke as on UKP?. I used the same VCDS lead that I used on my B5.5 Passat. I never got the visual ME7 logger working but used the original ME7 logger on my TT and that worked well. All the stuff you need to know is on the NefMoto site. It's a bit fiddly and took me some time to get it working but you can log serious amounts of measurements compared to VCDS.
http://nefariousmotorsports.com/forum/index.php?topic=837.0
You have to login to the site to see the downloads.
upload_2019-7-2_14-21-49.png
 
Top