1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Vibration/Rattle from MMI Screen?

Wild Bob Oct 23, 2018

  1. Wild Bob

    Wild Bob New Member

    4
    2
    3
    Hi,
    Anyone had any experience of a creaking/vibration from the MMI screen on the dash? Happens usually at speed and going over bumps in the road - It sounds like the MMI screen assembly is making the noise as if I hold it when purposefully going over bumps/cats eyes to replicate it seems to stop....

    Had a good look for similar on here and found nothing....annoying as it's not 100% persistent - just seems to be certain speed/road condition that causes it...

    Anyone seen anything similar??

    WB
     
    Hambee1234 likes this.
  2. Avatar

    Google AdSense Advertisement


  3. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    9,432
    3,424
    113
    None at all on mine, sorry...
     
  4. Hambee1234

    Hambee1234 Active Member

    109
    48
    28
    My car does suffer from this.
    I have just resorted to making sure that the radio is just that little bit louder.
    I am waiting on a new car coming soon (WLTP Fiasco) so just living with it for now tbh.
     
  5. Simonwhite2000

    Simonwhite2000 2017 S5 Coupe Daytona Grey

    301
    148
    43
    Mine does it - turns out its not the screen is the band of aluminium trim below it. If I place my thumb against the trim just under or above the air con screen it stops.
     
  6. A4A4

    A4A4 Well-Known Member

    662
    1,138
    93
    Had a similar creaking sound on mine around the MMI.

    Cost pennies and took minutes to fix.

    I just put 2 small felt sticky back pads underneath the dash in the areas the creaking is coming from.

    No more creaks for years now.
     
  7. Wild Bob

    Wild Bob New Member

    4
    2
    3
    Sounds sensible - I presume pads between the MMI and trim would probably sort it....I may have a tinker...
     
  8. Addict

    Addict Well-Known Member

    298
    406
    63
    I had a similar problem on my B9 RS4. When the engine hit 2000 revs it rattles / buzzed. Took ages to sort it as they kept thinking they had fixed it so it was back and forth 3-4 times. Not sure what they did eventually but maybe something was unclipped somewhere.

    Strangely enough though I noticed only today it’s something similar again. But this time it sounds like an actually speaker rattle at certain tones / pitch levels when playing music. Not what you should expect from a B&O speaker!


    Sent from my iPhone using Tapatalk
     
  9. Simonwhite2000

    Simonwhite2000 2017 S5 Coupe Daytona Grey

    301
    148
    43
    My central BnO speaker vibrates without any music playing and the passenger door one resonates very easily. Very poor quality fittings. The merc and bmw have a metal style grille and doesn’t seem to have the same problems. When mine goes in for the oil change next month I’m getting these things looked at.
     
  10. Wild Bob

    Wild Bob New Member

    4
    2
    3
    A4A4 - sounds like you fixed a reasonably common issue - any photo available of where you placed the pads? I can't find a gap big enough :)
     
    Simonwhite2000 likes this.
  11. Filipão

    Filipão Active Member Audi S4

    106
    58
    28
    No pics, no fix... ;-)
     
  12. Avatar

    Google AdSense Advertisement


  13. A4A4

    A4A4 Well-Known Member

    662
    1,138
    93
    I just lifted up (slightly) the plastic trim away where the noise was coming from using plastic trim removal tool.

    Then placed two felt pads underneath

    But your creaking maybe coming from a different area and mine is a B8.5 model.
     
  14. A4A4

    A4A4 Well-Known Member

    662
    1,138
    93
    This worked for me.

    IMG_20181101_084450.jpg
     
  15. Filipão

    Filipão Active Member Audi S4

    106
    58
    28
    @A4A4 Thanks so much!
     
  16. Wild Bob

    Wild Bob New Member

    4
    2
    3
    Yes - thanks - little different on B9 but wonder if same issue - may have a root around :)
     
  17. Alexandru Pana

    Alexandru Pana New Member

    2
    0
    1
    Same Here. i was at dealer officials and they cannot find the source. Is something around MMI screen.
     

Share This Page