1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice
  3. Maintenance work on Tuesday 7th April

    Due to some much needed work to the servers we will be going off line for a couple of hours on Tuesday.

    Sorry for the inconvenience
    Dismiss Notice

V6 2 cylinder misfire.

Roadrunner146 Jan 7, 2020

  1. Roadrunner146

    Roadrunner146 Active Member Team Moonlight Supercharged TFSI Owners Group Team V6 S-line owners group quattro Audi A6 Audi Avant Owner Group

    345
    80
    28
    Evening all.
    My S4 engined A6 has developed a high rev misfire on cylinder 5 and 6.
    It all seemed to start at the same time I ran the petrol tank lower than I have done before.
    If I take it up over 5k I get the mil light and very rough running. When I switch the engine off and re start all is fine.
    Since this started I have noticed a slight lack of power in very low revs compared to what I'm used to.
    So far I've swapped over the plugs and coils with no change. I've also fitted a new fuel filter and run a quarter tank of fuel with a bottle of Forte injector cleaner. Still no change.
    I've purchased a crank position sensor after reading other situations but not fitted it yet and if I'm honest I can't see it fixing the problem.
    A friend mentioned about a fuel tank pick up strainer being partially blocked. Does anyone know if the pump has this.
    I've also read that because it's 5 and 6 these are the last 2 cylinders on the fuel delivery strengthening the fuel starvation theory.
    I don't have VCDS but use the Torque app which has lots of which craft things on it that I've never used before.
    Any advice greatly appreciated before I spend vast amounts of money on the wrong parts.
    Thanks
    Brad.
     
  2. Avatar

    snack-media
    Advertisement


  3. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    31,219
    2,188
    113
    Maybe the lift pump has an issue, maybe it's drawn up **** from the tank bottom.

    Could try flushing the lines incase of debris partially blocking & check the lift pump.
     
  4. Roadrunner146

    Roadrunner146 Active Member Team Moonlight Supercharged TFSI Owners Group Team V6 S-line owners group quattro Audi A6 Audi Avant Owner Group

    345
    80
    28
    By the lift pump are you describing the in tank pump because that is my next job to look at. Would there be a basic filter on it.
     
  5. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    31,219
    2,188
    113
    Yeah it's it's usually under the rear seats, if it's a quattro it has 2, 1 each side of the prop.
     
  6. Roadrunner146

    Roadrunner146 Active Member Team Moonlight Supercharged TFSI Owners Group Team V6 S-line owners group quattro Audi A6 Audi Avant Owner Group

    345
    80
    28
    Thanks.
    When I removed the old fuel filter the petrol that came out was brown.
     
  7. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    31,219
    2,188
    113
    Brown, urmmmm that's not good, remove pumps & check the state of the tank.
     
  8. Roadrunner146

    Roadrunner146 Active Member Team Moonlight Supercharged TFSI Owners Group Team V6 S-line owners group quattro Audi A6 Audi Avant Owner Group

    345
    80
    28
    :salute:
     
  9. Roadrunner146

    Roadrunner146 Active Member Team Moonlight Supercharged TFSI Owners Group Team V6 S-line owners group quattro Audi A6 Audi Avant Owner Group

    345
    80
    28
    Removed pump. Fairly straightforward job. But you can't take it apart.
    I could see that it looked a little grubby in bottom so I released the pump from the housing and soaked it in fuel line cleaner for an hour. It cleaned it all up fine. Put it all back and it still misfires when reaching the high revs.
    Tank was fairly clean to from what I could see.
    One thing I've noticed is that the fault will not happen until the engine gets warm and revs fine when luke warm.
    Cylinder 4 has tripped also so it seems the whole passenger side bank is affected only.
     
  10. PenttisHSR

    PenttisHSR Active Member Audi S4 Audi Avant Owner Group Manual

    145
    48
    28
    How's your coolant level?
    Not leaking from the intercooler in that bank I hope.
     
  11. Roadrunner146

    Roadrunner146 Active Member Team Moonlight Supercharged TFSI Owners Group Team V6 S-line owners group quattro Audi A6 Audi Avant Owner Group

    345
    80
    28
    Haven't checked that. But wont I have had a warning light?
     
  12. Avatar

    snack-media
    Advertisement


  13. Roadrunner146

    Roadrunner146 Active Member Team Moonlight Supercharged TFSI Owners Group Team V6 S-line owners group quattro Audi A6 Audi Avant Owner Group

    345
    80
    28
    Coolant levels are fine. But the TPMS is now malfunctioning.
     
  14. Roadrunner146

    Roadrunner146 Active Member Team Moonlight Supercharged TFSI Owners Group Team V6 S-line owners group quattro Audi A6 Audi Avant Owner Group

    345
    80
    28
    It looks as though my catalytic converter has gone.
    Driving yesterday started to be lumpy on steady driving then cleared. Tried to force a misfire 3 times and all was good.
    This coincided with a rattle coming from under the car passenger side.
    Anyone have any opinions regarding a cheaper fix rather than paying Audi £1100 just for the part.
     
  15. PenttisHSR

    PenttisHSR Active Member Audi S4 Audi Avant Owner Group Manual

    145
    48
    28
  16. Roadrunner146

    Roadrunner146 Active Member Team Moonlight Supercharged TFSI Owners Group Team V6 S-line owners group quattro Audi A6 Audi Avant Owner Group

    345
    80
    28
    I've just checked the tail pipe and there is what looks like hard ash loose at the end.
    I took my cat off the other weekend expecting to find a slightly damaged innards. Then I was going to smash the rest out. On inspection it was as clean as a whistle inside, just an empty shell.
    So plan is to run as is for time being. Then test it at a friendly garage to see if it will pass mot. If not , fit a cheap aftermarket one further down the pipe for ease of access.
    Regards
    Brad
     
  17. PenttisHSR

    PenttisHSR Active Member Audi S4 Audi Avant Owner Group Manual

    145
    48
    28
    At the MOT, get the Tester to put the emissons sampling pipe up the "good" side (ie the one which still has an intact cat).
     
  18. Roadrunner146

    Roadrunner146 Active Member Team Moonlight Supercharged TFSI Owners Group Team V6 S-line owners group quattro Audi A6 Audi Avant Owner Group

    345
    80
    28
    Like it.:thumbs up:
     
  19. Roadrunner146

    Roadrunner146 Active Member Team Moonlight Supercharged TFSI Owners Group Team V6 S-line owners group quattro Audi A6 Audi Avant Owner Group

    345
    80
    28
    Does anyone know why I would have less power as soon as the engine gets close to operating temp.
    When the engine is cold it feels more responsive and definitely runs better.
    Ive swapped out the lambda sensor post cat on bank 2 after clearing out the cat. The wires where getting damaged.
    Due to an app telling me it would fail emissions. It says I have a Secondary air system problem but I get no fault codes.
    Would this be linked to the first issue.
    Regards
    Brad
     

Share This Page

Do Not Sell My Personal Information