Turbo/Engine "rattle"?!

18TS

Registered User
Ok... Need some serious help - The other day i started my car up and could hear kinda like a squeeking belt from the engine, so opened the bonnet to hear nothing. Then to check i just revved the engine a bit from the engine bay, but when i let off the throttle i could hear a kind of vibrating/knocking this was in time with the engine (sounded a bit like if you have a sander turned on and touch it gently on a solid piece of wood) then when the revvs dropped a bit it stopped but did it again and again each time i revved it... after it had warmed up after a short drive to the mechanic - there was no sound at all but later when it had cooled i started it up and checked... and sure enough... there it is again.

I'm not sure if it's the turbo buggered or something far worse! It's difficult to figure out where the noise is coming from. It kinda sounds like it's to the right of the engine but also sounds like it's down the back of it...

Any ideas? Cheers!
 

abdus

Top Gear
VCDS Map User
secondary air pump?

it does it only when cold? and the revs are about 1k? it stops and revs settle to 800-900?
 

18TS

Registered User
abdus said:
secondary air pump?

it does it only when cold? and the revs are about 1k? it stops and revs settle to 800-900?

it does it whatever the rev range though the higher it is the worse it sounds but doesn't seem to do it for any longer, it's as soon as they start to drop.

don't think its the manifolds as it's kicking out a bit of blue smoke at the same time - not loads its fairly difficult to see but it still shouldn't be there... ******* Audi!!!:confused:
 

LaSarthe&Back

Registered User
For a start, blue smoke is Oil being burnt. You need to find out what this it asap. It may be your turbo on the way out, the seals only patially failing at the moment. This may not be the only cause however.

abdus said:
secondary air pump?

it does it only when cold? and the revs are about 1k? it stops and revs settle to 800-900?

AGU's (I assume it's AGU!) don't have a secondary air pump. Don't know why!


dummi said:
not the exhaust manifold loose?

It would sound like a tank if it was loose or blown. If you have ever heard an un muffled engine you'll know what it sounds like.

I had something similar on mine (AGU also*) but I could only hear it when I drove down streets with buildings close to the road and could hear the sound reflect off walls. It only happened when letting off throttle. It turned out to be a heat shield which I had moved when I changed my turbo.

Have you had ANY work done on the car?

You may need to have someone rev it while you or someone else looks and listens for where it originates.

Good luck and HTH.

Cheers
Andy
 
Top