Tuning box fitting help

W

Wifeb4Life

Guest
Well I've installed and removed my spider tuning boxes numerous times on both my old Giulietta and Fiesta with no issues, however ive nearly snapped 2 fingers and tried for 40 mins trying to fit a box to the 3.0 biTDI and had too give up.

I managed to get the boost pressure sensor connected in seconds however could i'ell get the second sensor out, normally theres either a platic tab you pull outto release the sensor or you squeeze a tab, however how do you releasethe attached sensor?
 

Attachments

  • 20170217_172855.jpg
    20170217_172855.jpg
    231.6 KB · Views: 143
  • 20170217_172906.jpg
    20170217_172906.jpg
    214.1 KB · Views: 96
Last edited by a moderator:

Jcdub

JCDUB
If you put your finger in the rectangular shaped section in the sensor and pull it update it should release, if not press down on the sensor with your free hand then try reloading the clip art the same time. Hopefully this works for you..
 
W

Wifeb4Life

Guest
Okay thanks I'll give it a second attempt today, the thing thats worrying me about being too forceful is if i am pulling too hard when the sensor releases, the wire loom is attatched to another sensor very close by and just wrapped in some tape so i don't want to yank that and snap the wiring.

Really want to get this box in as they greatly improved my last two cars.
 

Jcdub

JCDUB
I've got one fitted to my 3.0 204ps A6. Pretty happy with it.
I'd say just use your thumb to fit into the rectangular area and push down on the sensor, then pull on the tab and sensor at the same time. It should come free...
 
W

Wifeb4Life

Guest
Thanks glad you are enjoying your box, did you have any issues installing yours?

Im assuming this is the fuel rail sensor anyway.
 

Jcdub

JCDUB
No issues myself apart from deciding what the best route was for running the loom while looking neat and tidy . Worked out well in the end. I can take a pic this afternoon if your struggling to get everything routed neat and tidy ,
 
W

Wifeb4Life

Guest
Thanks matey, I tried again today, luckily it was after a good journey out so the engine bay was really hot and had made the plastic sensor slightly squidgy and it made it much easier to remove first time in 5 seconds lol.

Just push your finger in the square hole as hard as you can and pull the sensor up and out.

So much more top end pull when you want it and so much torque for low speed cruising, it's just so easy too drive and floor haha
 

Jcdub

JCDUB
Glad you got it sorted.
What settings are you running it in at the moment? Have you tried different settings?
 
W

Wifeb4Life

Guest
I did a 100 mile drive since fitting, did about 20 miles in eco mode never going over 3000rpm which is my usual run in process.

Then switched it to setting 3 too see how it feels for a 50 miles which was a great increase you could feel in most situations in drive, however if you use sport more and like high end power the 30 miles back in race mode was much more fun. However setting 3 or 4 will probably be better for most daily driving so I may put it back.

Luckily I have the iMode spider box so with the app on my phone I can change the setting on the fly depending on what I need.
 

Jcdub

JCDUB
Sounds like a good unit. I've got the DTUK crdt+ I've been running it on 1 +1 fit the last while but changed it to 3 +1 and file a delay between the pedal and the response, so just changed it to 2 +1 and see how it goes.
 
W

Wifeb4Life

Guest
Yeah heard good things about the DTUK boxes and had concidered them, Spider boxes have worked great on my last few cars so stuck with them again.

Need to get on the dyno again but both my other cars had roughly a 20% bhp increase and just over 20% torque increase so I'm hoping for 360-370bhp & 780-790nm of torque. Certainly feels about that much of an increase.
 

Aly

Registered User
I've got a DTUK box in my BiTDi also! Currently on prog 2.3 atm... Did have it on 3.1 but my engine light came on! Been upping it slowly maybe every fortnight. Quite like it... Goes well with the Kufatec Sound Booster Pro

Sent from my SM-G935F using Tapatalk
 
W

Wifeb4Life

Guest
Ive had that putting the box on full whack strait away thats why i do 20 miles on the lowest setting then its usually fine to put it on any setting.

How much is the sound booster?
 

Jcdub

JCDUB
I've got a DTUK box in my BiTDi also! Currently on prog 2.3 atm... Did have it on 3.1 but my engine light came on! Been upping it slowly maybe every fortnight. Quite like it... Goes well with the Kufatec Sound Booster Pro

Sent from my SM-G935F using Tapatalk

I like 3 +1 personally. I'd say I'll settle on either prog 2 +1 or prog 1+2
 

Aly

Registered User
Ive had that putting the box on full whack strait away thats why i do 20 miles on the lowest setting then its usually fine to put it on any setting.

How much is the sound booster?
It's around £230

Sent from my SM-G935F using Tapatalk
 
Top