1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Traction & ABS lights illuminate when Haldex engages

pilla Aug 3, 2018

  1. pilla

    pilla Old ones are the best ones

    281
    35
    28
    Hi guys, having more issues with the S3 - Had to limp 20 miles home on 3 cylinders on Wednesday, have sorted that issue now, but its still registering a misfire on cylinder 1, i think the cylinder shut down for whatever reason. I Do still have a cyl 1 misfire code and also a camshaft over advancement code and a sligt misfire blow 1500rpm, but car goes well - However, another fault has arisen, If im launching the car to a quick getaway, and the haldex must engage, I get the traction/abs/handbrake light all light up and stay lit until i cycle the ignition, No codes showing for this fault, (not on the cheapo reader anyway)

    Any ideas! :) Thanks in advance. Pilla.
     
  2. Avatar

    snack-media
    Advertisement


  3. Daveyonthemove

    Daveyonthemove Well-Known Member VCDS Map User

    1,829
    624
    113
    If you have a misfire, camshaft error and issue with Cyl 1, why the hell are you doing 'quick getaways' in it?
    Get it looked at before you ruin it.
     
    pilla, leshkin and samuelh_888 like this.
  4. ch1z64

    ch1z64 C'mon you's bhoy's in Green Silver Supporter VCDS Map User

    4,203
    930
    113
    In reply to why ur getting all these lights, your cars wheels are slipping as it is trying to get traction not a good practice mate as u can cause urself a load off grief as you are starting to find out :thumbs up:
     
    pilla and Daveyonthemove like this.
  5. leshkin

    leshkin Hold my beer... VCDS Map User

    3,032
    1,887
    113
    Basic OBD readers don't support all canbus modules. For that you need an Audi dealer, VCDS or OBDeleven. You are likely having some form of haldex/abs failure and there will be codes stored there that you can't see.

    I'd also agree with previous coments, get your car checked by someone who knows what they are doing before launching it if you want to avoid costly repairs later.
     
    pilla and Daveyonthemove like this.
  6. mechanic69

    mechanic69 Registered User Gold Supporter VCDS Map User

    2,066
    784
    113
    Sounds like a cam timing chain issue is there a rattling noise on the right side of the engine?

    Also sounds like the haldex pump has given up, would need to change pump filter and oil and all will be good again


    Sent from my iPad using Tapatalk
     
    pilla likes this.
  7. pilla

    pilla Old ones are the best ones

    281
    35
    28
    I have just had the stethoscope on the right side of the engine, there is a noise coming from that area, only when coming off the throttle at idle, very low revs, its not there during driving or anywhere else in the rev range. Its most notable at the thin square shaped end plate, there is also an oil leak from there. Thanks for the sound advice, the Haldex issue can wait, what do you recommend i do, remove the cover and inspect it, and is it ok to use? Cheers.
     
  8. mechanic69

    mechanic69 Registered User Gold Supporter VCDS Map User

    2,066
    784
    113
    The cam chain is on the right side next to the battery, I would look at videos of the noise to see if that is you problem. If the cams misalign it’s valves and pistons meeting and game over for the engine so I would be very cautious.

    The haldex is relatively cheap around 300 quid if you do it yourself, that’s pump oil and filter a garage shouldn’t charge much more than a 100 to fix it. If you don’t just means you got two wheel drive and a lot of scary wheel spin


    Sent from my iPad using Tapatalk
     
  9. pilla

    pilla Old ones are the best ones

    281
    35
    28
    Hiya. The haldex is certainly working still. There is no wheelspin under acceleration. Even in damp conditions.

    What i have noticed this evening. Is the noise from the camchain area only happens when the engine is cold and also right after startup on a warm engine. It seems to me that it subsides when the oil gets up and about. Because once driving, it does not make the noise anymore.
     
  10. pilla

    pilla Old ones are the best ones

    281
    35
    28
    Hi mate, i have got the camchain exposed, Im going to start a new thread, if you wouldnt mind having a look and letting me know what you think. Thanks.
     
  11. pilla

    pilla Old ones are the best ones

    281
    35
    28
    Quick getaways and a quicker sale. Will stick to the old models with less "electronics"
     

Share This Page

Do Not Sell My Personal Information