1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

strut top mounts issues?

glenandem Apr 4, 2020

  1. glenandem

    glenandem Active Member

    881
    87
    28
    a4 b8 2010 avant had a slight knocking at low speeds on one side and seems to be both sides now, ive had it jacked up and pry bar in all the suspension joints and theyall seem fine, i can not find anything dodgy at all but now thinking strut top mounts, anyone else replaced theyre's or know if its a known issue etc?
     
  2. Avatar

    snack-media
    Advertisement


  3. spartacus 68

    spartacus 68 Active Member

    543
    115
    43
    Have you checked top arms first? They tend to go first.
     
  4. glenandem

    glenandem Active Member

    881
    87
    28
    Yeah had a good look at those and no play and barely any cracks in them, I think I’m gonna get my Mrs to drive it round a car park with me sat in engine bay so I can pin point it lol as I’m stuck between top mounts and bottom rear arms as I can’t see the bushes in those from underneath
     
  5. jakm15

    jakm15 Active Member

    190
    67
    28
    If it's done 80k plus controls arms usually need replacing.

    Sent from my moto e5 plus using Tapatalk
     
    glenandem likes this.
  6. CHEZ

    CHEZ moderately amusing Supporter

    7,376
    1,670
    113
    [QUOTE="glenandem, post: 3565205, member: 71303"I think I’m gonna get my Mrs to drive it round a car park with me sat in engine bay so I can pin point it lol [/QUOTE]

    I would love to see that video please!
     
    Pie-eyedpiper, jdp1962 and glenandem like this.
  7. jakm15

    jakm15 Active Member

    190
    67
    28
    Have you located your knocking noise? The lower rear arm is the usual culprit for a creaking and sometimes knocking noise.

    Sent from my moto e5 plus using Tapatalk
     
  8. glenandem

    glenandem Active Member

    881
    87
    28
    Hi pal I suspect it’s the lower rear arm too, I need to replace both bottom arms anyway as the front lower arm bushes look fairly worn!
     
  9. Roy Clarke 85

    Roy Clarke 85 New Member

    10
    5
    3
    I had this problem on my s4,I did replace all the arms as one bush had failed,after replacing them it still had a knock and was getting worst and took ages to locate it,it was the anti roll bar bushes,cost £6 and easy to replace,you could inspect yours as I did and they looked fine,but fixed the problem once replaced,someone told me to push a lolly pop stick in both the bushes to righting them up and see if it makes a difference then atleast you know if needs replacing,even then for £6 you aswell just do it mate,good luck
     
    All-rod and jakm15 like this.

Share This Page

Do Not Sell My Personal Information