Seat memory bug on the A6

psychopomp1

Registered User
Has anyone managed to get their dealer to fix the seat memory bug, whereby everytime you start the car, you always have to press seat memory buttons 1 or 2 to put the drivers seat into the last seat position. In other words, the car 'forgets' the last seat position after switching off the engine.
Cheers
 

pp2414

Member
Has anyone managed to get their dealer to fix the seat memory bug, whereby everytime you start the car, you always have to press seat memory buttons 1 or 2 to put the drivers seat into the last seat position. In other words, the car 'forgets' the last seat position after switching off the engine.
Cheers

Yes, got it sorted few months ago.
Had same issue. I think one of the mmi upgrades brought in this bug. It’s well know now and easy to fix with a software upgrade. Ask any Audi service centre for help.

Good luck


Sent from my iPhone using Tapatalk
 

psychopomp1

Registered User
Thanks bud, will give Highland Audi on buzz on Monday and see what they say.
 

enry68

Member
Sorry but it's NOT a bug. In the VC appear the windows with the phrase: Press and hold the button to restore the seat position. i suppore for safety it's required that a human set the position and not automatically. ;-)
 

pp2414

Member
Sorry but it's NOT a bug. In the VC appear the windows with the phrase: Press and hold the button to restore the seat position. i suppore for safety it's required that a human set the position and not automatically. ;-)

You need to read one more time mate.
We all know what you said.
But this is something to do with seat not remembering the last position...
So read before you write;)
Have a good one.


Sent from my iPhone using Tapatalk
 

MPTT

Registered User
They fixed mine a couple of months ago when it went in for the starter motor recall, software update.

It did the front camera fault again a few weeks ago though. Irritating car!
 

enry68

Member
You need to read one more time mate.
We all know what you said.
But this is something to do with seat not remembering the last position...
So read before you write;)
Have a good one.


Sent from my iPhone using Tapatalk
Sorry my friend, i think to have read it well. My car has seats with memory and when I enter in my car I have to keep pressed the Memory 1 to restore my position all the times. Where I'm in wrong ? :)
Enrico
 

psychopomp1

Registered User
Sorry my friend, i think to have read it well. My car has seats with memory and when I enter in my car I have to keep pressed the Memory 1 to restore my position all the times. Where I'm in wrong ? :)
Enrico
Then I’m afraid your A6 also has this bug. When my car was brand new, upon starting the engine the seat automatically went into the last driving position. But a MMI update last August messed this up.

If you are the ONLY driver then you should not need to press seat memory button # 1 or 2 every time you start the car - the memory buttons are intended for restoring seat position(s) if the seat has deliberately had its position changed.
 

enry68

Member
Then I’m afraid your A6 also has this bug. When my car was brand new, upon starting the engine the seat automatically went into the last driving position. But a MMI update last August messed this up.

If you are the ONLY driver then you should not need to press seat memory button # 1 or 2 every time you start the car - the memory buttons are intended for restoring seat position(s) if the seat has deliberately had its position changed.
Thank you, understood. In my opinion I suppose it is not a bug even if in the past it has worked as you explained. I've taken my A6 last month and it has always worked like this. My be it is a "new feature" even of I can understood that for you is now a regression.

Enrico
 

psychopomp1

Registered User
Thank you, understood. In my opinion I suppose it is not a bug even if in the past it has worked as you explained. I've taken my A6 last month and it has always worked like this. My be it is a "new feature" even of I can understood that for you is now a regression.

Enrico
Trust me, you should NOT have to press the seat memory button every time you start your car. I suggest you ask your dealer if there’s any software updates available for your car.
 

enry68

Member
Trust me, you should NOT have to press the seat memory button every time you start your car. I suggest you ask your dealer if there’s any software updates available for your car.
Thank you, I can ask to him next time I will go to my dealer.

However if it were a bug, the display would not clearly write to press and hold the button. Do not you think ?
 

pp2414

Member
Thank you, I can ask to him next time I will go to my dealer.

However if it were a bug, the display would not clearly write to press and hold the button. Do not you think ?

Believe me it is a bug.
To double check this you can switch comfort entry seat function off and then you will see that the seat still moves funny way when you open the door. It may not happen each time but in my case was happening 2-3 times out of 10 openings.
I think Audi called this ‘memory seat misalignment error’
You need to push Audi to fix it otherwise they won’t do it for you..


Sent from my iPhone using Tapatalk
 

enry68

Member
Hello frienfs, YOU have right. Today my car has completely restored the seat position automatically immediately after I have pressed the START-STOP pushbutton.

Today the beahaviour has been as espected, fisrt time in a month for me.
 

psychopomp1

Registered User
AAAARRGHHHHH! Car went into dealer (Highland Audi) today to get seat memory bug fixed but technician says its normal to have to press memory button 1 or 2 to get seats into position every time I start the car...WTF??!! It certainly wasn't happening when the car was brand new, only started happening after the last MMI update (Summer 2020)

To those who are no longer getting this bug, pleeeeeease could you post a pic of the software version of your MMI? If its a newer version than mine, then i have solid proof that my car is NOT running the latest version. This is what my car is showing at present:



Many thanks!
 

elan2s

Registered User
The software version displayed by the MMI system is not the software version for the whole car and all the systems, just the MMI system. I suspect the software for the seats is in the Comfort Contriol unit and that will have its own software. It may be that is identifiable if you have access to VCDS
 

psychopomp1

Registered User
Thanks I’ll plug in obd11 dongle and try to get further software versions.
cheers
 

enry68

Member
The SW version of the seats is in the Seat ECU 0x36. But I think that more then one ECU is envolved in this behaviour. It may be the 36, but also the 09 or the 5f or again the 46 .... difficult to say.

May be useful for all to display each sw/fw version for all ecus.... but it's a big work
 

psychopomp1

Registered User
@pp2414
@MPTT

Guys would you be kind enough to share the MMI software version on your cars? The issue started happening after the MMI software was updated last August so it may or may not be related to that.

Cheers :)
 

elan2s

Registered User
@pp2414
@MPTT

Guys would you be kind enough to share the MMI software version on your cars? The issue started happening after the MMI software was updated last August so it may or may not be related to that.

Cheers :)
You will need it from someone who has a car with the same MMI system as yours. I am assuming your car has MIB-2 (2 USB-A ports and SD Card reader) rather than MIB-3 as per new cars (2 USB-C ports only). Also does you car have Tech Pack or not, as that will likely change the MMI software used?
 

pp2414

Member
You will need it from someone who has a car with the same MMI system as yours. I am assuming your car has MIB-2 (2 USB-A ports and SD Card reader) rather than MIB-3 as per new cars (2 USB-C ports only). Also does you car have Tech Pack or not, as that will likely change the MMI software used?

Here we go
MIB-2
01a5fec2fd666a8c6dad0d249e94ce9b.jpg



Sent from my iPhone using Tapatalk
 

psychopomp1

Registered User
Here we go
MIB-2
01a5fec2fd666a8c6dad0d249e94ce9b.jpg



Sent from my iPhone using Tapatalk
Thanks buddy, much appreciated :thumbs up:

So you have the same MMI software version as mine (mine is also MIB-2, no tech pack). Which points to a different software update. If its not too much trouble, could you ask your dealer which software component of the car they changed which fixed the seat memory bug and to what version? I will then pass this info onto my dealer, because as things stand they've fobbed me off saying that the memory seats are performing as they should which we both know is utter rubbish.
Thank you so much mate, you're my last hope of getting this fixed!
 

elan2s

Registered User
A question for all of you: my car has 2 USB + SD + SIM . Which MIB 2 or 3 ? Thank you

MIB-2


Sent from my iPad using Tapatalk
 
Top