1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Sat Nav voice command issue....

TonyJ999 Jan 23, 2020

  1. TonyJ999

    TonyJ999 New Member

    12
    2
    3
    Good evening first time poster here, and just hoping that I’m putting this in the correct place!

    I recently purchased a late 2014 silver S3, having re-joined the Audi ranks after many years of Ford Fiesta ownership, the joys of having families and no money! Anyway, before the kids arrived I was lucky enough over the years to have owned an S4, A6 2.7T and an A4 1.8T Quattro so I’ve always had a thing for the quick Audis, and now that the opportunity arose I decided to go for it again.

    A lovely one owner car, at a very reasonable price was secured, but when I got it I knew it was missing one or two little “extras” that had been present on some of my previous vehicles. I set about looking at ways to upgrade the new beast and after an extensive dig around the internet I found people who could do the sort of stuff I needed. I embarked on some retrofit upgrades; powered mirrors were added as was a reversing camera and then my main gripe when I got the car, the pop up MMI set up.

    Initially the car had come with the bog standard 5.8” screen and basic configuration that has now been upgraded to a 7” unit with built in SatNav, Carplay/Android Auto connections etc that came from an RS3.

    And with that, I come to the issue I have. I can’t fault the install, absolutely impeccably done and overall it works beautifully. The DAB radio, multi media playback, phone calls all work fine. So does the SatNav – to a point.

    My problem is that it does not have any voice commands when it is in use. Bizarre as it seems it appears not to have a voice. I’ve looked through all the settings and they are enabled (see pictures), the music whether it is on the radio or SD Card plays when the SatNav is in use, but there are simply no commands coming from the unit! Has anyone heard of this before or have any thoughts or ideas? It’s almost like they have been deleted from the hard drive! Apart from that the SatNav works fine, the directions, maps etc all flawless.

    As a final caveat, and I don’t know if it is connected, but I noticed today that when I try to activate the voice command button on the steering wheel it flashes up a “please wait...” command on the screen but then does nothing. The “iNav” button also appears to have no function.

    I have tried searching through the internet but currently a bit stumped......


    01.jpg 02.jpg
     

    Attached Files:

    • 03.jpg
      03.jpg
      File size:
      146.1 KB
      Views:
      49
    • 05.jpg
      05.jpg
      File size:
      148.9 KB
      Views:
      51
    • 06.jpg
      06.jpg
      File size:
      213.3 KB
      Views:
      50
    • 07.jpg
      07.jpg
      File size:
      168.6 KB
      Views:
      47
    • 08.jpg
      08.jpg
      File size:
      143.5 KB
      Views:
      49
  2. Avatar

    snack-media
    Advertisement


  3. jrumball

    jrumball Well-Known Member Sportback Audi A3 etron Cosmos Blue

    627
    324
    63
    Is it as simple as the volume is turned down for the voice commands ? When you initiate a command withe the key on the steering wheel turn the volume up with the dial on the center console ....
     
  4. TonyJ999

    TonyJ999 New Member

    12
    2
    3

    Thanks for the advice but unfortunately not. All I get when I do that is an adjustment in the sound of the entertainment system....
     
  5. JohnM100

    JohnM100 Well-Known Member Gold Supporter VCDS Map User Team Navarra Audi S3 Black Edition

    1,326
    628
    113
    Does the computer voice work for other commands eg dialling a person in your contacts list (assuming you have paired your phone)?

    There is a voice training module in the settings menu.

    The intent here is to see if it says anything at all.

    Also, you might consider deleting your first pic if that is showing your home address.
     
  6. TonyJ999

    TonyJ999 New Member

    12
    2
    3
    No, it does not activate when using the phone and it appears that this option is greyed out on the options list. Assuming I am looking in the correct place!

    Good call on the picture, I had two and loaded the wrong one... :flushed: Any idea how you amend it as I can't seem to find it the option to do so.......?
     
  7. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    31,101
    2,160
    113
    Ask a mod to edit as it's time dependent on self editing.
     
    TonyJ999 likes this.
  8. Dubjam

    Dubjam Active Member Team Daytona VCDS Map User S tronic saloon quattro Audi A3 Black Edition

    593
    156
    43
    I presume this is a MIB2 upgrade from MIB1?

    I've been investigating this recently as I am debating doing the change also.

    Question - I dont know if this is connected but do you have the MIB1 buttons/wheel in the centre console (RED lights with four buttons either side of wheel with TOUCH) or the MIB2 one (white lights with two buttons either side of the wheel). From research he MIB1 centre console unit does seem to have issues with certain elements of the MIB2 Satnav functions, it may or may not be connected but worth mentioning.

    Also each 'cracked' MIB2 unit needs to be coded. some firms will code it to your VIN, some do it manually once installed, it may have been missed somewhere..
     
  9. TonyJ999

    TonyJ999 New Member

    12
    2
    3
    The fitting included upgrading the centre console as well (see pic).

    The guy has done a few of these so knows his stuff. OK he is not cheap, but I can't fault the workmanship at all and I didn't mind paying if the job is done right! I believe the units are re-coded to my vehicle and as I said the other functions work flawlessly. However, my suspicions are now growing that there is something wrong with that process.

    Unfortunately I live a couple of hours away from them so it's not something I can just pop down and sort out although I suspect I might have to eventually.....
     

    Attached Files:

    • 04.jpg
      04.jpg
      File size:
      206.8 KB
      Views:
      31
  10. Dubjam

    Dubjam Active Member Team Daytona VCDS Map User S tronic saloon quattro Audi A3 Black Edition

    593
    156
    43
    So you have white LEDs in the centre bit and Red everywhere else? or have the white ones been replaced with red? I think only Hazzydayz offers that service, although I can't imagine its that complicated to do.

    To be fair after phoning a few retrofitters Hazzydayz where the ones who I felt like actually wanted my business and didn't mind spending half an hour telling me about the pro's and con's and costs of what I was looking at etc. Some of the others either just didn't reply to emails or sounded like I was trying to buy their wife for 50p on the phone, so I would probably use them if it came down to it, but they'd need to do something about their extortionate pricing first. Still, they never returned my call when they said they would so...

    The company who seems to do a lot of these cracked MIB coding is Vag-Tec in Doncaster, I contacted them myself I got some really crappy info from them regarding what I would need for install (as a complete install, they omitted a lot of stuff initially, didn't instil faith thats for sure), so maybe they are better at the software side of things over actual fitting the entire kit.

    I am sure it's probably something simple, but I'd be interested to hear if you get to the bottom of it. Some of these retrofitters can connect wireless to your diagnostics port, so it may be able to be checked remotely at first?
     
  11. TonyJ999

    TonyJ999 New Member

    12
    2
    3
    Yes white and red elsewhere.


    Hazzydayz was one of the sites I originally bookmarked but I was put off by those prices, especially when adding VAT on top of them! I basically paid their net price for the work I had done and in some of the upgrades less than their quoted figures. I think that if no-one else has any solutions on here I will go back to them, as my original thought was a possible coding issue.


    As a slight diversion I forgot to mention that Android Auto also won’t fire up, but Apple Carplay does and works fine. It might be linked but I suspect that one lies with a Google issue and not the fit.... :sunglasses:
     
  12. Avatar

    snack-media
    Advertisement


  13. AlS3BE

    AlS3BE Well-Known Member

    3,029
    1,732
    113
    There’s a setting in the audio setting for voice command. Can’t remember exact place for it but near the bass/treble settings.
    Next maybe try a factory reset, not sure what effect that has on a hacked unit though.
     
    TonyJ999 likes this.
  14. Dubjam

    Dubjam Active Member Team Daytona VCDS Map User S tronic saloon quattro Audi A3 Black Edition

    593
    156
    43
    How do you cope with the mismatch of button colours?! that would make me insane, I've been looking how complicated/costly it would be to change to the white ones if . I go for the swap..but it includes a steering wheel, putting a couple of hundred quid on the bill. Luckily for me I have the Tech pack with the bigger screen, so all i would be gaining is Carplay.

    Yes HD are just monstrous expensive, to be honest, other retrofitters now use them as a net price cost which they 'match', which I feel can often still be pricey for some of the jobs to. Everyone has to make a living I know but...

    Android is software so it won't be Google I would imagine, it is starting to sound like you have some software issues, but if you've followed everyones advice on here for the sound settings then i guess the only option is a return trip sadly. You could pay someone closer to you to look at the issue, but it might end up being more expensive than a tank of juice.
     
    TonyJ999 likes this.
  15. TonyJ999

    TonyJ999 New Member

    12
    2
    3

    Yep I have seen that but it has no effect, there is simply no option to adjust any other sound setting rather than the entertainment system. I have been staring at that factory reset option but like you I'm not entirely sure that would solve things and I would simply end up with nothing working!
     
  16. Dubjam

    Dubjam Active Member Team Daytona VCDS Map User S tronic saloon quattro Audi A3 Black Edition

    593
    156
    43
    Have you actually called your fitter and asked them?
     
    TonyJ999 likes this.
  17. TonyJ999

    TonyJ999 New Member

    12
    2
    3
    Ha, I sort of know what you mean but it does not worry me that much. If I could somehow change the gear selectors to white it might help, but I have not looked into it if I’m honest.

    With regards to the retro fitters, I had thought of doing it myself and getting the parts independently but once you start to cost it up some of them are not charging that much more to fit and source, taking into account a “profit mark up”. Most of the parts I could find were very expensive, and there is always the Wild West that is eBay of course, but not even I was brave enough to go down that route!!!!

    Going off track a bit the Android thing is an odd one as if it was something to do with the unit I would expect its equivalent, Apple Carplay not to work. However, that works flawlessly. Just plug it in and it fires up and performs with no issue. At the moment I’m trying to find someone with a newish Audi to try it in their car but I have not come across anyone as of yet although I stalk the supermarket car park when I go shopping...:tearsofjoy::tearsofjoy:
     
  18. TonyJ999

    TonyJ999 New Member

    12
    2
    3
    Yes I have, and he is awaiting a reply from his "source". I just thought I would also have a look around myself to see if anyone had any ideas. Obviously I will keep this thread updated as/if/when I get this resolved....:icon thumright:
     
  19. Dubjam

    Dubjam Active Member Team Daytona VCDS Map User S tronic saloon quattro Audi A3 Black Edition

    593
    156
    43
    Just change the LED's in the new console unit..or maybe you can even reverse the polarity like the cup holder and BO lights, they go red then :)

    At least with eBay/PayPal you get a six month warranty, so if something dosent work, then there is always a come back. I don't have to much of an issue buying from ebay but generally stick to breakers as at least its not been ****** around with, just taken from the car. Retrofitters get them from all the same places, there is no golden Audi mine anywhere :)

    Give your installer a call and see what they say, it might be something obvious to them? Im really thinking the MIB unit has a software issue.
     
    TonyJ999 likes this.
  20. Dubjam

    Dubjam Active Member Team Daytona VCDS Map User S tronic saloon quattro Audi A3 Black Edition

    593
    156
    43
    Sounds like it could be a Vag-Tec MIB unit..but yes please, as this thread is definitely making me think twice about doing the swap!
     
    TonyJ999 likes this.
  21. TonyJ999

    TonyJ999 New Member

    12
    2
    3
    Mmm I hadn’t thought of that. May have to explore the option as long as it does not cost me hundreds! I did have a quote for the “sweeping indicators” at the same time and nearly feel through the floor at that one so I passed. I’ll call him again next week for advice and will certainly keep this thread active.

    Do I regret it? Not one bit to be fair, the whole screen thing is so much better than what it was and I can live without Android Auto but would like my voices for the SatNav.

    As someone suggested earlier I did some digging and just found a setting within the MMI this morning as per the attached picture.

    Definitely pushing me along the bad software route now....


    09.jpg
     
  22. Dubjam

    Dubjam Active Member Team Daytona VCDS Map User S tronic saloon quattro Audi A3 Black Edition

    593
    156
    43
    The 5.8" low res screen is atrocious, I can completely understand your joy when you got it changed! Its like something from a Commodore 64 in the 80's.

    If you read something like this, it makes me wonder if your MIB unit came out of a Cabriolet?

    https://www.audi-sport.net/xf/threads/voice-activation-disabled-in-cabriolet.220172/
     
    TonyJ999 likes this.
  23. TonyJ999

    TonyJ999 New Member

    12
    2
    3

    Oh that's a good find. I was under the impression that the unit came from an RS3 but I could be mistaken. I'll pursue this next week and see what he says.....
     
  24. TonyJ999

    TonyJ999 New Member

    12
    2
    3
    Just as a point of closure on this I made the journey back on Tuesday to the original fitter, and it was traced to a line of coding that needed altering. All good now and the SatNav is working as it should. Also got my voice commands back as well.... :icon thumright:
     
    Dubjam and JohnM100 like this.
  25. Dubjam

    Dubjam Active Member Team Daytona VCDS Map User S tronic saloon quattro Audi A3 Black Edition

    593
    156
    43
    Good news!

    Did your Android Auto begin working also?

    Now you just have to deal with those white LED's ;)
     
  26. TonyJ999

    TonyJ999 New Member

    12
    2
    3
    Afraid not.

    We came to the conclusion that bit requires some more work and I've left it with him. He did get the units in, as I think you suggested, but has now invested in the software to do it himself. He just needs a bit more time to get to grips with it, which is fine by me.

    As for the colour issue, he kindly swapped out the transmission selector to a white one and I'm currently sourcing the switch bank (which looks easy to swap) and the heater controls (which does not ) to change to white.

    White.jpg
     
  27. Dubjam

    Dubjam Active Member Team Daytona VCDS Map User S tronic saloon quattro Audi A3 Black Edition

    593
    156
    43
    Oh thats good news he is unlocking these system himself. Heard so many bad reports about Vag-tec, but they seem to be the place all these retrofitters go to to have them done, which is possibly where some of your issues rose from.

    Don't forget your steering wheel and headlamp switch for the LED swap as well! Even though white is definitely nicer, it would probably be easier and cheaper to swap the white LED's to Red ones in the old console.
     

Share This Page

Do Not Sell My Personal Information