1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Help Please Sat Nav issues

WozzaAK Jun 27, 2019

  1. WozzaAK

    WozzaAK Registered User

    218
    76
    28
    Hi guys I need some help. Who's the go to guy on this? The car is S4 B8 saloon.

    I'm currently trying to get the sat nav working which shows no satellites. It has a shark fin antenna which turns out has broken connections in headliner. I've stripped it back to c pillars & removed both fakra connections on either side. My plan was to use a hockey puck antenna. But once I removed the head unit (cd changer) I cannot see the fakra connection on stereo or the fakra connection on the loom anywhere.

    My system appears to be bang & olufson, cd changer, ami usb in glove, centre console with all the buttons & mmi screen, shark fin antenna with 2 connections. I'm not totally sure if some or all of these bits are original or have been retrofitted later. I've only had the car 2 weeks.

    I'd appreciate any help.

    Thanks
     
  2. Avatar

    snack-media
    Advertisement


  3. AudiLeon

    AudiLeon Well-Known Member VCDS Map User

    2,313
    214
    63
    Isn't the sat nav bit in the boot?
     
  4. WozzaAK

    WozzaAK Registered User

    218
    76
    28
    I ain't got a clue dude. I need to speak with someone who knows this setup. I can strip parts if necessary just need advice.
     
  5. wilco184

    wilco184 Registered User

    30
    20
    8
    Hi,

    This might sound like a daft fix but has the power to the head unit in the middle of the dash (where the SD/CD's go in) been disconnected at any point? I ask because I had the exact same issue and unplugging the Quadlock connector on the back of the unit and reconnecting sorted the issue for me.

    Thanks,

    Matt.
     
  6. JohnS3

    JohnS3 Registered User

    3,175
    46
    48
    The GPS connector on the back of the head unit is the blue Fakra. There is a universal colour code for Fakra connectors, GPS is blue.
     
  7. WozzaAK

    WozzaAK Registered User

    218
    76
    28
    I've disconnected the & reconnected a few times. I want to bypass the factory fakra connection but can only find the connection in the c pillar at the rear of car & no fakra connections at the front of car.
     
  8. WozzaAK

    WozzaAK Registered User

    218
    76
    28

    Yes I know but theres no fakra connection at the back of head unit. There is a shark fin antenna & fakra connections at the c pillar at the rear. This is whats confusing me, where is the fakra connection on the factory loom at the front & why does the cd changer not have a fakra connection on the back of head unit. It's possible that previous owner has tried to retrofit the mmi system & has not completed it.
     
  9. WozzaAK

    WozzaAK Registered User

    218
    76
    28
    I need to speak with someone who knows this system in & out. Anyone know the best person to speak to? Thanks for ur help guys
     

    Attached Files:

  10. Stonefish

    Stonefish Registered User

    251
    69
    28
    Do you know what system you have? It might be MMI 2G in which case the sat nav module is in the boot on the passenger side.
     
  11. WozzaAK

    WozzaAK Registered User

    218
    76
    28
    Hi I checked earlier & yes the sat nav module & multimedia player is in the boot. Will i find the fakra connection there? I want to bypass sharkfin antenna & use hockey puck as a temp fix just to get the nav up & running. Thanks
     
  12. Avatar

    snack-media
    Advertisement


  13. Stonefish

    Stonefish Registered User

    251
    69
    28
    yes, there should be a blue fakra connector on the back of the navigation module
     
  14. WozzaAK

    WozzaAK Registered User

    218
    76
    28
    Ok thanks a lot.

    By the way would u know where the single brown spade connection from behind climate control goes. I cant find anywhere it should connect. 20190629_183259.jpg
     
  15. Stonefish

    Stonefish Registered User

    251
    69
    28
    Probably the earth for the cd changer.
     
  16. WozzaAK

    WozzaAK Registered User

    218
    76
    28
    Ok will check the head unit. I bypassed the sat nav antenna & its all working now. But I must've loosened a connection on the B&0 system in the boot as all the bass has gone. Will check this later, thanks for ur help
     

Share This Page

Do Not Sell My Personal Information