S5 auto selector won't go into Park

ChrisH370

Registered User
Noticed today on my new S5 that the small P switch on the selector you press when parking no longer turns red, but the red P appears on the base R N D/S instead.
Does this indicate that the Park function is faulty and the car may run away on a slope so I should apply the electronic handbrake or is the switch light faulty and the Red on the selector means its still in Park?
 

Buck

Registered User
What does it say on your dashboard? Possibly it's just the selector indicator light not working correctly?

I would go by that. Also, when in park I'll always make sure the handbrake is on as an extra check.
 

DickiePhitt

Active Member
VCDS Map User
A sharp shove on brake pedal as you push red button to stop engine will put into Park and apply handbrake automatically (usually) except from reverse (I have found).
 

ChrisH370

Registered User
Brake pedal doesn't make any difference. I've also tried selecting the P button in R and D/S and it still goes to P on the base plate and the engine cuts, but no red light on in the small P switch.
The dash board confirms its in P and the transition feels locked.
 

Buck

Registered User
Good that it sounds like it is actually going into 'P' and just not showing it.

Time to book in with Audi then. Sounds like a faulty light in the selector.
 

ChrisH370

Registered User
Yes, it's showing P in red on the base plate too. I've called the M/ Tech at my dealer, not point in asking the sales staff.
 

Buck

Registered User
True. Hope it's a quick fix.
 

ChrisH370

Registered User
I cant find an online manual for the new S5 so dont know under what conditions the small red light is supposed to illuminate.
When I had a demo I got the impression this was always the only "Park" indicator light and there was nothing on the base plate.
Can someone check their car and let me know if the base plate "P" is lit red as well as the small button or only the button?
 

b0k

Registered User
Note that's for A5 auto not S5. Different auto transmission but I would have thought controls would most probably be the same
 

Buck

Registered User
Just in my car now...

My A5 has the white "P" lit up on the lever when I got into my car with the red "P" on the base plate.

When I press the "P" it lights up.
 

ChrisH370

Registered User
OK, that's like mine then. Am I imagining it or isn't the S5 selector lever P button supposed turn to a red?
 

ChrisH370

Registered User
Dealer service dept. called and confirmed the small P button never goes red, only the base plate.
Must be going senile!
 
Top